Illustrator 2019 direct selection not functioning properly

Community Beginner ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Is anybody else experiencing the direct selection tool not working at all in Illustrator 2019?

Several issues:

  • paths, anchor points, and handles are not selectable and only highlight on rollover
  • anchor points and handles are completely invisible unless you guess right
  • anchor points and handles are only moveable on click and drag in one action

It is rendering Illustrator useless to me at this point. And, yes, I have tried virtually every selection and anchor display preference combination. !

TOPICS
Tools

Views

14.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Nov 13, 2018 Nov 13, 2018
So it turns out that it was only this one legacy document (created in 18) that was the problem. This was the first document I opened after installing 19. I deleted preferences. I reset the workspace. I tried everything. I then opened a brand new document and found there was no problem. I opened another legacy document created in 18 and no problem with that one either. I then copied and pasted the elements from the problem document (luckily not a complex one) into a new document and it’s working ...

Likes

Translate

Translate
Adobe Community Professional ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

If you installed CC 2019 using the option to retain previous preferences and settings then it is possible that may be the problem. Try trashing your Illustrator preferences and see if things improve.

To do so:

For Macintosh Users: The User Library folder in which Illustrator’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that Illustrator is closed and click on the desktop to launch a Finder Window (Command-N).With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe Illustrator <Version #> Settings” (earlier versions of Illustrator might just say “Adobe Illustrator”) and the file called “com.adobe.Illustrator.plist” and delete both that folder and that file. When Illustrator is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching Illustrator and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works great but if it doesn’t you may have to manually delete them.

To do so:

On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\[User Name]\AppData\Roaming\Adobe\Adobe Illustrator [version number]\ Settings\<Language>. Make sure that Illustrator is closed when you do this. When you relaunch the program it will create  new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

Thanks for the suggestion, Bill, but that didn't work. It is exactly the same.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

It worked great for me. You have to make sure you search for the file "adobe.Illustrator.plist" which is not easy to find by going through the folders. It took me a couple of tries and it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

I do not see that behaviour. Did you try to turn off GPU Preview? Maybe it is your graphics card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2018 Nov 12, 2018

Copy link to clipboard

Copied

I had the same problem today. I fixed it my resetting your workspace. To do this: Select Window > Workspace > Reset Essentials

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2018 Nov 13, 2018

Copy link to clipboard

Copied

I am having a similar issue, i can see my anchor points and bars but is ridiculously hard to grab them. I have my selection tolerance at 8px but still cant seam to land on the handles. its incredibly frustrating. i have to zoom in extremely close to the handle and then i cant see the rest of my artwork so have no idea where i am dragging it to. Also to mention i am having way to many issues with Photoshop and am just using .18. i would rather trash 19 then ever use it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2018 Nov 13, 2018

Copy link to clipboard

Copied

So it turns out that it was only this one legacy document (created in 18) that was the problem. This was the first document I opened after installing 19. I deleted preferences. I reset the workspace. I tried everything. I then opened a brand new document and found there was no problem. I opened another legacy document created in 18 and no problem with that one either. I then copied and pasted the elements from the problem document (luckily not a complex one) into a new document and it’s working fine now. Can’t really explain why this worked but it did.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2019 Nov 20, 2019

Copy link to clipboard

Copied

This option worked for me as well. I also found that if I saved the 18 doc as a 19 then the paths worked better. Still clitchy, but at least it doesn't seem like the paths are locked anymore. Thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

Same issue. Can hover over shapes, paths etc and can see everything. But as soon as you move away, the objects look like they are not selected and have no way to grab or select points. Even in wireframe mode they are ridiculously difficult to grab.

As you posted a new document created in CC 2019 doesn't have this issue...however saving an older document in 2019 doesn't eliminate it. Backwards comparability within versions of your own software wouldn't be too hard to ask for would it Adobe?

Honestly I'm really loosing the rag with these constantly buggy updates that are killing so much time away from client work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

May have just found something...seems to have worked. Go to View > Show edges

​Why that's turned off by default is mind boggling!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

  schrieb

May have just found something...seems to have worked. Go to View > Show edges

Why that's turned off by default is mind boggling!

It's not turned off by default.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

It 100% was in my Install as its only just been installed and I hadn't altered a thing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2019 Sep 27, 2019

Copy link to clipboard

Copied

omg this worked perfectly, I'm sure I have checked the View menu .. maybe I didn't notice the option, or thought it was on, really thank you so much 3rd day on having the problem :).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2019 Apr 17, 2019

Copy link to clipboard

Copied

This works – Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

This is a much easier solution I found than having to recreate the whole document!! Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2019 Jul 24, 2019

Copy link to clipboard

Copied

You just saved my afternoon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2019 Sep 13, 2019

Copy link to clipboard

Copied

me too. small thing, but SOOOO annoying. Thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2019 Sep 24, 2019

Copy link to clipboard

Copied

Thank you! I was going crazy trying to find out what I did!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

I am getting a similar issue as the OP wherein if I drag a selection marquee with the direct selection tool, it won't select anything. However, if I directly click it, then it will select. Once I have directly clicked it and then drag a marquee, it deselects... that's not meant to happen. This is only happening in artwork mode. In preview mode it works as I would expect.

It's taken me a good few minutes to write this post because I have been trying to figure out what is going on, and in the process of switching between preview and artwork mode and selecting between the two, the direct selection tool has just started working as I would expect.

It seems there is an intermittent bug!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 31, 2019 Jul 31, 2019

Copy link to clipboard

Copied

if you hold the option key while using the group selection arrow, you can access anchor points. clunky but it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2019 Oct 21, 2019

Copy link to clipboard

Copied

I not only trashed my preferences, I did a clean reinstall without carrying over old settings and it worked for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

LATEST

Late to the game but... I think I had the same problem. I fixed this by making the "Hide Edges" option active under the Window menu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines