Illustrator 2021 - "Apple Symbols" font - unable to insert glyphs via glyphs panel

Contributor ,
Dec 12, 2020

Copy link to clipboard

Copied

Good Morning,

While I can insert all "Apple Symbols" glyphs on InDesign, (via glyph pannel) I'm unable to do so in Illustrator. Some of the glyphs are getting a question marks in a black diamond shape (view screenshot). Can't figure it out.

Screen Shot 2020-12-13 at 9.19.41 13-12-20.png

Mac OS 10.14.6

Illustrator 2021

 

Please Help 🙂

Shlomit

 

 

OK, I thing I figured it out.

It's because I'm using the Middle Eastern version, and although I was sure I selected Adobe Par. Single Line Composer, I now see that it was on Adobe World Ready Single Line Composer. Once I change that, it works OK. 

 

Do you think it should have worked in both composers?

 

Thank you everybody 🙂

TOPICS
How to, Type

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator 2021 - "Apple Symbols" font - unable to insert glyphs via glyphs panel

Contributor ,
Dec 12, 2020

Copy link to clipboard

Copied

Good Morning,

While I can insert all "Apple Symbols" glyphs on InDesign, (via glyph pannel) I'm unable to do so in Illustrator. Some of the glyphs are getting a question marks in a black diamond shape (view screenshot). Can't figure it out.

Screen Shot 2020-12-13 at 9.19.41 13-12-20.png

Mac OS 10.14.6

Illustrator 2021

 

Please Help 🙂

Shlomit

 

 

OK, I thing I figured it out.

It's because I'm using the Middle Eastern version, and although I was sure I selected Adobe Par. Single Line Composer, I now see that it was on Adobe World Ready Single Line Composer. Once I change that, it works OK. 

 

Do you think it should have worked in both composers?

 

Thank you everybody 🙂

TOPICS
How to, Type

Views

85

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 12, 2020 0
Adobe Community Professional ,
Dec 13, 2020

Copy link to clipboard

Copied

Inserting them by double clicking the glyphs in the Glyph panel works for me.

Illustrator 25.01 same Mac OS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2020 0
Contributor ,
Dec 13, 2020

Copy link to clipboard

Copied

Thank you, but as you see in my screenshot, it didn't work for me, at list not with the ones I tried accept from the first glyph... Did you try similar glyphs or jsut any glyph? It does work with some of them, but not all of them...

The second one from left (shift icon) for instance is GID 997

Thank you

Shlmoit

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2020 0
Adobe Community Professional ,
Dec 13, 2020

Copy link to clipboard

Copied

I did try similar glyphs, but the ones you are missing don't have a unicode in the panel.

I tried with Preferences > Type > Enable Missing Glyphs Protection on and off but that did not make a difference.

Glyphs.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2020 0
Contributor ,
Dec 13, 2020

Copy link to clipboard

Copied

I still don't understand why I can type them in InDesign and not in Illustrator...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2020 0
Adobe Community Professional ,
Dec 13, 2020

Copy link to clipboard

Copied

I cannot type the either, but I can insert them by double clicking in the Glyphs panel.

The text engines of InDesign and Ilustrator are differerent, which may explain the behaviour.

You may want to report it here:

https://illustrator.uservoice.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2020 0
Contributor ,
Dec 14, 2020

Copy link to clipboard

Copied

Thank you!

I'm sorry, it's my fault, I meant insert and not type. I fixed it my main post title.

 

Shlomit

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2020 0
Contributor ,
Dec 14, 2020

Copy link to clipboard

Copied

OK, I thing I figured it out.

It's because I'm using the Middle Eastern version, and although I was sure I selected Adobe Par. Single Line Composer, I now see that it was on Adobe World Ready Single Line Composer. Once I change that, it works OK. 

 

Do you think it should have worked in both composers?

 

Thank you everybody 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2020 0
Adobe Community Professional ,
Dec 15, 2020

Copy link to clipboard

Copied

Good to hear you found the cause of your problem.

"Do you think it should have worked in both composers?"

You may ask the question here:

https://community.adobe.com/t5/type-typography/bd-p/type-and-typography?page=1&sort=latest_replies&f...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2020 0
Resources