Illustrator 25.1 Mac plugins not avalaible

Community Beginner ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

On Mac (Big Sur), third-party plugins aren't avalaible with Illustrator 25.1.

TOPICS
Bug, Third party plugins

Views

352

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Jan 08, 2021 Jan 08, 2021
Hi all,   As Monika mentioned, this has been reported by some plugin manufacturers already and we are working on this. Since this process involves the plugin makers as well, please allow some time to get it fixed. In the meanwhile, if you use third-party plugins, use the previous version of Illustrator.   If you need assistance in installing the previous build, please check this link for help.   Thanks, Om

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Some plugin manufacturers already pointed this out.

Before updating, please do always fist check if all your plugins are compatible.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

The problem with third-party plugins was that plug-ins that didn't support some framework changes wouldn't load properly.

It was due to the removal of support for older models in 25.1, which relied on the older API of macOS.

If the plug-in does not load, you will need to get a new version from the developer.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Hi,

Same for me. Since I made the 25.1 update, the Origami and Suitcase Fusion plugins are no longer recognized, even though they work on version 25.0.1.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2021 Jan 11, 2021

Copy link to clipboard

Copied

Just want to note that Origami has been fixed and now works just fine with Illustrator 25.1: https://boxshot.com/2021/01/12/origami-3-0-11.html

 

Although it was our fault (the plugin missed a file now required by Illustrator), it would be really nice if Adobe makes that sort of changes in major annual updates of their apps.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Hi all,

 

As Monika mentioned, this has been reported by some plugin manufacturers already and we are working on this. Since this process involves the plugin makers as well, please allow some time to get it fixed. In the meanwhile, if you use third-party plugins, use the previous version of Illustrator.

 

If you need assistance in installing the previous build, please check this link for help.

 

Thanks,

Om

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

HI,

I hope that this problem will be solved very soon.
I'm not sure that the problem comes from Extensis Fusion but rather from the too fast betatests made by Adobe.
I am a professional user (graphic designer) of the Adobe suite and it seems to me that plugins like Suitcase Fusion should be part of your tests.
Sincerely

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

We (Extensis) are planning to release an update for Suitcase Fusion for this issue potentially by the end of the week. Please file a support ticket with our Technical Support Team so that we may contact you once the update is avaialble.

 

Please do so using our web form found here:

https://www.extensis.com/contact-us 

 

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

I saw a notice from Astute Graphics a few days ago warning users about the Illustrator 25.1 update. Their huge suite of Illustrator plug-ins apparently continue to work fine on the Windows version of Illustrator 25.1 (I'm not seeing any issues with my installation). However the plug-ins for the Mac version break. They're working on an update that will be released later in January.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Update: Astute Graphics rolled out updates to their plug-ins early this morning (Jan 13). Those updates include compatibiilty fixes for Illustator 25.1 on OSX as well as introducing some new features.

Likes

translate

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines