Highlighted

Illustrator CC 2019 doesn't turn snapping off, no matter what.

New Here ,
Nov 21, 2018

Copy link to clipboard

Copied

Hi.

Ever since the new update to the 2019 range of CC products, Illustrator has been acting weird and Photoshop crashes (A LOT) randomly and I'm pretty sure my rig is beefy enough to run any Adobe solution. Now Illustrator does not for the life of me turn off snapping. I've deactivated every possible snapping option that I'm aware of but it is still snapping (to grid, to pixels, to objects, etc...). I've uninstalled and reinstalled already, as well as trying it with both a new document and a document I was already working on. Nothing.

Am I missing something? Or is it just that Adobe has really wrecked their own products? Because hey, Adobe, I'm not paying over 50 dollars for your products to hinder my work instead of making it simpler, so fix your damn products!

TOPICS
How to, Tools

Views

16.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC 2019 doesn't turn snapping off, no matter what.

New Here ,
Nov 21, 2018

Copy link to clipboard

Copied

Hi.

Ever since the new update to the 2019 range of CC products, Illustrator has been acting weird and Photoshop crashes (A LOT) randomly and I'm pretty sure my rig is beefy enough to run any Adobe solution. Now Illustrator does not for the life of me turn off snapping. I've deactivated every possible snapping option that I'm aware of but it is still snapping (to grid, to pixels, to objects, etc...). I've uninstalled and reinstalled already, as well as trying it with both a new document and a document I was already working on. Nothing.

Am I missing something? Or is it just that Adobe has really wrecked their own products? Because hey, Adobe, I'm not paying over 50 dollars for your products to hinder my work instead of making it simpler, so fix your damn products!

TOPICS
How to, Tools

Views

16.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 21, 2018 5
Adobe Community Professional ,
Nov 21, 2018

Copy link to clipboard

Copied

Can you share your OS and a step by step example that produces the unwanted result? I haven't noticed any changes to snapping behaviour.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2018 1
New Here ,
Nov 21, 2018

Copy link to clipboard

Copied

Hi Doug, thanks for your reply.

I'm on Windows 10 Home (I have an Acer Nitro 5 laptop), but this is also happenning on my much beefier setup at home (64gigs of ram, Ryzen 7 CPU, etc.), which uses Win 10 Pro.

As for the example, it goes like this:

Whenever I try to move an object with precision, it ends up moving a lot more than just 1px, for example. It's like it's moving 10 pixels, even though I have all snapping turned off and pixel increment set to 1. To illustrate the example, here are some screenshots (not sure if it's gonna serve you any purpose, but it's better than nothing):

1) Let's say I'm trying to join those two red elements together. This is 2400% zoomed in, so a simple move of the mouse (I'm on a Logitech G502 which by itself has millimetric precision with the press of a button) or a press of the arrow keys would do the trick:

2) But whenever I do that, I get no precision at all. It snaps way far into the other object and never aligns to its edge, doesn't matter what I do. The result is as follow (this result was produced with a single press on the arrow key, with the lowest possible pixel increment):

The snapping is all over the place, as if it was skipping ten or more pixels at a time, never getting the exact precision I need, and every snapping option (again, the ones I'm aware of) is turned of. I'm almost 100% positive I'm not forgetting to uncheck/check any option, but a second opinion is always a good idea.

Was that enough to illustrate the problem? If not, let me know and I can try and be more clear.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2018 1
Adobe Employee ,
Nov 26, 2018

Copy link to clipboard

Copied

Hi there,

Sorry to hear about this. Please try resetting preferences for Illustrator( How to set preferences in Illustrator ) and then try to uncheck all the Snapping options from "View" menu.

Snapping oprions Ai.png

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 3
New Here ,
Feb 24, 2020

Copy link to clipboard

Copied

Wow... it works.... 

from long time i was searching this solution!! Now I got it.

 

Thank you so much Srishti 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
Explorer ,
Oct 12, 2020

Copy link to clipboard

Copied

This did not work for me. I have unchecked all snapping options everywhere I can find them. I have scoured help files and the program itself: every snapping available in every menu, in every sub-menu, in every tool that has snapping options. I've even *enabled* snapping through clicking on the snapping icon in the top right corner just to be able to then clicking snapping options and turn off all snapping, all to no avail. Holding CTRL does nothing to temporarily disable snapping.

Illustrator has become an extremely frustrating experience. It does not matter what pointing device I am using or how many snapping options in how many preferences I disable, snapping is still happening, as described in detail by thetunez two years ago.

At this point I am longing for a DISABLE ALL SNAPPING button. I actually wish I could remove the feature entirely from the software as it has become the actual bane of my illustrating experience. Once upon a time I had to tell this software everything I wanted to do, and now the software thinks it's smarter than I am and that it knows what I really want to do: It does not know better than me where I want the node to be placed. I have a stylus: I'm extremely precise, I do not need "assistance".

How does one completely disable snapping, please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Explorer ,
Oct 12, 2020

Copy link to clipboard

Copied

Version:
metagrapher__0-1602525622631.png

I took a video of it snapping and apparently cannot upload it here, you ask me for a URL, which I do not have.

The video that I cannot upload clearly shows snapping still occurring in spite of every option being disabled. I finally turned off all the guides, including smart guides (since I suddenly got a hunch it could be related.) Indeed, disabling guides does turn off snapping to guides. I wish I could have guides enabled without snapping to them, you know, to use them visually, like guide lines, but cool. So guides are apparently useless in illustrator now because turning them on seems to indicate that everything should snap to guides, whether you want snapping to guides or not? This is definitely a bug in the software. If it's a feature, then it's a terrible feature, as it's doing things I did not ask it to do, almost always a bad UX decision.

Hopefully this can be resolved with a future update. I look forward to (ideally) a disable all snapping button. Like, a button that would turn off ALL snapping, even surprise extra snapping that tools 'think' you need. That would be the best ever. I really don't want to have to click 15 hidden menu items just to disable snapping.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

That's weird. For me (using version 24.2.3) it does not snap to Guides (using pen tool) if I disable "Snap to Point." What tool are you using? Is the snapping to guides your main issue, or is it also snapping to lines / points when not supposed to? Have you tried locking the layer that has the guides and illustrating on a separate layer? I find this works for me even when I have snapping enabled (which is annoying, but may help in your situation).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Mar 27, 2019

Copy link to clipboard

Copied

I'm having the same problem, turned off all snapping  options and its still snapping....so frustrating.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2019 0
Adobe Employee ,
Apr 04, 2019

Copy link to clipboard

Copied

Hi Aoife,

We’re so sorry to hear about this. I would request if you can share a few more details like:

  • OS( exact version of Windows/MAC)
  • Exact version of Illustrator (We have recently released an update for Illustrator CC2019 (v 23.0.3) which contains some stability fixes. If you are not already on 23.0.3, then we recommend you to update to latest version.)
  • Screenshot or video of the issue.
  • Is the issue related to a specific document(s)/asset(s)? If yes, can you please share the document(s)/asset(s) with us?
  • Does trashing Illustrator Preferences(https://helpx.adobe.com/in/illustrator/using/setting-preferences.html) help resolve the issue?

Resetting preferences will remove all the custom settings and Illustrator will launch with default settings. You can also take a backup of the folders in case you want to. Location is mentioned in the article.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
New Here ,
Apr 14, 2019

Copy link to clipboard

Copied

I'm getting the same thing.  All snapping options on the "View" menu are turned off.  I'm using Illustrator 2019 v. 20.0.3 on a MacBook Pro 15 inch, 2018 running Mac OS Mojave 10.14.4.  I can't figure out how to turn off all snapping everywhere. It's making me mad and interfering with my work. First the ransomware subscription model and now the tool doesn't even work as it used to?

Rapidly losing my liking for Adobe products.

-Michael V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2019 0
Adobe Employee ,
Apr 15, 2019

Copy link to clipboard

Copied

Hi Michael,

We are extremely sorry to hear about this issue. Did you try resetting preferences as mentioned above? Does that help resolve the issue?

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2019 0
Adobe Community Professional ,
Apr 15, 2019

Copy link to clipboard

Copied

michaelv8014682  schrieb

I'm getting the same thing.  All snapping options on the "View" menu are turned off.  I'm using Illustrator 2019 v. 20.0.3 on a MacBook Pro 15 inch, 2018 running Mac OS Mojave 10.14.4.  I can't figure out how to turn off all snapping everywhere. It's making me mad and interfering with my work. First the ransomware subscription model and now the tool doesn't even work as it used to?

Please tell us what exactly is happening. Which tool do you use to do what exactly and in which way does Illustrator keep you from achieving what you want?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2019 0
Adobe Community Professional ,
May 12, 2019

Copy link to clipboard

Copied

Hey

Late to the party, I know but if you're still experiencing this issue (or for anyone else that may be and ends up here);

Please could you check (as you say that you've disabled every snapping option you know of) if you have disabled everything in the Pixel Snapping Options? Set aside the three snapping widgets in the Properties Panel and the options in the View menu just for a moment and enable the Control strip (if it isn't already—it's the long bar that runs across the top of the workspace).

At the right-hand side you'll see a Magnet Icon there—turn that on (you'll also notice it becomes enabled in the Properties Panel) and then click the arrow to the right of the icon you just clicked; you should get a dialog like this:

Screenshot 2019-05-12 at 22.54.19.png

Uncheck all of those options and you should be all set.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2019 5
New Here ,
Jun 17, 2019

Copy link to clipboard

Copied

Hi Tony,

It sounds like your idea may fix this frustrating problem but I have no idea what you said. It was confusing for me. Sorry. Any chance you can explain a little better? Please. I looked for "snapping widgets" in the AI Properties Panel but couldn't find anything that looked like your screenshot. I've looked everywhere. Looked in the "View" menu too and nothing. I am using Illustrator 2019. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 0
Adobe Community Professional ,
Jun 17, 2019

Copy link to clipboard

Copied

Look more carefully at the area I have outlined in red (in the Control Panel):

Menu.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 2
Adobe Employee ,
Jun 20, 2019

Copy link to clipboard

Copied

Hi Sean,

Thanks for reaching out. Looks like you are facing some issues while turning of snapping in Illustrator. I am hopeful that the issue is resolved by the suggestion shared by Tony and Steve. If not, please share the following details:

  • OS (exact version of Windows/MAC)
  • Few screenshots or a small video of the issue.
  • Is the issue related to a specific document(s)/asset(s)? If yes, can you please share the document(s)/asset(s) with us?

You can also check out this help article for more details on snapping: Seamlessly align your artwork with the pixel grid...

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2019 0
ZINCT LATEST
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

On the Mac, I figured out that if you turn off smart guides, the snapping went away. Make sure to also turn off the tiny magnet icon on the right side of the menu bar (to the right of the Document Title). It was driving me insane.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

Thanks tonyharmer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 0
New Here ,
Nov 25, 2019

Copy link to clipboard

Copied

Sorry!! Still making the same issue. Still put me the snap. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2019 1
Community Beginner ,
Jan 17, 2020

Copy link to clipboard

Copied

SOLUTIONS first; 
#1, lock or hide all other shapes / layers. Pen Tool does not snap to locked shapes or points. 
#2, when the Pen Tool wants to snap to the current shape (line) which must be unlocked obviously, hold the SHIFT key. This will allow you to place a point right next to the line without snapping to it.

With those two fixes, the only "bug" left is it will still snap to the Points of the current shape. It would be nice if SHIFT worked for that too, but for me doesn't.

 

More details:

 

Previous suggestions do not fix this issue. Pixel snapping and smart guides are different. When you click the magnet icon it enables pixel snapping, same as doing this through the View dropdown. When you open the Pixel Snapping Options panel and disable the 3 Snap to pixel options, you're just turning off the features of pixel snapping that you just enabled. This does nothing.

My problem is I have disabled Point Snapping in the view menu so I expect no point snapping, but (probably because you NEED it to close a shape) I still get point snapping when using the Pen tool. I have disabled Smart Guides (cmd+U) or view menu > smart guides, it's not related. Pen Tool snaps to any Point (a point is not a pixel) on any unlocked/visible layers when drawing vector shapes with Pen Tool. It also snaps to the currently selected shape's points AND lines, so if you try to make a very accute angle for instance it will snap to the existing line and make no shape. It doesn't seem to be a problem when using Rectangle/Ellipse tools. Once again, this is point and shape snapping. This is NOT smart guides. This is NOT pixel snapping. This is NOT grid snapping or perspective grid snapping. 

Other things I've tried: Preferences > Smart Guides > Change snapping tolerance to 0pt. (no effect of course, because it's not a smart guides issue.)
Resetting Preferences (zilch)
Updating from Illustrator 2019 v22.1 to Illustrator 2020, v24.01. (no effect, both apps behave the same)


Thanks, hope this was useful to anyone.
Mac OS 10.14.5 Mojave.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2020 0
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

The answer for me was simple: On the Mac, I figured out that if you uncheck smart guides, the snapping went away. Make sure to also turn off the tiny magnet icon on the right side of the menu bar (to the right of the Document Title). It was driving me insane.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

Not really, snapping still goes on. On the Mac, I figured out that if you turn off smart guides, the snapping went away. Make sure to also turn off the tiny magnet icon on the right side of the menu bar (to the right of the Document Title). It was driving me insane.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

@adobe Stop breaking and overly complicating your software. If it's not broke then don't fix it. I mean do you guys do any user research!!?? I know this forum is for illustrator -but for god sakes -stop trying to break after effects AND IF ANYTHING STOP CHANGING AND BREAKING PRIMARY FUNCTIONS -LIKE RAM PREVIEW. If you need my help bc you hired the wrong people then hit me up. I'll be happy to fix your issues for you. AND stop saying you're sorry -just fix it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 3
Adobe Community Professional ,
Jun 25, 2019

Copy link to clipboard

Copied

@mcbone,

Except for getting it off your chest, there's absolutely no reason to talk about your feelings about After Effects (a totally separate app which probably only a tiny number of Illustrator users have experience with).

You should post those feelings in the After Effects forum here:

After Effects

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 0
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

After I did all the above

-turn off snapping in prefs

-turn off snapping in the new magnet menu

-turned off snapping in view menu

Then I did (drumroll)

-View menu -uncheck smart guides

works now

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 4
Community Beginner ,
Feb 04, 2020

Copy link to clipboard

Copied

i'm at my wits end. I'm using Illustrator cc2020 on a new iMac and i cannot for the life of me turn off snapping to points. All options under the view menu are turned off. Smart guides are turned off, magnet menu stuff is all turned off. WTH?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2020 0
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

On the Mac, I figured out that if you turn off smart guides, the snapping went away. Make sure to also turn off the tiny magnet icon on the right side of the menu bar (to the right of the Document Title). It was driving me insane. Customer support should have easily answered this question, instead, they ask for your System software and come up with these convoluted rabbit holes. Sheesh. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 1