Highlighted

Illustrator CC 2020 Performance issues // lags on Mac

Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Hello there,

 

I updated from Illustrator 2018 to 2020.

 

In the moment I opened up a new document, I immediately noticed major performance issues.

 

The navigation lags very hard. That goes for hand tool and (since always) swiping on Magic Mouse.

Same with objects you move around with the cursor.

It is not possible to work fast in this state. 

I did a direct comparison between 2020 and 2019 (23.1.1) and 2019 feels much more fluid. 

Also good to mention is the performance of Adobe XD in comparison – this does a very, very fluid job.

1. Is the performance issue major and will it be addressed?

2. Is a technical iteration of the Illustrator UX performance towards XD a part of the roadmap?

TOPICS
Bug, Feature request, Performance

Views

271

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC 2020 Performance issues // lags on Mac

Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Hello there,

 

I updated from Illustrator 2018 to 2020.

 

In the moment I opened up a new document, I immediately noticed major performance issues.

 

The navigation lags very hard. That goes for hand tool and (since always) swiping on Magic Mouse.

Same with objects you move around with the cursor.

It is not possible to work fast in this state. 

I did a direct comparison between 2020 and 2019 (23.1.1) and 2019 feels much more fluid. 

Also good to mention is the performance of Adobe XD in comparison – this does a very, very fluid job.

1. Is the performance issue major and will it be addressed?

2. Is a technical iteration of the Illustrator UX performance towards XD a part of the roadmap?

TOPICS
Bug, Feature request, Performance

Views

272

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 03, 2020 0
Adobe Community Professional ,
Jul 04, 2020

Copy link to clipboard

Copied

Which hardware is it?

Does it have automatic GPU switching and can you turn that off in the system?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 04, 2020 0
Community Beginner ,
Jul 05, 2020

Copy link to clipboard

Copied

Bildschirmfoto 2020-07-06 um 07.56.18.png

Hardware above. 

 

I can switch GPU off but that makes it even worse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 05, 2020 0
Community Beginner ,
Jul 05, 2020

Copy link to clipboard

Copied

Did a bit of testing:

 

  1. "Scale cursor proportionally" in UI settings doesn't make a difference
  2. "Scale UI" doesn't make a difference
  3. What does make a significant difference is when I downsize the hole AI window to 50% or less.

 

I'm working on a 4K Thunderbolt Display.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 05, 2020 0
Community Beginner ,
Jul 05, 2020

Copy link to clipboard

Copied

Okay it's the 4K display.

 

I tried on a HD 1080p display and it's full performance at full size.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 05, 2020 0
Community Beginner ,
Jul 06, 2020

Copy link to clipboard

Copied

I created a workaround for performance issues at 4K. This way it's way better and operational at fullscreen.

 

Rightclick on Illustrator → Information  Activate "Open in low resolution"

Bildschirmfoto 2020-07-06 um 09.10.13.png

 

Still not a solution really. The UI's resolution is worse than on a regular HD display (which it works perfectly on).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0
Community Beginner ,
Jul 06, 2020

Copy link to clipboard

Copied

Here's a direct comparison between "open at low resolution" and default performance, both on a 4K display.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0
Community Beginner ,
Jul 07, 2020

Copy link to clipboard

Copied

I just changed my color profile in the preferences from my calibration profile to Apple RGB and that did the trick!

 

Still, searching for a solution since I need to work on a calibrated view.

This is a direct comparison between working with Adobe Illustrator at "Open at low resolution" on/off on macOS Catalina. Both are captured on a 4K display. T...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2020 0