Highlighted

Illustrator CC 22.0.1 Type Anti-Aliasing Issue

Community Beginner ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi everyone,

I'm having an issue with the latest version of Illustrator and the type window anti-aliasing.

A few things are happening:

  1. The dropdown menu in the type window for anti-aliasing options is disabled seemingly at random.
  2. The anti-aliasing dropdown menu in the type window allows me to designate a render setting to one type selection however, this setting also seemingly applies to all type on the document (i.e. I cannot apply "Sharp" to one text block and "Strong" to another).

Is anyone else having this issue or have a fix for this? Thank you!

Adobe Community Professional
Correct answer by Monika Gause | Adobe Community Professional

https://forums.adobe.com/people/Aleks+Golotvinov  schrieb

Very similar problem here.

Anti-aliasing is completely disabled in the character menu.

Using Windows 10 64-bit, latest version of Illustrator CC (2018)

Screenshot_1.png

What is selected? The text object with the selection tool? Or the text with the text tool? It will only work when the text object is selected.

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC 22.0.1 Type Anti-Aliasing Issue

Community Beginner ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi everyone,

I'm having an issue with the latest version of Illustrator and the type window anti-aliasing.

A few things are happening:

  1. The dropdown menu in the type window for anti-aliasing options is disabled seemingly at random.
  2. The anti-aliasing dropdown menu in the type window allows me to designate a render setting to one type selection however, this setting also seemingly applies to all type on the document (i.e. I cannot apply "Sharp" to one text block and "Strong" to another).

Is anyone else having this issue or have a fix for this? Thank you!

Adobe Community Professional
Correct answer by Monika Gause | Adobe Community Professional

https://forums.adobe.com/people/Aleks+Golotvinov  schrieb

Very similar problem here.

Anti-aliasing is completely disabled in the character menu.

Using Windows 10 64-bit, latest version of Illustrator CC (2018)

Screenshot_1.png

What is selected? The text object with the selection tool? Or the text with the text tool? It will only work when the text object is selected.

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 26, 2018 1
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

These are settings for Photoshop, not Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Community Beginner ,
Feb 26, 2018

Copy link to clipboard

Copied

No, this is an illustrator issue.Screen-Shot-2018-02-26-at-12.27.31-PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

Sorry about that.

What are you doing? How are you selecting? If you have one large text block and highlight it, it can not have more than one setting applied. You can only select with a selection tool (direct or the selection tool) and apply one of the drop downs. Same if you just type, you can't highlight the text that you want it applied to. If it isn't working this way for you, then you might want to try resetting your preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Community Beginner ,
Feb 26, 2018

Copy link to clipboard

Copied

Correct, I am on the same page with you as far as how it should be working and how I am using it. I have also deleted this version and all prior illustrator version preference presets and restarted my computer and the program. Still no resolve. As

I have reported the bug as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

I'm on a MacBook Pro - Sierra not High Sierra and it is working fine. Hope they find a solution for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

I am on Sierra as well with 22.0.1.

Are you sure you can have 2 separate text objects each with its own different anti aliasing method?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Community Beginner ,
Feb 27, 2018

Copy link to clipboard

Copied

michelew83603738​ Thank you!

I am on High Sierra—


Yes, If I have two text boxes I should be able to designate separate anti-aliasing methods to each.

See my screen recording comparing 2018 to 2017 capability:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

It works in the previous CC2017 version, but is broken in CC2018

Please report it here:

Adobe Illustrator Feedback

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Community Beginner ,
May 31, 2018

Copy link to clipboard

Copied

Very similar problem here.

Anti-aliasing is completely disabled in the character menu.

Using Windows 10 64-bit, latest version of Illustrator CC (2018)

Screenshot_1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2018 0
Adobe Community Professional ,
Jun 01, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Aleks+Golotvinov  schrieb

Very similar problem here.

Anti-aliasing is completely disabled in the character menu.

Using Windows 10 64-bit, latest version of Illustrator CC (2018)

Screenshot_1.png

What is selected? The text object with the selection tool? Or the text with the text tool? It will only work when the text object is selected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 1
Explorer ,
Sep 05, 2020

Copy link to clipboard

Copied

How is this marked solved? What's the solution?  I'm on CC 2020 and it's still not working.  I can see you have to use the selection tool to select the text before the anti-aliasing options are enabled, however adjusting them has no effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 0
Adobe Community Professional ,
Sep 05, 2020

Copy link to clipboard

Copied

You need to turn on Pixel Preview to see the result of the anti-aliasing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 1
Explorer ,
Sep 05, 2020

Copy link to clipboard

Copied

Ton, I have anti-aliasing set to Sharp and have never changed it (as most of my work is for print). When you design typrography for the web, do you change that setting? If so, to what do you set it, and does it perceptibly improve the PNG or JPG display on screen? Thanks in advance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 0
Adobe Community Professional ,
Sep 05, 2020

Copy link to clipboard

Copied

There is no single setting for all fonts.

Which setting to choose depends on the design and size of the type and if it is visually pleasing.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 0
Explorer ,
Sep 05, 2020

Copy link to clipboard

Copied

Understood. But can I assume that you do experiment with the anti-aliasing settings (with Pixel Preview on) when you create type for the web?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 0
Adobe Community Professional ,
Sep 05, 2020

Copy link to clipboard

Copied

Yes you do experiment when creating type for web as well as for images.

I just found that Pixel Preview gives distorted (and wrong size) previews in version 24.3 when the Preferences setting "Display Print Size at 100% Zoom" is checked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2020 0
Resources