Highlighted

Illustrator CC Drop Shadow Issue

Explorer ,
Sep 29, 2013

Copy link to clipboard

Copied

Since upgrading to Illustrator CC, I am having random issues with drop shadows. It doesn't matter if the shadow is applied to a basic vector graphic per screenshot attached, or to a placed transparent image, and it can be on complex shapes or very simple shapes. I get these odd straight lines running through the shadow. It is just a CMYK file (no spot colour), set up for print, document raster effects resolution set to 300ppi. I have tried fiddling with the drop shadow settings, if I move the x and y settings it just moves the line. If I keep the x and y distance the same but remove the blur value, the line disappears (see screenshot without blur). It is not related to transparency, because even if I flatten the image and expand the shadow, it is still there.

Screen Shot 2013-09-30 at 4.29.55 PM.pngScreen Shot 2013-09-30 at 4.24.27 PM.pngScreen Shot 2013-09-30 at 4.32.19 PM.png

Yes, two ways:

• I upgraded my ram to the max amount my iMac can take.

• I custom reduced "raster effect settings", bring it down a bit at a time, until I reached the limit where the error disappeared. This is not the idea solution but my iMac is old, and this is the only solution I can find until I buy a new retina iMac later this year.

All the best!

Views

17.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC Drop Shadow Issue

Explorer ,
Sep 29, 2013

Copy link to clipboard

Copied

Since upgrading to Illustrator CC, I am having random issues with drop shadows. It doesn't matter if the shadow is applied to a basic vector graphic per screenshot attached, or to a placed transparent image, and it can be on complex shapes or very simple shapes. I get these odd straight lines running through the shadow. It is just a CMYK file (no spot colour), set up for print, document raster effects resolution set to 300ppi. I have tried fiddling with the drop shadow settings, if I move the x and y settings it just moves the line. If I keep the x and y distance the same but remove the blur value, the line disappears (see screenshot without blur). It is not related to transparency, because even if I flatten the image and expand the shadow, it is still there.

Screen Shot 2013-09-30 at 4.29.55 PM.pngScreen Shot 2013-09-30 at 4.24.27 PM.pngScreen Shot 2013-09-30 at 4.32.19 PM.png

Yes, two ways:

• I upgraded my ram to the max amount my iMac can take.

• I custom reduced "raster effect settings", bring it down a bit at a time, until I reached the limit where the error disappeared. This is not the idea solution but my iMac is old, and this is the only solution I can find until I buy a new retina iMac later this year.

All the best!

Views

17.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 29, 2013 0
Adobe Community Professional ,
Sep 30, 2013

Copy link to clipboard

Copied

Is the line still there after exporting to PDF?

What is below the object?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
Explorer ,
Sep 30, 2013

Copy link to clipboard

Copied

Removing everything but the whole circle, it is still there. Copied and pasted to a new blank page just to double check, I got yet another line. Scaled up and down, it changes, some sizes the lines disappear, other sizes they just move. I thought it was when I was working on really large, high resolution signage, but then it happened on a smaller file too.

Have exported as a flattened PDF and the lines are still there.

Cheers,

Julie

Addendum:

OK, I have just dropped the raster effects resolution setting and the lines disappeared. But this is not a solution because I want high resolution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
Adobe Community Professional ,
Sep 30, 2013

Copy link to clipboard

Copied

Have you tried resetting the preferences?

Restart the computer?

And since we're talking about large: how large?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
Adobe Employee ,
Sep 30, 2013

Copy link to clipboard

Copied

Keeping resolution as 300 ppi, did you try increasing the value 'Add ....pt around object'. Please let us know if that helps. If that doesn't then let me know the size of this circle and the drop shadow options at which you are able to see the problem. Along with that let me know the Effect>DRE settings.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
Community Beginner ,
Sep 30, 2013

Copy link to clipboard

Copied

I had this problem too, I guess this was because the resulted rastered shadow layer was too big.

Some things that helped:

Using the SVG drop shadow.

Updating the legacy drop shadow with the new one.

Restarting Illustrator.

Getting more RAM.

Getting a better video Card.

What helped definatley in most cases was:

using a dropshadow appearance per object, with this you can save raster resolutionsince each object using it's own rastered shadow layer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
Explorer ,
Sep 30, 2013

Copy link to clipboard

Copied

Dhirendra Mohan, thanks but it happens on all different shapes and sizes, irrelevant of stroke being added or not, but it is definitely linked to high resolution, larger files.

Raymarcher, I reckon you've nailed it. I did not have this problem with CS5 on the same size files but updating to CC has caused a lot of performance issues on my Mac. Photoshop CC has already told me to update my video card. I'm running:

iMac 24" 2009 2.93GHz Intel Core 2 Duo

4gb 1067 MHz DDR3

NVIDIA GeForce GT 120 256MB

Running OS X 10.8.5

Waiting on the next release of iMac before buying. Will just have to adjust the raster effects resolution in the meantime and will certainly try switching off other applications when working on large files and see if that works. Have never used SVG drop shadow but will read up thanks.

So problem not totally solved, clarification from Adobe that this would be the cause would be great, before I buy a new iMac please.

Cheers,

Julie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2013 0
New Here ,
Apr 15, 2014

Copy link to clipboard

Copied

Changing the raster effect settings works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2014 0
New Here ,
Feb 04, 2014

Copy link to clipboard

Copied

I'm having the exact same issue as jmgd, but with the drop shadow effect. It expands after I save my Illustrator CC file. When I reopen it, I can no longer the drop shadow in the appearance panel and the drop shadow becomes its own shape. Has anyone found a fix/explanation for this???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 0
Adobe Community Professional ,
Feb 04, 2014

Copy link to clipboard

Copied

I'm having the exact same issue as jmgd, but with the drop shadow effect. It expands after I save my Illustrator CC file. When I reopen it, I can no longer the drop shadow in the appearance panel and the drop shadow becomes its own shape. Has anyone found a fix/explanation for this???

Is that a file saved from a previous version of Illustrator? And did you just save instead of Save as?

Then it happened, because Illustrator saved the file to the previous file format thus expanding the drop shadow. This is because the drop shadow has been renewed and is no longer compatible with the old version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 0
New Here ,
Feb 04, 2014

Copy link to clipboard

Copied

You're right, that seems to be the issue. Thanks for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 0
New Here ,
Mar 31, 2014

Copy link to clipboard

Copied

I'm also having issues with drop shadows in Illustrator CC. My issue is that there is no gradient when I apply the effect. I'm very familiar with shadows, and used them all the time in CS5 and CS5. In CC for some reason though, even when I set the X, Y, and Blur properly, they only sometimes work. Sometimes I receive a nice gradient. Sometimes I receive a solid color at 75% transparency. Anyone else running into this? Any known fixes?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2014 0
New Here ,
Sep 14, 2014

Copy link to clipboard

Copied

Hi Pat121785,

Did you ever get a resolution to this?  I am having the same issue and it's very frustrating!

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2014 0
Explorer ,
Sep 18, 2014

Copy link to clipboard

Copied

Yes, two ways:

• I upgraded my ram to the max amount my iMac can take.

• I custom reduced "raster effect settings", bring it down a bit at a time, until I reached the limit where the error disappeared. This is not the idea solution but my iMac is old, and this is the only solution I can find until I buy a new retina iMac later this year.

All the best!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2014 0
New Here ,
Sep 19, 2014

Copy link to clipboard

Copied

Thanks jmgd - changed the raster effect settings and it worked.  Obviously need to upgrade hardware at some point too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2014 0
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

Oh my god, you have saved my life here! I finished a logo for a client who wanted a drop shadow and when I was just about to do the final export, noticed these pesky lines cutting through the bottom of my graphic's drop shadow. I've been trying to find a solution for days.... thank you sooo much for this solution, worked like a charm! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2020 0
Resources