Highlighted

Illustrator CC2020 not saving files, Error:-54

New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

Hello!

I've been using Illustrator 2020 24.0.1 64-bit and after a while, I can't save an .ai file anymore when I make changes to it, the message appears: "Cannot save the illustration. Maybe the file is read-only or is being used by another application, or you don't have the necessary permissions. Save the document under a different name, in a different folder or directory. Identification: -54 ".

When I try to Save As ... it doesn't save as an .ai file, but as a .tmp file and with the random name "~ ai-3cb4f2a4-769b-4f86-99a2-a05daf604013_".

When I go to Export to screens ... to PNG, the files are saved with the ending .tmp $$. If I rename, remove that ending .tmp $$ and leave only .png, the file looks like a normal image, but that shouldn't happen when I export!

If anyone has been through this or knows how to solve it, please help me!

 

 

{Renamed by MOD}

TOPICS
Bug, Import and export

Views

132

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC2020 not saving files, Error:-54

New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

Hello!

I've been using Illustrator 2020 24.0.1 64-bit and after a while, I can't save an .ai file anymore when I make changes to it, the message appears: "Cannot save the illustration. Maybe the file is read-only or is being used by another application, or you don't have the necessary permissions. Save the document under a different name, in a different folder or directory. Identification: -54 ".

When I try to Save As ... it doesn't save as an .ai file, but as a .tmp file and with the random name "~ ai-3cb4f2a4-769b-4f86-99a2-a05daf604013_".

When I go to Export to screens ... to PNG, the files are saved with the ending .tmp $$. If I rename, remove that ending .tmp $$ and leave only .png, the file looks like a normal image, but that shouldn't happen when I export!

If anyone has been through this or knows how to solve it, please help me!

 

 

{Renamed by MOD}

TOPICS
Bug, Import and export

Views

133

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 18, 2020 0
Adobe Employee ,
Apr 20, 2020

Copy link to clipboard

Copied

Hi Leo,

 

Sorry to hear about your experience. Would you mind sharing some more information like:

1. Version of OS?
2. Is it happening with a specific file or all?
3. Are the files saved on network or on a local drive?

 

If the file is saved on a network, try copying it on local drive and then try to save changes. Let us know how it goes.

I'd also recommend updating Illustrator to the latest version.

All this information will help us understand the issue and work accordingly. Looking forward to your response.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2020 0
New Here ,
Sep 30, 2020

Copy link to clipboard

Copied

Hello !
I have the same problem and no solution.
Can you share me the solution ?

Thanks !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2020 0
Resources