Highlighted

Illustrator Forces/Switches Keyboard Language (MacOS)

New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

I run the latest English Illustrator, with Arabic Support on MacOS.

I have the "Automatically switch to document's input source" disabled on the Keyboard settings.

 

I work between multiple softwares at the same time, moving objects and text around, and whenever I tab over back to Illustrator, Illustrator will switch my keyboard input language to the last language I was using when I had Illustrator selected.

 

That might be a bit confusing, here is an example:

I'm working on Illustrator, and typing in Arabic

  I move to Chrome, switch input to English and search for something

    I go back to Illustrator, the keyboard language changes back Arabic by itself!

 

Its frustrating!!

Topics

Bug

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator Forces/Switches Keyboard Language (MacOS)

New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

I run the latest English Illustrator, with Arabic Support on MacOS.

I have the "Automatically switch to document's input source" disabled on the Keyboard settings.

 

I work between multiple softwares at the same time, moving objects and text around, and whenever I tab over back to Illustrator, Illustrator will switch my keyboard input language to the last language I was using when I had Illustrator selected.

 

That might be a bit confusing, here is an example:

I'm working on Illustrator, and typing in Arabic

  I move to Chrome, switch input to English and search for something

    I go back to Illustrator, the keyboard language changes back Arabic by itself!

 

Its frustrating!!

Topics

Bug

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

with Catalina 10.15.6, I disabled "Automatically switch to a document's input source", and as long as my cursor is not inside an Arabic text frame, my input keyboard sticks to English at all times when I switch back and forth between applications.

By the way, even in MS. Exel, if my cursor is in an Arabic filled cell, then the input language will switch to Arabic upon opening Exel.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 13, 2020

Copy link to clipboard

Copied

I have Illustrator on two devices, one running a Mojave and the other running Catalina... 

Both devices have the "Automatically switch to a document's input source" disabled...

The input language still changes to arabic when no text frame is selected, also when no document is even open..

I don't have Exel, so I can't test there.. From my testing, Illustrator seems to be the only Application that is exhibiting this behaviour... 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 27, 2020

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out. I agree with Zaid's statement. This concern is related with OS and not with Adobe Illustrator workflow. Still, if you'd like, you may report it to Adobe Illustrator UserVoice. This forum is monitored by product team and they'll be happy to look into it.

Hope it helps.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...