Illustrator only exporting as tmp, won't create png or eps

New Here ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

Using Windows 10 with the latest version of Illustrator CC.

When I try to export as png or eps, illustrator creates a tmp file instead. If I delete the tmp extension and clear the cache on the file it recognizes the file type but that is annoying.

Anyone else having this problem?

Tried uninstalling and reinstalling, problem still exists.

Views

16.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Explorer , May 31, 2018 May 31, 2018
Same here but just sometimes... and last time it was yesterday, i just delete the termination .tmp and it was ok but is verry annoying doing that when i have 10 files... windows 7 here.

Likes

Translate

Translate
New Here , Jan 21, 2021 Jan 21, 2021
I had the same problem and deselecting the option didn't work for me at all. What I did to solve the problem was: resetting all the messages bars (tutorial ect) I the option (I don't remember where it was sorry). Doing this triggered my antivirus, so I figured that it was the cause why I couldn't save. In fact I had to put illustrator in the "safe programs list" because it suddenly was being blocked without any reasons. Try this and tell us. (My antivirus is Avast)

Likes

Translate

Translate
Adobe Community Professional ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

It is a problem in your windows permissions.
I think it may happened because of some harmful files. In Mac OS there are many ways to solve the permissions problem but in windows I don't know how to do it. You can try to add another user to your windows or scan your system.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

Just started having the same problem in the last couple of days with Windows 7

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

I just tried exporting my files to a different location. Previously I was exporting straight into my Adobe Creative Cloud Folder when the the tmp problem was occuring. When I export the same file onto an external hard drive I get the PNG file created as expected. Not a fix I know but a little more info to work with to solve the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2018 May 30, 2018

Copy link to clipboard

Copied

Just started having the same issue =( Anyone learn a fix?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 31, 2018 May 31, 2018

Copy link to clipboard

Copied

Same here but just sometimes... and last time it was yesterday, i just delete the termination .tmp and it was ok but is verry annoying doing that when i have 10 files... windows 7 here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2018 May 31, 2018

Copy link to clipboard

Copied

Same here. I delete the extra .tmp$$ and then it appears correctly, but it is a pain. Only noticed this within the week.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2020 May 23, 2020

Copy link to clipboard

Copied

Having the same isues, I somehow fixed it but now its back and I dont know how to fix it anymore, I tried deleting the .tmp$$ file but, when I try to export it again, its the same file type

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2020 Jul 16, 2020

Copy link to clipboard

Copied

How to solve this problem man ? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2020 Jul 16, 2020

Copy link to clipboard

Copied

"How to solve this problem man ? "

 

Please tell us your system and version and also where exactly you save your files.

What's in the files?

Did it ever work correctly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2020 Aug 05, 2020

Copy link to clipboard

Copied

Same problem here, Windows 10 anyone else could fix it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2020 Oct 11, 2020

Copy link to clipboard

Copied

I blocked my antivirus and it worked perfectly

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

I am having the same problem on WIndows 10 in Illustrator. I turned off the "Auto save Recovery Data" in the File Handling preferences, and that seems to have fixed it. BUT, now it isnt saving incrementally, and Illustrator crashes on my system FREQUENTLY. So this isnt a good, long term solution. Any other fixes?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2020 Oct 11, 2020

Copy link to clipboard

Copied

I blocked my antivirus and it worked

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2020 Oct 16, 2020

Copy link to clipboard

Copied

I am having the same problem on WIndows 10 in Illustrator. i am changing the file name and extention to .ai, it's work i dont know its permenent solution or not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I have the same problem on win10 and the 2020 version of illustrator. When I try to save my .ai file onto my desktop it creates a tmp file (same with pdf file but not for the other extensions) but when I try to save the same file onto my external harddrive the file just saves normally. It's frustrating because I tried to uncheck the autosave and things but it doesnt work anyway. I also tried to reinstall but nothing changed. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Same problem. I have to export as PNG twice in a row and the second time around it works fine. But have to do the exact same thing twice in sequence and then I have my accurate PNG and the tmp$$ file is deleted. It's a waste of time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Please try and in the Preferences deselect the option to "Save/Export in background"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I tried to deselect the option to "Save/Export in background" but nothing changed.
I search everywhere but anyone knows how to solve the problem.

Pls anyone help me...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I had the same problem and deselecting the option didn't work for me at all. What I did to solve the problem was: resetting all the messages bars (tutorial ect) I the option (I don't remember where it was sorry). Doing this triggered my antivirus, so I figured that it was the cause why I couldn't save. In fact I had to put illustrator in the "safe programs list" because it suddenly was being blocked without any reasons. Try this and tell us. (My antivirus is Avast)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

its worked... thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

LATEST

thank you, you the real issue from avast 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Hey, I was having the same problem. Then I unconciously exported the file to somewhere else ,different than where I was exporting the file before and it worked!!  Try exporting the file in a different disk . I hope it works for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

I SOLVED THE PROBLEM!! After researching I realized that maybe the issue was my antivirus's fault. And it is indeed. To fix it, you have to give Illustrator permission on your antivirus. Mine is Avast, so I went to Settings, and there I saw the permission button, then I clicked in all Adobe's software.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines