Highlighted

Illustrator Smooth Tool 2020 Bug

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

Hello everyone,

so I was using the Smooth Tool as always and Illustrator suddenly started giving me a strange error when I tried to smooth out a line on my design. I'm not sure what it means, and I assume it's a new 2020 bug. After researching for quite a while, I was not able to find anything related to that error in illustrator.

 

The Error states: "Partially selected objects cannot be set as key objects. In order to set an object as a key object, make sure the entire object is selected and try again."

Not really sure what it's supposed to tell me, but I guess it's a JavaScript bug.

If anyone knows what's up with that and could help, please let me know. It's getting kinda annoying hearing a Mac's error sound every millisecond. Thanks in advance.

 

Screenshot 2020-07-02 at 15.08.37.png

Topics

Bug, Draw and design, Tools

Views

137

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator Smooth Tool 2020 Bug

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

Hello everyone,

so I was using the Smooth Tool as always and Illustrator suddenly started giving me a strange error when I tried to smooth out a line on my design. I'm not sure what it means, and I assume it's a new 2020 bug. After researching for quite a while, I was not able to find anything related to that error in illustrator.

 

The Error states: "Partially selected objects cannot be set as key objects. In order to set an object as a key object, make sure the entire object is selected and try again."

Not really sure what it's supposed to tell me, but I guess it's a JavaScript bug.

If anyone knows what's up with that and could help, please let me know. It's getting kinda annoying hearing a Mac's error sound every millisecond. Thanks in advance.

 

Screenshot 2020-07-02 at 15.08.37.png

Topics

Bug, Draw and design, Tools

Views

138

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

WHich version exactly is it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

Latest update 24.2.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

Did you reset the preferences after the update?

And then what are you doing step by step?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

I did yes.

I Image Traced a picture of a head that I wanted to use for a Logo I was making, and I was smoothing out some edges because the trace was too rough. So I began using the Smooth Tool when suddenly for the first time this error appeared. I had to restart Ai for the Error to disappear for a while. Then as I was smoothing out the rest of the head, the Error started popping up again, without me doing anything else that could disrupt my process.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

I can't reproduce that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 08, 2020

Copy link to clipboard

Copied

I have the same problem. It worked fine yesterday. Today, I created a few leaves with the Blob brush, then tried to use the smooth tool on one and received the "partially selected objects..." error. I don't understand how this could be related to a "key object" since I'm not trying to align anything. I'm using the latest Illustrator as of 7 days ago on a newer Macbook Pro.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 09, 2020

Copy link to clipboard

Copied

Which version is that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
cydward LATEST
Community Beginner ,
Jul 10, 2020

Copy link to clipboard

Copied

Illustrator 24.2.1 on a 2018 15" Macbook Pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...