IllustratorGc.jsx script error while launching Illustrator 25.3

Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Updated this morning to Illustrator 25.3 - as soon as the update was done this scripting error began appearing (every 30 seconds). .. Personally went back to 25.2.3 which has solved this issue. 

 

Screen Shot 2021-06-08 at 10.01.26 AM.png

 

 

{Renamed by MOD}

TOPICS
Bug, Performance

Views

21.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct Answers

Adobe Employee , Jun 10, 2021 Jun 10, 2021
Hi there, Sorry to hear about your experience. Please check if you have an app installed called "Logi Options" or you have Logitech webcam. If you do, please update it to the latest version & let us know if it helps. Regards, Ashutosh

Likes

Translate

Translate
Adobe Employee , Jun 14, 2021 Jun 14, 2021
Hi all, I hope the issue is resolved by now. If not, please check out this help article ( https://helpx.adobe.com/illustrator/kb/fix-scripting-error.html ) for more details. Regards, Srishti

Likes

Translate

Translate
Community Beginner , Jul 02, 2021 Jul 02, 2021
I think I figured it out! No amount of updating or uninstalling worked. However, in Logi Options, the box for "Create custom settings for specific applications" was enabled by default. I toggled off the button for Application Specific Settings, and the annoying notice is gone in Illustrator. 

Likes

Translate

Translate
replies 114 Replies 114
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about your experience. Please check if you have an app installed called "Logi Options" or you have Logitech webcam. If you do, please update it to the latest version & let us know if it helps.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Already updated the Logi Options to the latest version and it helps nothing to it. Very frustrating.

 

roll back to 25.2.3 is the only option for me. please fix this bug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

This doesn't work. I updated Logi Options, I rebooted, I DELETED Logi options, I rebooted again, I'm still getting the message. Please fix this ASAP.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I had the same issue. For me, Logi option and Illustrator were all latest version. I reinstalled Logi option and the message is now gone.

Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I didn't have to update Logi, but I did turn off “Application Specific Settings” in Logi. This has resolved it on my end.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Note: I was already on the most current version of Logi and I was getting this message. Turning off was the only was to resolve outside of uninstalling Logi.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

yes same for me after contact en remote help from adobe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Had same problem with brand new installs of Logi options and AI. ONLY turning off Application Specific Settings works. Thanks Ismithbarbri! Adobe - please FIX! Need those options! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I tried this and it did not work for me unfortunately, thanks for posting though!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Thanks for the tip, that was getting super annoying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

OMG. You are my hero. This fixed it for me. (Knock on wood, fingers crossed...)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

Yes! That's what worked for me too. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

This solution worked for me too, Logi Options needed updating to the latest version (auto-update was switched on, but for some reason didn't do its job). The intensely infuriating pop up has now stopped popping up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Hi Ashutosh,

 

I am trying to pass the script path as a parameter to Illustrator.exe and It was working for a long time but as soon as 25.3 is installed, I start getting this warning. Is this feature continue to be supported or you guys took it out in 25.3?

 

I didn't have Logi Options Installed but I tried to Install the latest version but It didn't help. 

 

Any help is appreciated !!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Hi Community -

Since updating Illustrator this Morning to version 25.3, I get a permanent "script alert".

The alert pops up every few seconds and majorly disrupts my workflow.

I have neither installed a script or changed any settings from an earliuer version of Illustrator.

Any solutions or thoughts out there?

 

Thanks,

 

Uli

Screen Shot 2021-06-09 at 11.54.59.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi Uli,

 

Sorry to hear about your experience. Please check if you have an app installed called "Logi Options". If you do, please update it to the latest version & let us know if it helps.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi Ashutosh,

 

thank you for pointing this out. Indeed, I have the app installed as I use Logitech Mouse and Keys. I updated from version 8.50xxx to 8.54xxx and the error went away after a restart of the computer. However, after launching Photoshop a service message appeared saying that the certificate for the Logitech extension was not properly signed. I will monitor this and see if other issues persist. Will be sure to update the Logi app regularly.

 

Thanks for your  quick feedback.

 

Uli

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

This doesnt work, i updated the app but still have this annoying message popping up every 30 seconds making illustrator completely unusable!!! What is the solution??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Same situation here.  I just installed Logi Options and Illustrator a few days ago on a new MBP, and I'm getting the error every 30 seconds when I use illustrator.  I checked, and they're both the most recent releases.  
Is there a solution for this if you're already up to date? 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

That worked for me Ashutosh! - Thank you. I am using a Logitech MX Master 3 mouse. Just updated to the latest software and the pop-up went away.

 

Thanks, . . . . Rick

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Just getting this weird message after updating to the latest version of AI.

"You are about to run the script contained in the file "illustratorGc.jsx". Are you sure you want to do this? or, select Learn more for information on using scripts in Illustrator and disabling this message. "

I keep canceling it and it keeps popping up.  I have no third party plugg-ins or scripts running in illustrator

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

i belive it was logitech options...uninstalled it but latest version of illustrator is unresponsive to the point of being unusable. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about your experience. You may try using Creative Cloud Cleaner Tool to remove the existing installation & reinstall once done.

For the script error, please install the latest version of Logitech Options. Let us know how it goes.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I had the same error and got mad about Illustrator being unusable for several hours even I was busy.

One thing I tried was downgrading the program to 25.2.3 from the Creative Cloud and the problem has been solved. No annoying popup showing up.
Sad thing that I can't use the latest Illustrator version for now, but I bet Logitech is the one who should update Logi Options for this urgent bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines