Highlighted

Keyboard layout defaults to US and ruins shortcuts

Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Hi,

I'm having this issue for a long time and I decided to look for help now. In Both Illustrator and Photoshop, my keyboard layout is not being recognized. Instead, both software recognize my keyboard layout as being US default, and mey shortcuts are a mess... My Windows 10 configuration is correct, I believe. I run a version of Windows that is in English, but my keyboard is configured to Brazilian Portuguese ABNT2. I have no other layouts in my list, so I don't believe this is the case where the OS is switching layouts by itself, because there really isn't any other layout installed but the one I mentioned (Brazilian Portuguese ABNT2). However, In Illustrator - or Photoshop -, it is as though my keyboard layout was American and the shortcuts work according to that layout, which is driving me nuts! Does anyone know how to fix this, please? Is there anyone to tell Illustrator what keyboard layout I have and /or want to use?

Thanks all!

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Keyboard layout defaults to US and ruins shortcuts

Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Hi,

I'm having this issue for a long time and I decided to look for help now. In Both Illustrator and Photoshop, my keyboard layout is not being recognized. Instead, both software recognize my keyboard layout as being US default, and mey shortcuts are a mess... My Windows 10 configuration is correct, I believe. I run a version of Windows that is in English, but my keyboard is configured to Brazilian Portuguese ABNT2. I have no other layouts in my list, so I don't believe this is the case where the OS is switching layouts by itself, because there really isn't any other layout installed but the one I mentioned (Brazilian Portuguese ABNT2). However, In Illustrator - or Photoshop -, it is as though my keyboard layout was American and the shortcuts work according to that layout, which is driving me nuts! Does anyone know how to fix this, please? Is there anyone to tell Illustrator what keyboard layout I have and /or want to use?

Thanks all!

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 22, 2017 1
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

They have always behaved like that.

Running a multi-language setup means trouble.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

That's the point, I don't run a multi-language set-up. I run a single language, English Windows 10 set-up, the only thing si I have a non-standard American English keyboard... How is it possible Illustrator won't recognize my keyboard layout!??? We're talking Adobe Illustrator, not some kiddo home-made app, gee

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 1
Adobe Employee ,
Jun 22, 2017

Copy link to clipboard

Copied

Hi prubini,

Please try to install Illustrator in Brazilian Portuguese version and check if that solves the problem.

For that open creative cloud desktop app and uninstall Illustrator

uninstall Ai.png

And then change language from creative cloud

Click settings Icon >click preferences

CCDA prefrences.png

Choose App language to Portugues do Brasil

install.png

Then reinstall Illustrator from creative cloud.

Please share the result as we could not check it our end unfortunately.

Regards

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Hello Srishti,

I'll try it later on today or tomorrow but, if that works, I'll have to get back to the English version anyways, because I need my Adobe products in English for a numbers of reasons. I'll get back with feedback once I have any! I'm only sorry Illustrator won't simply pick up Window's current keyboard layout, at least at startup...

Sincerely,

Pedro Rubini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Srishti,

I've just done as you suggested and it didn't fix the problem. Installing Illustrator in Brazilian Portuguese doesn't help it changing its keyboard layout internally at all. US english remains its keyboard layout, even though its interface is now in Portuguese. Do you have any other ideas?

Cheers,

Pedro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

Pedro, did you manage to solve the problem? I'm having the exactly the same issue here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 0
Community Beginner ,
Jul 30, 2020

Copy link to clipboard

Copied

Hi there, 

I regret to inform thatthe issue remains completely unadressed. Adobe doesn't even think it's an issue, from my understanding. If you want to use the Adobe Suite in English, you need to buy an american/english keyboard, or remap your shortcuts manually. There's maybe a plugin which could do that "automatically", but I haven't found it so far! I barely use Adobe software anymore, anyway. Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 1
Retroker LATEST
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

Thank you so much for responding such an old topic!

Just to keep it registered (this is not important to you now), this issue is so bizarre that even remapping the shortcuts manually couldn't solve it, because when you are within the remapping menu the Illustrator does see a ABNT2 keyboard! But when you are actually using the defined shortcuts the keyboard is seen as an English one and they just don't work properly.
For instance:
Here I've defined the Bring to Front and Bring Forward as default, i.e. Shift+Ctrl+] and Crtl+], respectively. As you can see, Illustrator even show these shortcuts to me on workspace.

 

Retroker_1-1597258828401.pngRetroker_2-1597258835128.png

 

However, these key combinations do nothing in practice and to get the actions of Bring to Front and Bring Forward, I must press Shift+Ctrl+[ and Crtl+[, respectively.

Furthermore, to perform Send to Back and Send Backward, I must press Shift+Ctrl+´ and Crtl+´, respectively.

 

Quite confusing -_-'

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2020 0