Highlighted

Latest Illustrator update (24.2) entire software not working.

Community Beginner ,
Jun 20, 2020

Copy link to clipboard

Copied

So after updating to the latest version of Adobe Illustrator (24.2), the software just doesn't want to respond when it opens up. It opens and shows the 'what's new' panel, I try to close that or just do anything, even close down the app using the cross - nothing works. I leave it for 5 minutes and still to no avail. I have to task manager it to end the process to close it. Ive reverted back to version 24.1.3, that works fine.

 

I've resinstalled it like 5 times now. I would reset the preferences and what not, but as I said I can't do anything, anyway I'm pretty sure they get reset once you unistall/reinstall. Oh and it doesn't throw any error message, else I would have reported it that way.

 

If it helps, I'm running on a Gigabyte Aero 15X | 1070-MaxQ | I7-8750H | 64bit Windows 10.

 

Can anyone help me? Is anyone else having the same problem???

 

P.S - Sorry if this is in the wrong thread - with it being an Illustrator problem, you know.

Correct answer by MrMinks | Community Beginner

So I just went onto a remote support with Adobe themsleves and I got the problem fixed in a group effort. The problem seemed to have lied with the NVIDIA display drivers. I've decided that I'll help anyone with this issue and put what helped fix it for mine, down below.

 

1. What we did first was to go into the "Device Manager" on Windows (just search for it).

2. Go down to where it says "Display Adaptors" and then right click the "NVIDIA ****" adaptor and "disable device.

3. Click "YES".

4. Go to your NVIDIA GeForce app and clcik "DRIVERS" at the top left part of the app.

5. Near "CHECK FOR UPDATES" there is a icon that loooks like 3 dots on top of eachother, click that and then choose "Studio Driver".

6. Install the latest studio driver - I chose to do the quick installation, NOT the custom installation.

7. While that istalls, go back to the device manager and re-enable the "NVIDIA ****" adaptor that you disabled earlier.

8. Wait for the studio driver to finish installing/updating and try the latest Illustrator version (24.2) again.

9. Wallah, there you go 🙂

 

Hope that helps anayone with the same problem as I had , it fixed mine. If this doesn't fix yours just get a chat going with Adobe Support - I'm sure they'll help.

Topics

Bug, Performance

Views

180

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Latest Illustrator update (24.2) entire software not working.

Community Beginner ,
Jun 20, 2020

Copy link to clipboard

Copied

So after updating to the latest version of Adobe Illustrator (24.2), the software just doesn't want to respond when it opens up. It opens and shows the 'what's new' panel, I try to close that or just do anything, even close down the app using the cross - nothing works. I leave it for 5 minutes and still to no avail. I have to task manager it to end the process to close it. Ive reverted back to version 24.1.3, that works fine.

 

I've resinstalled it like 5 times now. I would reset the preferences and what not, but as I said I can't do anything, anyway I'm pretty sure they get reset once you unistall/reinstall. Oh and it doesn't throw any error message, else I would have reported it that way.

 

If it helps, I'm running on a Gigabyte Aero 15X | 1070-MaxQ | I7-8750H | 64bit Windows 10.

 

Can anyone help me? Is anyone else having the same problem???

 

P.S - Sorry if this is in the wrong thread - with it being an Illustrator problem, you know.

Correct answer by MrMinks | Community Beginner

So I just went onto a remote support with Adobe themsleves and I got the problem fixed in a group effort. The problem seemed to have lied with the NVIDIA display drivers. I've decided that I'll help anyone with this issue and put what helped fix it for mine, down below.

 

1. What we did first was to go into the "Device Manager" on Windows (just search for it).

2. Go down to where it says "Display Adaptors" and then right click the "NVIDIA ****" adaptor and "disable device.

3. Click "YES".

4. Go to your NVIDIA GeForce app and clcik "DRIVERS" at the top left part of the app.

5. Near "CHECK FOR UPDATES" there is a icon that loooks like 3 dots on top of eachother, click that and then choose "Studio Driver".

6. Install the latest studio driver - I chose to do the quick installation, NOT the custom installation.

7. While that istalls, go back to the device manager and re-enable the "NVIDIA ****" adaptor that you disabled earlier.

8. Wait for the studio driver to finish installing/updating and try the latest Illustrator version (24.2) again.

9. Wallah, there you go 🙂

 

Hope that helps anayone with the same problem as I had , it fixed mine. If this doesn't fix yours just get a chat going with Adobe Support - I'm sure they'll help.

Topics

Bug, Performance

Views

181

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 20, 2020

Copy link to clipboard

Copied

I have same problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

Hey Darvin, I've just posted the solution to my problem in the same thread - if you wanna try that, it might help you 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 20, 2020

Copy link to clipboard

Copied

Do you have any third party plugins installed?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 21, 2020

Copy link to clipboard

Copied

Nope.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 21, 2020

Copy link to clipboard

Copied

The most terrible update! The Illustrator and InDesign have become disgusting! The Illustrator may not start at all the first time, only restarting the computer saves. Terrible! I haven't seen such disgusting work from Adobe since the CS3 version

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

Hey MYST, I've just posted the solution to my problem in the same thread - if you wanna try that, it might help you 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

so cute! tnx. But i have Mac OS...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

So I just went onto a remote support with Adobe themsleves and I got the problem fixed in a group effort. The problem seemed to have lied with the NVIDIA display drivers. I've decided that I'll help anyone with this issue and put what helped fix it for mine, down below.

 

1. What we did first was to go into the "Device Manager" on Windows (just search for it).

2. Go down to where it says "Display Adaptors" and then right click the "NVIDIA ****" adaptor and "disable device.

3. Click "YES".

4. Go to your NVIDIA GeForce app and clcik "DRIVERS" at the top left part of the app.

5. Near "CHECK FOR UPDATES" there is a icon that loooks like 3 dots on top of eachother, click that and then choose "Studio Driver".

6. Install the latest studio driver - I chose to do the quick installation, NOT the custom installation.

7. While that istalls, go back to the device manager and re-enable the "NVIDIA ****" adaptor that you disabled earlier.

8. Wait for the studio driver to finish installing/updating and try the latest Illustrator version (24.2) again.

9. Wallah, there you go 🙂

 

Hope that helps anayone with the same problem as I had , it fixed mine. If this doesn't fix yours just get a chat going with Adobe Support - I'm sure they'll help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
y14 LATEST
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

I faced the same problem but I cannot find the NVIDIA GeForce app, would you please help me locate it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...