Latest update not compatible with MacOS High Sierra

New Here ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

I have a pretty old iMac running MacOS High Sierra. Now CS is telling me the latest updates for Photoshop/Illustrator/InDesign aren't compatible and I need to update my MacOS. Except my old machine can't update to the latest MacOS. What the hell do I do now? Is there a way around this? I can't afford a new Mac! HELP!!

TOPICS
Bug, How to

Views

205

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jun 27, 2021 Jun 27, 2021
Which versions are you using at the moment? And yes, if you can no longer update your OS there is nothing you can do except stick with the last versions that work.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

Then you can't update.

So just don't update. And see that you keep the old installers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

That's what I thought.

 

Except the apps now take ten times as long to load, and don't function properly once they have started up. It's incredibly frustrating. This always happens when the apps need to be updated, but as I can no longer update, do I just have to put up with the frustration?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

LATEST

Which versions are you using at the moment?

And yes, if you can no longer update your OS there is nothing you can do except stick with the last versions that work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines