Mac OS GPU causing horrible color flicker

Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

The colors in Illustrator documents frequently flicker when the mouse is moved. Turning off GPU performance fixes this issue but slows down Illustrator to the point of being unusable. The flickering is between higher and lower saturation. It's subtle, but enough to give me a headache. It flickers on laptop screen and also on external display if connected.

 

This doesn't always happen, so maybe there's an additional cause. I assume this is just a horrible bug, but has anyone found a work-around?

 

Macbook Pro 2019 Big Sur / Illustrator 2021 25.2.1

Standard Factory GPUs:

Radeon Pro Vega 20 4 GB

Intel UHD Graphics 630 1536 MB

 

Thanks!

 

TOPICS
Bug, Draw and design

Views

82

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Is the automatic GPUswitching turned on in the system preferences and can you turn that off?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Thanks for your reply.

 

I don't see that option in the Mac OS system preferences. AI prefs has checkboxes for GPU Performance and Animated Zoom, both of which ar turned on because I need them.

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I'm. having this same issue now. GPU switching is under the Energy / Battery preference in your System Preference menu (that apple icon menu). 

 

I have mine turned off but I'm still getting the flickering. I think this is a new issue as I don't recall it happening before.

 

Any tips?

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

LATEST

Looks like if you turn off/on the GPU perfomance in Illustrator that fixes it. It did for me (for now anyway).

Hope this helps.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines