Highlighted

Mask does not retain proper opacity when saving as pdf and emailing file

Community Beginner ,
Jan 10, 2018

Copy link to clipboard

Copied

I'm having a problem with Illustrator not retaining the proper transparency of my clipping masks when I am doing a gradient fade.

Essentially, I am trying to create a fade from 0% opacity to 100% opacity. I achieve this affect by placing a gradient box over my objects, selecting all objects including the gradient box, then clicking on "Make Mask" in my transparency window. The effect looks exactly as it should while in Illustrator.

I save a copy of the file as an editable PDF and open it on my computer in Acrobat and it still looks good.

However...

When I email the file or transfer it via thumbdrive to another computer the opacity gets all messed up and I can clearly see the objects where they should be totally transparent. It doesn't matter what program I try, the opacity is wrong.

It is worth noting that when I save the pdf by going to file>print>pdf it looks fine. It also looks fine if I save as a png. The issue occurs when I save as an editable pdf that is transferred or emailed (even if I email it to myself and open it on the same computer this happens). I noticed that it also happens if I open the pdf in Photoshop.

I have attached a sample image. The stars on the left are what I want.

Any ideas? Please help, this is driving me crazy and I have an assignment due! Thanks in advance!sample-star-gradient-mask-test.jpg

Adobe Community Professional
Correct answer by Barbara Ash | Adobe Community Professional

It can be solved if you set up the gradient mask differently.

Instead of a black to white gradient for the mask, use these settings:

Where you want the stars to show, use 100% white, as shown for the gradient slider on the right.

Where you want the stars to be hidden, as shown for the gradient slider on the left, use 0% opacity instead of black. Where it is zero % opacity it will act the same as black.

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mask does not retain proper opacity when saving as pdf and emailing file

Community Beginner ,
Jan 10, 2018

Copy link to clipboard

Copied

I'm having a problem with Illustrator not retaining the proper transparency of my clipping masks when I am doing a gradient fade.

Essentially, I am trying to create a fade from 0% opacity to 100% opacity. I achieve this affect by placing a gradient box over my objects, selecting all objects including the gradient box, then clicking on "Make Mask" in my transparency window. The effect looks exactly as it should while in Illustrator.

I save a copy of the file as an editable PDF and open it on my computer in Acrobat and it still looks good.

However...

When I email the file or transfer it via thumbdrive to another computer the opacity gets all messed up and I can clearly see the objects where they should be totally transparent. It doesn't matter what program I try, the opacity is wrong.

It is worth noting that when I save the pdf by going to file>print>pdf it looks fine. It also looks fine if I save as a png. The issue occurs when I save as an editable pdf that is transferred or emailed (even if I email it to myself and open it on the same computer this happens). I noticed that it also happens if I open the pdf in Photoshop.

I have attached a sample image. The stars on the left are what I want.

Any ideas? Please help, this is driving me crazy and I have an assignment due! Thanks in advance!sample-star-gradient-mask-test.jpg

Adobe Community Professional
Correct answer by Barbara Ash | Adobe Community Professional

It can be solved if you set up the gradient mask differently.

Instead of a black to white gradient for the mask, use these settings:

Where you want the stars to show, use 100% white, as shown for the gradient slider on the right.

Where you want the stars to be hidden, as shown for the gradient slider on the left, use 0% opacity instead of black. Where it is zero % opacity it will act the same as black.

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 10, 2018 0
Adobe Community Professional ,
Jan 10, 2018

Copy link to clipboard

Copied

It can be solved if you set up the gradient mask differently.

Instead of a black to white gradient for the mask, use these settings:

Where you want the stars to show, use 100% white, as shown for the gradient slider on the right.

Where you want the stars to be hidden, as shown for the gradient slider on the left, use 0% opacity instead of black. Where it is zero % opacity it will act the same as black.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0
Participant ,
Jan 10, 2018

Copy link to clipboard

Copied

Hi, can you check this article, it seems that have your same issue and there is a solution for it

How to print and save transparent artwork in Illustrator

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0
Adobe Community Professional ,
Jan 11, 2018

Copy link to clipboard

Copied

You mean an opacity mask?

Document color mode is important in this.

Is the document RGB or CMYK?

If it's RGB, don't use greyscale in the gradient. It will then not be converted to RGB 000.

Also when opening this in other apps or another Illustrator version, do you convert the document color mode?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2018 0
Community Beginner ,
Jan 11, 2018

Copy link to clipboard

Copied

Thank you everyone for your feedback! Barbara Ash - your answer was the solution. Lowering the black to 0% did the trick. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2018 0
Adobe Community Professional ,
Jan 11, 2018

Copy link to clipboard

Copied

You're welcome. Glad that tricky issue was solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2018 0
Explorer ,
Sep 29, 2020

Copy link to clipboard

Copied

Yeah I had the opposite experience. My PDF's weren't honoring the opacity when I did white at 0%, which is why I came here in the first place. For whatever reason, mine had to be black at 0% for it to work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2020 0