New 2019 CC Illustrator Update Breaks Align Distribution Spacing

Community Beginner ,
Feb 14, 2019 Feb 14, 2019

Copy link to clipboard

Copied

I recently updated to the latest version of 23.0.1.  Everything works properly except in the align tab for spacing the unit parameters is broken.  I use inches for everything besides stroke.  Once updated the field for spacing defaulted to an unknown unit, couldn't even override it by typing in the unit manually.  Had to reinstall the previous version as I use this function hourly and was very frustrating.  Hoping to make the problem aware so it can be fixed in the next update, don't want to be stuck not being able to.

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Employee , Sep 01, 2020 Sep 01, 2020
Hi there, We have tried to fix this in our recent release for Illustrator 2020 (v 24.3) which contains some stability fixes. If you are not already on v24.3, then we recommend you to update to latest version and share your observations with us.  Regards!

Likes

Translate

Translate
Community Beginner , Apr 19, 2021 Apr 19, 2021
Still the best fix so far from this intital post I made 2 years ago is to go to preferences / units / change stroke from points to inches.  Close box and then go back and do it again to switch stroke back to points.  For some reason that fixes it until you have to reopen the program.  2 years later and still a problem.  I dunno, that's the workaround but still waiting for that one magic update that will solve this sillyness.  

Likes

Translate

Translate
Adobe Community Professional ,
Feb 14, 2019 Feb 14, 2019

Copy link to clipboard

Copied

The latest version is 23.0.2 and I don't see what you are describing.

Can you share a screenshot that illustrates the issue?

Also, Windows or Mac version of Illustrator?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2019 Feb 14, 2019

Copy link to clipboard

Copied

Windows and yes I see that it was .2 version now.  I work in 10 scale for my projects as I do design work for a sign company and it's too large to go full size.  In the new version I would try and space 3 lines 13in apart (so 1.3 in scale) and I have no idea what units that illustrator is defaulting to but is spacing them .008 in apart approximately.  As there is no unit popping up in the text field like there usually is I don't know.  I already uninstalled the new version to fix the problem and I am back to normal now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2019 Apr 25, 2019

Copy link to clipboard

Copied

Travis,

Unrelated to the main subject, why not work in 1:6 if possible and just create everything in picas so you can use exactly the same numerical values as the desired final values in inches, as in 13 picas apart which will become 13 inches apart?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

this is really helpful, thanks for this!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 20, 2019 Mar 20, 2019

Copy link to clipboard

Copied

Still waiting for an update on this

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2019 Apr 25, 2019

Copy link to clipboard

Copied

The issue appears to be that the Distribute Spacing input is set to points at software startup, regardless of the user's selected unit of measure in preferences. Mine is set to inches and the box for Distribute Spacing in the Align panel says "0" with no denoted unit of measure. A little trial and error testing shows it's using points as the default.

I can get the function back to correct by going into preferences and setting a different unit of measure, clicking OK, then going *back* into preferences and setting it back to the unit of measure I want to actually use. Then the box in Distribute Spacing will say "0 in" if I set to inches.

Occasionally I'll notice it's fixed itself somehow, when I have multiple documents open. I haven't been able to determine what causes it to self-correct though. I suspect it may have something to do with opening a document(s) that were originally saved when the function was working correctly.

...but I really hate having to do that everytime I start Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2019 Apr 25, 2019

Copy link to clipboard

Copied

I suggest to report it here:

Adobe Illustrator Feedback

There is another problem mentioned that looks partially similar:

Illustrator CC 23.0.2 Align Distribute not working correctly MacOS Mojave 10.14.3 – Adobe Illustrato...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

It's odd how the statement of the problem has been marked as "Correct Answer"

But I can confirm this issue.

When .02 rolled out the Align / Distribute by a key object does not work properly. If set to .25 inches, it should space the objects by .25 inches...instead if you put .25 in the space option, it doesn't list as inches, mm, or any unit. Instead it seems to space by a small fraction of an millimeter.

I noticed this ( as well as other previous bugs ) in 23.0.2 when it was released, after many attempts to fix I ended up rolling back to 23.0.1.

Just yesterday, I performed a 100% clean installation of windows 10, and tried installing 23.0.2 and tested the problem. It still persists.

For what it's worth, I am a paid professional designer with over 20 years experience utilizing adobe products for almost all projects. It's safe to say multiple adobe products are industry standard. Rather than make paying customers the beta testers to find bugs that hinder their work flow, possibly have a beta download and a stable download so that people who use adobe programs aren't suffering. The growing amount of bugs that have been popping up on every release and not being fixed has our company looking at other options.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

i thought i was going crazy too.  very similar situation, plenty of experience w Adobe, large format signage, new install (on new workstation) and coming from an older version of Illustrator since i hate the upgrade changes.

i noticed my Align>Distribute Spacing>Align To was not creating the correct spacing i had indicated in the form fill (.5 in).  It did seem to be very small spacing (points, i assumed).  i entered the value of 36 (points = .5 in, if 9 pts = .125") and it correctly spaced my objects the half inch i needed.  Since it accepted my value, it toggled back to ".5 in" in the palate, so i can enter ".75" for three-quarters of inch, back to my normal workflow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Adobe is driving me nuts. With every update it changes my preferences. Files that have been in inches for years keep reverting to points and now "distribute by" is not honoring inches. It's almost as if the developers are insisting that they understand our workflow better than us.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

I can attest this is still a problem in 24.0.3 Typically Illy allows you to choose your measurement by typing px, in., etc. but not with distribute. At the very least, the dialogue should indicate which form of measurement is begin defaulted without one having to veify in preferences. For sure, this slows me down.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 22, 2020 Jul 22, 2020

Copy link to clipboard

Copied

yes same here, still a problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2020 Jul 28, 2020

Copy link to clipboard

Copied

Just updated Illustrator today and its still broken.

If i draw squares arcross the artboard randomly and then use any of the 3 horizontal distribution buttons they just collapse all of the objects together. This is also true for the 3 vertical distribute buttons.  I use this tool allot but i can't now as its broken. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 28, 2020 Jul 28, 2020

Copy link to clipboard

Copied

Did you reset the preferences when updating?

And then also set the "Align to" option?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 28, 2020 Jul 28, 2020

Copy link to clipboard

Copied

can you give more info on where/how to deal with that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

This is still an issue. I keep updating as soon as updates become available hoping this will be fixed as it is a major bug and slows down work efficiency drastically. But still it is happening.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

Hi there,

 

We have tried to fix this in our recent release for Illustrator 2020 (v 24.3) which contains some stability fixes. If you are not already on v24.3, then we recommend you to update to latest version and share your observations with us. 

 

Regards!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Hello can someone please untick this as being the correct answer, as that upgrade did not fix the issue, and in later updates post that update, it is still buggy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

This issue became worse for us in 25.0  Not only are the units defaulting incorrectly, but you must have the distribute dialogue visible before choosing the control object.  If you choose a set of objects, then choose a control object without the dialogue visible, when you open the dialogue the option to distribut is greyed out, as if no control object were chosen.  You must then deselect the control object, REselect the control object, after which the action becomes available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

It seems to be partially fixed in 25.0.1  By that I mean the units are now correct inside the box.  But if you don't have that box visible when you choose a key object, then the box appears grey (unusable) when you switch to the Align tab.  However it only *appears* unusable.  You can click it and it works, although you cannot change the box value until you click the first time, which changes its state to active.  So there is still a minor cosmetic glitch, but much improved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2021 Feb 16, 2021

Copy link to clipboard

Copied

Here's a potential workaround:

  1. Go to 'Illustrator > Preferences... > Guides & Grid...'.
  2. Uncheck or check the box for 'Show Pixel Grid (Above 600% Zoom)'.
  3. Click 'OK'.
  4. Select objects to distribute, click on a 'Key Object', then see if the 'Distribute Spacing' value now has a measurement label (.e.g. "in", "pt", etc.).

This works for me using v24.0.1 on Mac.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I am on Windows, and that does work for me. It's also easier than the workaround I was using, which was to change the unit types in Preferences twice.

 

What we had noticed is that the units' label was missing from the box and those units were invisibly defaulted to something other than what we had specified, i.e inches.  I think it was always treating the box as *points* during an ordered distribution.  So changing the units, then changing them back was the workaround.

 

This comes up after a glitchy restart, one where Illustrator forgets all its recent files, etc.  I will need to wait for the next one of those to see if your workaround corrects the units rather than merely revealing them, which is still very helpful so thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

For Version 25.2 I can confirm that toggling Show Pixel Grid fixes the issue in all respects, except it does not fix the problem of the input box being initially inaccessible if the key object was selected while the Align tab was not active.  But that's pretty minor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

Still the best fix so far from this intital post I made 2 years ago is to go to preferences / units / change stroke from points to inches.  Close box and then go back and do it again to switch stroke back to points.  For some reason that fixes it until you have to reopen the program.  2 years later and still a problem.  I dunno, that's the workaround but still waiting for that one magic update that will solve this sillyness.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines