Highlighted

PDF created with Illustrator is showing hidden layers. Sometimes.

Community Beginner ,
Apr 06, 2017

Copy link to clipboard

Copied

I admit I am an Illustrator noob. I'd like to understand what is happening here, and avoid it if I can. I created a PDF from an illustration, after hiding a couple of layers. I thought that the PDF would only have the layers that were visible, and when I open it in all the various readers I have on my PC, that was the case. Recently, though, a friend printed it from his Mac (I'm not sure which app), and ALL the layers printed on top of one another. How can I prevent that extra information from being in the PDF in the first place? TIA!

Correct answer by caresrg | Community Beginner

My friend was finally able to get back to me after I sent an experiment file with "Create Acrobat layers" UNchecked. I also unchecked keeping it editable, though that probably has nothing to do with anything, but when a very busy friend was helping with an experiment I only wanted to take one shot. It worked! I'd be curious to see whether it works for you if you only uncheck creating the layers.

Thanks everyone for your help!

Views

8.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PDF created with Illustrator is showing hidden layers. Sometimes.

Community Beginner ,
Apr 06, 2017

Copy link to clipboard

Copied

I admit I am an Illustrator noob. I'd like to understand what is happening here, and avoid it if I can. I created a PDF from an illustration, after hiding a couple of layers. I thought that the PDF would only have the layers that were visible, and when I open it in all the various readers I have on my PC, that was the case. Recently, though, a friend printed it from his Mac (I'm not sure which app), and ALL the layers printed on top of one another. How can I prevent that extra information from being in the PDF in the first place? TIA!

Correct answer by caresrg | Community Beginner

My friend was finally able to get back to me after I sent an experiment file with "Create Acrobat layers" UNchecked. I also unchecked keeping it editable, though that probably has nothing to do with anything, but when a very busy friend was helping with an experiment I only wanted to take one shot. It worked! I'd be curious to see whether it works for you if you only uncheck creating the layers.

Thanks everyone for your help!

Views

8.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 06, 2017 0
Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

Hi Tia,

To really answer your question, I may be necessary to know which app your friend printed your PDF in. To get a better sense of what is going on, can you tell me if there hidden layers are on your artboard? Also does the same thing happen when you export the project as a png?

-Megan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 1
Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

Another suggestion I have is making sure these options are clicked when you export the PDF.Screen Shot 2017-04-06 at 12.42.12 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 1
Community Beginner ,
Apr 06, 2017

Copy link to clipboard

Copied

Yes, there are hidden layers. Those are what I don't want in the PDF. I don't know which app he used, and he is too busy at work to help me figure this out, but it really shouldn't matter (although it would be admittedly nice to test out). I'm wondering if unchecking the "preserve Illustrator Editing Capabilities" and unchecking "create Acrobat Layers from Top-Level Layers" in the dialog you show might work?

Do you know why the data was getting into my PDF, regardless of which app was used to print it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

Hi Caresrg,

Is there a reason you are keeping the hidden layers in the AI document? If there is, that is completely fine. Would you mind taking a screenshot of what the PDF panel looks like when you do Save As>PDF>then a panel should appear? The screenshot I provided above is what your panel should look like with those elements clicked.

The reason I asked about the software he used is because the automatic PDF reader on a Mac is Preview and I have found in the last few months that Preview reacts badly with PDFs versus when I open them and print them from Adobe Acrobat.

-Megan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 1
Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

Also I just hide some layers in one of my documents, exported as a PDF and printed and the layers were still hidden. So have you also tried copying the layers and moving them into a new document and trying to export. There may be a bug with the specific AI file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Adobe Community Professional ,
Apr 06, 2017

Copy link to clipboard

Copied

If you don't want to see the hidden layers in your pdf, delete them.

Acrobat will hide the layers that are supposed to be hidden, but they are still there and can be turned on.

Other PDF viewers, like Preview on the Mac, will ignore that and show the hidden layers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Community Beginner ,
Apr 07, 2017

Copy link to clipboard

Copied

Sorry for the slow reply, folks, I'm visiting my niece at her college this week and working while she's in class. If Preview for Mac prints all layers, I'm sure that's what he's using. I do need to keep the layers in the source doc; we use different versions sometimes. Below is a screenshot with all the layers showing, and below that are the settings I used (with only the desired layer showing, of course), but I'm wondering if unchecking the Create Acrobat Layers would help.

Capture2.JPGCapture.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2017 0
Explorer ,
Apr 07, 2017

Copy link to clipboard

Copied

Hi Caresrg,

I would try exporting it by unclicking "create acrobat layers from top-level layers" as you said. I completely understand the need to keep hidden layers, but it is definitely a strange occurrence that this is happening. I played a lot with hidden layers yesterday in Illustrator and I still could not get the hidden layers to appear. If this keeps happening you could take the Illustrator file and open it in InDesign and export it from there. I know that is a very backwards way of handling the issue, but I have seen other people have success with that. Let me know what happens.

-Megan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2017 0
Adobe Community Professional ,
Apr 07, 2017

Copy link to clipboard

Copied

I would save various versions.

Your AI source doc, containing all layers.

And versions where the hidden layers are deleted and saved as PDF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2017 0
Community Beginner ,
Apr 12, 2017

Copy link to clipboard

Copied

This seems to only happen when the file is viewed in Apple's Preview app and nowhere else. Saving various versions is not really an efficient solution, and deleting layers you don't want to be published makes no sense if they are integral to your file in some way. I've only been able to identify the program this issue appears in. When time permits I'll  try a variety of settings to see what works (or doesn't). I don't think "Create Acrobat Layers For Top Level_Layers" works in this case when Apple's Preview sees the hidden layer(s) which is also at the very top of the layer stack.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2017 0
Community Beginner ,
Apr 12, 2017

Copy link to clipboard

Copied

My friend was finally able to get back to me after I sent an experiment file with "Create Acrobat layers" UNchecked. I also unchecked keeping it editable, though that probably has nothing to do with anything, but when a very busy friend was helping with an experiment I only wanted to take one shot. It worked! I'd be curious to see whether it works for you if you only uncheck creating the layers.

Thanks everyone for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2017 0
Explorer ,
May 08, 2017

Copy link to clipboard

Copied

Have you figured out a resolution?  I'm having this same problem.  I cannot get .AI's non-print layers to show in Apple Finder's Preview.  Or, any print layer below the top layer.  It only shows the top layer.  I have a ticket with Apple and their engineering team review.  They said it's a problem with Adobe Illustrator itself - and not Apple.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 0
Community Beginner ,
May 08, 2017

Copy link to clipboard

Copied

Yours actually sounds like the opposite of mine. So when you create the PDF, try making sure "Create Acrobat Layers" is checked. That's all I've got; I'm a noob.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 0
Explorer ,
May 08, 2017

Copy link to clipboard

Copied

Yup - I'm using Illustrator to create the PDF - when "Create Acrobat Layers" is checked (or UNchecked for that matter) - it still won't show those layers underneath in Apple's Preview (or Finder's Preview).

But, even when I'm not creating a PDF - I'm creating a .AI file, there's no option that says "create Acrobat Layers".

How can we get Adobe to look in on this bug for us mac users?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 0
Adobe Community Professional ,
May 08, 2017

Copy link to clipboard

Copied

autumnf81148833  schrieb

Yup - I'm using Illustrator to create the PDF - when "Create Acrobat Layers" is checked (or UNchecked for that matter) - it still won't show those layers underneath in Apple's Preview (or Finder's Preview).

But, even when I'm not creating a PDF - I'm creating a .AI file, there's no option that says "create Acrobat Layers".

How can we get Adobe to look in on this bug for us mac users?

This is not a bug. It's just you using an inappropriate viewer application. Apple needs to fix their app to not view hidden layers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 0
Explorer ,
May 08, 2017

Copy link to clipboard

Copied

I wish that was true - I took this issue all the way to Apple's Engineering team (via support ticket) and they said it's Adobe that is causing the issue with Apple's Preview program (and the preview in Apple's Finder).  They said that that Adobe Illustrator is incomptable with the latest Mac Sierra 10.12.4 update. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 1
New Here ,
May 10, 2017

Copy link to clipboard

Copied

EAGERLY AWAITING

A RESOLUTION ON THIS.

(in the meantime we are creating duplicate documents - totally removing layers (that are later needed).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2017 0
Adobe Community Professional ,
May 10, 2017

Copy link to clipboard

Copied

You actually can control that with Print Layers option , then use the Done button and save your .ai, then you .pdf.. Though the wording say "Print" this applies to the creation of PDFs also. So for example choose "Visible Layers" and only the visible layers will show in the pdf.

Screen Shot 2017-05-10 at 5.19.57 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2017 1
Explorer ,
May 10, 2017

Copy link to clipboard

Copied

Looks like a work-around for PDF.  I just want the .AI "non print" layers to show up.  Or, any layer below that to be honest in .AI files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2017 0
Adobe Community Professional ,
May 10, 2017

Copy link to clipboard

Copied

Hi Autumn,

If you want the non-print layers to show up then visible layers will do that, if the layers are hidden then do All layers, and even the hidden ones will show,

We  avoid using apple preview for pdf review as there are too many issues. We have our clients  download the free acrobat reader, as  apple preview is a laymans tool with the problem mentioned and:

  • overprints do not show
  • people cannot save  data when completing forms, and the javascript to email completed form back to us does not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2017 0
Explorer ,
May 11, 2017

Copy link to clipboard

Copied

Thanks for the tip!  PDF won't work for us - we have to us the .AI extension, with all non-print layers visible in Apple's Preview Finder for our workflow.  I have another topic on this posted in the forums for .AI, but this PDF Layer thing seems almost identicle to the issue I was experiencing with .AI files; .AI files in Mac Preview will not show layers (both print and non-print)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
Explorer ,
May 11, 2017

Copy link to clipboard

Copied

FYI - We did the Print Settings on the .AI, but clicked "Done" instead of print - it didn't resolve the issue but instead now our "non-print" layers are now "printing" when we go to engrave them.  So - that workaround deff. does not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
Adobe Community Professional ,
May 11, 2017

Copy link to clipboard

Copied

Yes that is what  is supposed to happen, as that setting is both for PDF and PRINT. Use acrobat and not apple preview and you will see how this works.

Try using quick look  buy selecting a file and hitting the space bar, than might be a better option for you then apple preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
Explorer ,
May 11, 2017

Copy link to clipboard

Copied

Oh gotcha - No we need our "non print" layers to not print at all or else we have waisted material. 

Besides that, the workaround mentioned for showing non-print layers to be visible in Adobe Acrobat ends up only engraving half the art (and engraves the non-print layers) instead of the full sheet of art.  We can't change the "custom size" in the general print settings - it's grayed out.

Working from Adobe Acrobat for PDF's may be helpful for some others.  Unfortunately, since we do not use PDF's for our workflow nor do we use Adobe Acrobat for our workflow, Illustrator truly needs to fix the non-print layer issue in actual Illustrator .AI files for Sierra 10.12.4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
New Here ,
May 11, 2017

Copy link to clipboard

Copied

perfect explanation Mike.

Thanks.

issue resolved.

(not sure why this problem didnt pop up the last 13 years ive been making PDF's for laser cutting, anyway, just glad you helped me solve it.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
New Here ,
May 11, 2017

Copy link to clipboard

Copied

also, im looking for the 'correct' button below your answer - and am not seeing it. sorry.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
Adobe Community Professional ,
May 11, 2017

Copy link to clipboard

Copied

Thanks Don, glad that helped you, many people miss that feature myself included.

Only the orinigal poster can mark an answer as correct. Anyone can click on helpful and/or like.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2017 0
New Here ,
Nov 13, 2019

Copy link to clipboard

Copied

YES!

Turning the acrobat layers off when saving the PDF in Illustrator worked. 

Thank you!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2019 0
New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

Illustrator hiding images it shows in PDF file. Only show in Firefox browser. IE and Chrome are fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

So you import a PDF and the images are done?

Has the PDF been created in Illustrator and has it been saved with "Preserve editing capabilities"?

Otherwise there is no guarantee that you can import it or edit it or whatever.

https://prepression.blogspot.com/2014/09/the-ten-commandments-of-pdf.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

Thank you very helpful!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

Some PDF viewers will ignore layer properties and show all of the layers, even if they are turned off or set to never show. The solution is to only use Acrobat or Reader to view your PDFs, or delete the unwanted PDF layers in Illustrator or Acrobat.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

Yes I have follow your advice and delete the unwanted PDF layers in Illustrator.

Thank you very much! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Resources