Highlighted

PIPL not working

Contributor ,
Apr 12, 2020

Copy link to clipboard

Copied

Hi,

 

I am starting with SDK  development and ty to build sample projects.

Unfortunately the python scripts do not work

File "C:\tmp\Adobe Illustrator 2020 SDK\tools\pipl\pipl_gen\pipl_gen.py", l
  ine 126, in generate_pipl_bin_recursively_from_dict
      file_obj.write(pipl_dict[key]['vendor'])
  TypeError: a bytes-like object is required, not 'str'

I am using python 3.8 from the windows store.

Use Python 2.7 only.

 

I remember, when I started development and installed lastest python 3.8, I got errors.

TOPICS
SDK

Views

593

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PIPL not working

Contributor ,
Apr 12, 2020

Copy link to clipboard

Copied

Hi,

 

I am starting with SDK  development and ty to build sample projects.

Unfortunately the python scripts do not work

File "C:\tmp\Adobe Illustrator 2020 SDK\tools\pipl\pipl_gen\pipl_gen.py", l
  ine 126, in generate_pipl_bin_recursively_from_dict
      file_obj.write(pipl_dict[key]['vendor'])
  TypeError: a bytes-like object is required, not 'str'

I am using python 3.8 from the windows store.

Use Python 2.7 only.

 

I remember, when I started development and installed lastest python 3.8, I got errors.

TOPICS
SDK

Views

594

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 12, 2020 0
Explorer ,
Apr 13, 2020

Copy link to clipboard

Copied

Use Python 2.7 only.

 

I remember, when I started development and installed lastest python 3.8, I got errors.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2020 0
Contributor ,
Apr 13, 2020

Copy link to clipboard

Copied

Many thanks - I just built one of the sample programs fine. Unfortunately, AI refuses to load the plugin and only displays "error loading xxx.aip".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2020 0
New Here ,
Oct 02, 2020

Copy link to clipboard

Copied

Hi @birnerseff 
I am also facing similar issue with Adobe illustrator 2020 SDK , samplecode plugin not loading "error loading xxx.aip"
have you resolved this issue ? any solution would help me .. 

Thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2020 0