Highlighted

Please fix new Clipping Mask Bug

Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

This bug just appeared with the most current version of Illustrator. A child clipping mask shows the color of the shape along the outline of the parent clipping mask. This thin red line shows up in exports of artwork as png/jpg. The line also shows up in Print Ready pdfs.

 

Screen Shot 2020-06-04 at 12.37.06 PM.png

 

Screen Shot 2020-06-04 at 12.36.55 PM.png

 

Screen Shot 2020-06-04 at 12.36.37 PM.png

 

Screen Shot 2020-06-04 at 12.38.22 PM.png

 

Screen Shot 2020-06-04 at 1.31.44 PM.png

 

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

Another thing that you can try (and it may explain your experience with the previous version).

change the anti-aliasing settings for export to Art Optimized.

The default is Type Optimized which is good for type, but not so good for other objects.

TOPICS
Bug

Views

544

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Please fix new Clipping Mask Bug

Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

This bug just appeared with the most current version of Illustrator. A child clipping mask shows the color of the shape along the outline of the parent clipping mask. This thin red line shows up in exports of artwork as png/jpg. The line also shows up in Print Ready pdfs.

 

Screen Shot 2020-06-04 at 12.37.06 PM.png

 

Screen Shot 2020-06-04 at 12.36.55 PM.png

 

Screen Shot 2020-06-04 at 12.36.37 PM.png

 

Screen Shot 2020-06-04 at 12.38.22 PM.png

 

Screen Shot 2020-06-04 at 1.31.44 PM.png

 

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

Another thing that you can try (and it may explain your experience with the previous version).

change the anti-aliasing settings for export to Art Optimized.

The default is Type Optimized which is good for type, but not so good for other objects.

TOPICS
Bug

Views

545

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 04, 2020 0
Adobe Community Professional ,
Jun 04, 2020

Copy link to clipboard

Copied

It is an old problem wth clipping masks.

You could try an Opacity mask instead.

See: https://community.adobe.com/t5/illustrator/clipping-mask-create-fine-outlines/td-p/11116200?page=1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

Ok, thanks! Actually this didn't show up until after the latest update. The file was fine prior to the update as it was created before the latest update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Adobe Community Professional ,
Jun 04, 2020

Copy link to clipboard

Copied

Do you still have an older version of Illustrator?

You could check if that does not show the problem.

As far as I can see the problem exists since many versions (I did check CS6).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Participant ,
Jun 12, 2020

Copy link to clipboard

Copied

No, I have the latest version of Illustrator as indicated above. And ironically, for me, this is the first time this behavior has shown itself even going back to CS6.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Community Professional ,
Jun 12, 2020

Copy link to clipboard

Copied

Did you check this file in an older version?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Participant ,
Jun 12, 2020

Copy link to clipboard

Copied

Like I stated earlier, this file was created with the previous version of Illustrator and didn't show up, for me, until the latest version was installed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Community Professional ,
Jun 12, 2020

Copy link to clipboard

Copied

Then perhaps you did not notice it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Participant ,
Jun 12, 2020

Copy link to clipboard

Copied

Actually, when I exported the file as a png/jpg/pdf with the previous version of Illustrator, the line in question at the top was not there. With the latest version of Illustrator the results of exporting as a png/jpg/pdf the line is present. Same exporting options used in both instances.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Community Professional ,
Jun 12, 2020

Copy link to clipboard

Copied

Can you share the Illustrator file, or the part of it that gives the problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Community Professional ,
Jun 12, 2020

Copy link to clipboard

Copied

Another thing that you can try (and it may explain your experience with the previous version).

change the anti-aliasing settings for export to Art Optimized.

The default is Type Optimized which is good for type, but not so good for other objects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0