Problem moving objects in small increments

Explorer ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

Hey everyone, I've seen this similar question asked before however none of the solutions seemed to help my problem. I am trying to move an object in a pretty small increment, I have the preferences keyboard increment set to its lowest number, but I still need to move my object 1/3 as far. I've also tried to manually move the object to the correct point with my mouse and it just snaps back to the space where it was sitting which was as close as I could get it with arrow keys. I've turned off snap to grid and snap to point, with no change in my result. I'm basically trying to align a smaller triangle over a section of a larger triangle to act as a shading area. Any solutions? Thanks in advance.

TOPICS
Tools

Views

93.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Oct 25, 2014 Oct 25, 2014
mblaney,It does look like the Align to Pixel Grid ghost haunting you, as SRiegel suggested.Or maybe Snap to Grid.Are both unticked (the former when the black triangle is selected)?

Likes

Translate

Translate
Adobe Community Professional ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

Check in the Transform Pallet with the item selected, and make sure that Align to Pixel Grid is not checked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

Thanks for the reply, I'm ussing illustrator CC forgot to mention that, I made sure that option is not checked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

mblaney,

I have the preferences keyboard increment set to its lowest number, but I still need to move my object 1/3 as far

Are you saying that you need to move your object in increments of 1/3 of 0.001pt with the arrow keys?

Edit>Preferences>General>Keyboard Increment goes (at least) down to 0.001pt, and that is what you should get with the Arrow keys, and you should be able to see that in the Transform palette, looking at the X or Y value.

If not, it may be time for the list.

The following is a general list of things you may try when the issue is not in a specific file (you may have tried/done some of them already); 1) and 2) are the easy ones for temporary strangenesses, and 3) and 4) are specifically aimed at possibly corrupt preferences); 5) is a list in itself, and 6) is the last resort.

1) Close down Illy and open again;

2) Restart the computer (you may do that up to 3 times);

3) Close down Illy and press Ctrl+Alt+Shift/Cmd+Option+Shift during startup (easy but irreversible);

4) Move the folder (follow the link with that name) with Illy closed (more tedious but also more thorough and reversible);

5) Look through and try out the relevant among the Other options (follow the link with that name, Item 7) is a list of usual suspects among other applications that may disturb and confuse Illy, Item 15) applies to CC, CS6, and maybe CS5);

Even more seriously, you may:

6) Uninstall, run the Cleaner Tool (if you have CS3/CS4/CS5/CS6/CC), and reinstall.

<

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

Hey Jacob, yes I was saying basically I need to be able to move the object a third of what the smallest increment the keyboard will allow me to use. If i do use my mouse and put the shape exactly where I want it to be placed, it just moves back to the spot where I could get it closest with a keyboard, here are some screenshots so you can see what I'm trying to do: doc.jpgdoc2.jpg

I can't get the black triangle to line up up with the edge of the lighter blude colored shape.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 25, 2014 Oct 25, 2014

Copy link to clipboard

Copied

mblaney,

It does look like the Align to Pixel Grid ghost haunting you, as SRiegel suggested.

Or maybe Snap to Grid.

Are both unticked (the former when the black triangle is selected)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2018 Sep 27, 2018

Copy link to clipboard

Copied

This one got me too! I must not have tried to be so precise in a while because I've never had this issue before.

Thanks!

Eric

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 27, 2018 Sep 27, 2018

Copy link to clipboard

Copied

For my part you are welcome, Eric.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 26, 2019 Dec 26, 2019

Copy link to clipboard

Copied

Thanks a lot!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2014 Oct 25, 2014

Copy link to clipboard

Copied

Ah, thanks guys it was the align to pixel grid, I had unselected the "align new objects to pixel grid" option thinking it was applied to my selected object, and I didn't have the "align to pixel grid" option visible. My fault, thanks again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2016 Apr 26, 2016

Copy link to clipboard

Copied

Can you please post the repro steps on how to uncheck the "Align New Objects to Pixel Grid" and "Align to Pixel Grid" as I'm having difficulty trying to find it myself? Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2016 Apr 26, 2016

Copy link to clipboard

Copied

Select all the objects and then uncheck "ALign to pixel grid"

Then uncheck "Align new objects to pixel grid"

It's in the transform panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2016 Apr 26, 2016

Copy link to clipboard

Copied

I already did that but I am still unable to move in small increments. My pixel sizing in Preferences won't reduce to less than 0.01 px. This is so frustrating

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2015 Dec 08, 2015

Copy link to clipboard

Copied

You probably no longer need this, however if you zoom in, you can move in that increment based on the ratio... i've run into the same issue before and this is the only way I've found to make it work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2017 Mar 30, 2017

Copy link to clipboard

Copied

This is only 3 years late but in the newest version of illy you can find and change this in the snap to pixel layout, to change it you need to find the the three stacked boxes next to a magnet icon and click on it. This will bring up a separate setting for the grid layout and snap. You can edit it to what you want.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2017 Sep 12, 2017

Copy link to clipboard

Copied

Unchecking 'Snap to Pixel' under the 'View' tab fixed this issue for me. Thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2018 Mar 15, 2018

Copy link to clipboard

Copied

under View Tab and uncheck "Snap to Grid" or just hold Shift+Ctrl and press " have a good day

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Thanks a lot for this! Worked for me!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2018 Mar 15, 2018

Copy link to clipboard

Copied

Simply go to under View Tab and un check "Snap to Grid" or just hold Shift+Ctrl and pres " have a good day

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2018 Mar 26, 2018

Copy link to clipboard

Copied

in "transform" selecting an object which intend to move and unchecking  "snap to pixel"   it works

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2018 Aug 06, 2018

Copy link to clipboard

Copied

Screenshot_1.png

Hope this will work. Thank you:)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

thanks! I needed that too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2019 Dec 15, 2019

Copy link to clipboard

Copied

I had the same issue and it solved by turning off "Snap to Points" and "Snap to Pixel" from the document settings that we see when there's no object selected. (Properties Window)

Cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 26, 2019 Dec 26, 2019

Copy link to clipboard

Copied

You are welcome, екатерина

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

The shortest solution I found is that somehow the file got currupted. No answers in the Preferences but, I opened a new file and tested drawing and moving and all was well. So I simply copied the elements from the file I was working on and pasted them in the new document (command F or B) and all was well with the world.  I've been using Ill. since it came out and that was a first for me...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines