Highlighted

Problem with Adobe Illustrator pressure on a Surface pro 7

Community Beginner ,
Aug 22, 2020

Copy link to clipboard

Copied

I recently purchased a Surface Pro 7. I am a graphic designer and an artist and I've always worked on Illustrator but after installing it to my Surface Pro the experience is ruined for me.

I cannot get a sharp line even if my life depended on it. 

Basically the lines inside the box are the lines I'm getting, the single line outside of the box is what I should be getting but I'm not. It's like the pressure works but not on the low end as I can't make a line sharp, it always ends up like this.

By the way - When I first set up my Calligraphic 3x3 pressure brush and when I try to draw a line it looks like it's not being processed but it actually turns out with the right pressure, as it's supposed to be, but then when I get the real time processing (about half a minute later) and I can see the pressure while I am drawing the line I am getting these awful round lines.

P.S. The device is not faulty as the pressure sensitivity works great in Photoshop and Clip Paint Studio and I get great sharp lines there with accurate pressure.

Please help me, I want to continue using Illustrator, that's why I bought the Surface Pro 7 initially, but I just can't get the pressure to work right!

TOPICS
Bug

Views

88

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with Adobe Illustrator pressure on a Surface pro 7

Community Beginner ,
Aug 22, 2020

Copy link to clipboard

Copied

I recently purchased a Surface Pro 7. I am a graphic designer and an artist and I've always worked on Illustrator but after installing it to my Surface Pro the experience is ruined for me.

I cannot get a sharp line even if my life depended on it. 

Basically the lines inside the box are the lines I'm getting, the single line outside of the box is what I should be getting but I'm not. It's like the pressure works but not on the low end as I can't make a line sharp, it always ends up like this.

By the way - When I first set up my Calligraphic 3x3 pressure brush and when I try to draw a line it looks like it's not being processed but it actually turns out with the right pressure, as it's supposed to be, but then when I get the real time processing (about half a minute later) and I can see the pressure while I am drawing the line I am getting these awful round lines.

P.S. The device is not faulty as the pressure sensitivity works great in Photoshop and Clip Paint Studio and I get great sharp lines there with accurate pressure.

Please help me, I want to continue using Illustrator, that's why I bought the Surface Pro 7 initially, but I just can't get the pressure to work right!

TOPICS
Bug

Views

89

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 22, 2020 0
Adobe Community Professional ,
Aug 22, 2020

Copy link to clipboard

Copied

What Workspace are you using? Does using the Touch Workspace help?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2020 0
Community Beginner ,
Sep 06, 2020

Copy link to clipboard

Copied

Nope. Nothing helps unfortunately and from what I've seen on reddit pretty much everyone has this problem. It's only with Adobe Illustrator... like in Photoshop it's good, but I mostly work on Adobe Illustrator so it's a big issue. Any other ideas how to fix it? And if you work for Adobe can you forward this to your team? This is a big issue for everyone using the Surface Pro who works with Illustrator. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0
Adobe Community Professional ,
Sep 06, 2020

Copy link to clipboard

Copied

Hi,

I've seen that problem many times, and no solution has been found: Microsoft refers you to Adobe and Adobe refers you to Microsoft. It's an eternal loop!

If I find the answer, I will let you know.

Best Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0
Community Beginner ,
Sep 06, 2020

Copy link to clipboard

Copied

Yes! And it's a crazy issue - I've been saving for this device for a lot of time just to be able to work on the go, but it's close to useless now with this issue at hand. Can we forward this issue to Adobe somehow? And if you find a fix please inform me! Fixing this issue will be a life-changer for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0
Adobe Community Professional ,
Sep 06, 2020

Copy link to clipboard

Copied

Try going here to complain

https://illustrator.uservoice.com

 

This is where the engineers read about peoples problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0
Community Beginner ,
Sep 06, 2020

Copy link to clipboard

Copied

Thank you! I just added a post there. I'm not optimistic but this is a big issue so I hope that they can fix it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0