Highlighted

"Unable to set maximum number of files to be opened" in CS6 trial, CS5 runs fine

New Here ,
May 07, 2012

Copy link to clipboard

Copied

Trying to start up the CS6 trial on a mac running OS X 10.7.3, I get the following message: "Unable to set maximum number of files to be opened."  After clicking "OK" on that dialog, Illustrator quits.  Illustrator CS5 runs perfectly, as does Photoshop CS6 trial.

Searching for this error showed other people having this on much earlier versions of Illustrator as a result of their maxfiles limit being set too low.  The suggested fix was removing /etc/launchctl.conf to unset the limit.

Running `launchctl limit` show my maxfiles hard and soft limits are 10,000.  I do not have an /etc/launchctl.conf file, and running `mdfind launchctl` doesn't show any other config files with that name sitting elsewhere (like in /private).  Finally, I've run Repair Disk Permissions.

If anyone has ideas on what I can do to get Illustrator running on my computer, I'd appreciate it.

TOPICS
How to

Views

55.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"Unable to set maximum number of files to be opened" in CS6 trial, CS5 runs fine

New Here ,
May 07, 2012

Copy link to clipboard

Copied

Trying to start up the CS6 trial on a mac running OS X 10.7.3, I get the following message: "Unable to set maximum number of files to be opened."  After clicking "OK" on that dialog, Illustrator quits.  Illustrator CS5 runs perfectly, as does Photoshop CS6 trial.

Searching for this error showed other people having this on much earlier versions of Illustrator as a result of their maxfiles limit being set too low.  The suggested fix was removing /etc/launchctl.conf to unset the limit.

Running `launchctl limit` show my maxfiles hard and soft limits are 10,000.  I do not have an /etc/launchctl.conf file, and running `mdfind launchctl` doesn't show any other config files with that name sitting elsewhere (like in /private).  Finally, I've run Repair Disk Permissions.

If anyone has ideas on what I can do to get Illustrator running on my computer, I'd appreciate it.

TOPICS
How to

Views

55.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 07, 2012 0
Advocate ,
May 07, 2012

Copy link to clipboard

Copied

Hi medgno_43

Just for confirmation. The build is installed on your machine is the official Illustrator CS6 trial that Adobe made avaliable for download today at this page: http://www.adobe.com/cfusion/tdrc/index.cfm?product=illustrator&loc=en_us ?

Did you try to trash preferences or reinstall Illustrator CS6? Does the problem persist?

Best Regards

Gustavo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2012 0
New Here ,
May 07, 2012

Copy link to clipboard

Copied

I didn't install the version from that link, but I did install the official release of CS6 Web and Design Premium, and the application version is 16.0.0.  I both trashed the CS6 preferences and reinstalled Illustrator CS6, and I get the same error message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2012 0
Adobe Community Professional ,
May 07, 2012

Copy link to clipboard

Copied

Do you have any whiteboard software installed? I think I remember this as being the culprit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

Hi,

I had the same problem after upgrading from CS5 to CS6.  I found this solution: http://www.smarttech.com/us/Support/Browse+Support/Support+Documents/KB3/146595.aspx

This solved my problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
Dec 09, 2018

Copy link to clipboard

Copied

Hi Lan,

I have facing same problem unable to set maximum number of files to be opened illustrator cs6 mac. Requesting you to please solve this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2018 0
Community Beginner ,
May 08, 2012

Copy link to clipboard

Copied

I am having the same issue. I bought the CS6 Standard Suite Upgrade, and Illustrator gives me the exact same dialog, then quits.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2012 0
New Here ,
May 09, 2012

Copy link to clipboard

Copied

I'm having exactly the same issue. Cannot do anything to solve it. All the other CS6 programs work but not Illustartor. I installed it from the Design Premium CD I was sent by Adobe. Any ideas anyone?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2012 0
Advocate ,
May 09, 2012

Copy link to clipboard

Copied

Hi

I´ll forward this post to an engineer from Adobe Illustrator Team. Will ask about this problem.

Thank you for bringing this issue. Expect to receive answers soon.

Best Regards

Gustavo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2012 0
Advocate ,
May 10, 2012

Copy link to clipboard

Copied

Hi Friends

I´m in contact with an engineer from Adobe Illustrator Team.

Could you please tell us if the SMART Product Drivers 10.6 are installed on your systems? http://smarttech.com/us/Support/Browse+Support/Support+Documents/KB3/146595.aspx

Also...could you please tell us if it happens to old Illustrator version?

This info will help the engineer to find the problem.

Thank you a lot

Gustavo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2012 0
New Here ,
May 10, 2012

Copy link to clipboard

Copied

Hi Gustavo

Thanks for the help...I don't think the SMART Product Drivers are installed. When I follow the procedure within terminal that you sent me to above, I get this:

Screen Shot 2012-05-10 at 14.00.35.png

My Illustartor CS5.1 is still working fine.

Hope that helps.

Cheers,

Nick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2012 0
Advocate ,
May 10, 2012

Copy link to clipboard

Copied

Hi Nick

This is a note from the engineer:

"Launch terminal window on your Mac and type in ulimit. If you get anything other than unlimited you should change it back to unlimited.  There are plenty of web resources that you can use to find out more about this command and how to change it or you can ask on one of the MAC forums.

If you see the value unlimited and still see the error you should report back the bug to Adobe: https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Gustavo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2012 0
New Here ,
May 10, 2012

Copy link to clipboard

Copied

Hi again Gustavo.

Thanks for the suggestion but it hasn't helped!

I tried the above and I get unlimited:

Screen Shot 2012-05-10 at 16.17.59.png

I've reported the bug as you suggest on the link you sent.

Fingers crossed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2012 0
Advocate ,
May 10, 2012

Copy link to clipboard

Copied

Hi Nick

Thank you

Your form is already with the engineers.

Thank you a lot

Best Regards

Gustavo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2012 0
Explorer ,
May 11, 2012

Copy link to clipboard

Copied

Having the same issue from a fresh install today from the Creative Cloud. I don't have any SMART driver software installed and ulimit shows unlimited for me as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2012 0
Explorer ,
May 15, 2012

Copy link to clipboard

Copied

Is there an ETA on this? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2012 0
New Here ,
May 16, 2012

Copy link to clipboard

Copied

I'm having this exact problem with my newly downloaded Illustrator CS6.  It worked all day yesterday, and today I have this message.  Tried all the terminal commands as instructed above and no change.

CS 5.1 is working fine.

Any update on this issue is much needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2012 0
Adobe Employee ,
May 17, 2012

Copy link to clipboard

Copied

Create a new user accunt on your mac login using the newly created user and see if it changes things for you. Make sure you also have the latest OS updates installed on your mahine

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2012 0
Explorer ,
May 17, 2012

Copy link to clipboard

Copied

Yes, when launching Illustrator CS6 under a new user account, it runs fine. But how do I get it to run with my real account?

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2012 0
Adobe Employee ,
May 17, 2012

Copy link to clipboard

Copied

Hi Ian,

Glad to see it works for you.

I reccomended a new user account to remove few variables. I have tried this on numerious occasions when I see something weird happening only for me. If it runs fine under new account that means you need to review one of the softwares in your startup or some MAC OS settings. Troubleshooting this may take lot of time, If you are short on time maybe you should just copy files from the old account and start using the new one.

-- All the best

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

Hi guys

Just to let you know. I just updated the OS (to 10.7.4) and now it works! I've done nothing else. I'll let you know if it keeps working.

Hope that works for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Explorer ,
May 18, 2012

Copy link to clipboard

Copied

ADBEDesigner, do you have any suggestions on where to start looking for software that would modify this max open files option? My OS is the latest version (10.7.4).

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Adobe Employee ,
May 18, 2012

Copy link to clipboard

Copied

@Nick320: Even reinstalling 10.6 would have worked or just creating a new account. Most of these issues impacting few users are related to OS settings.During the course of our working we install many softwares and few of these even change the default settings at times we also change settings that we do not recall changing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Adobe Employee ,
May 18, 2012

Copy link to clipboard

Copied

Ian:  is is very difficult to pin point the software that would have modified it. I suggest you should have a look at all applications or hardware installed and most likely culprit could be products that deal with databases, network operations or file management systems. Cant really tell as we do not have this issue at computers at our office.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

do you have any suggestions on where to start looking for software that would modify this max open files option? My OS is the latest version (10.7.4).

@Ian: Please look for files /etc/launchd.conf, $HOME/.launchd.conf or /etc/sysctl.conf. These are the common files where the limit may exist.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Explorer ,
May 18, 2012

Copy link to clipboard

Copied

Thanks Nick. I couldn't find any of these files (and yes I knew to make sure the system files were visible to search in them). In the mean time I will keep using your script solution right now. It works and that's all I wanted. Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Explorer ,
Jun 04, 2012

Copy link to clipboard

Copied

Strangly enough, the problem seems to have fixed itself at some point. Maybe after a restart, not really sure. But my preferences were all reset which is fine, but now I don't have to use that terminal command.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2012 0
Adobe Employee ,
Jun 14, 2012

Copy link to clipboard

Copied

Thought I'd consolidate the useful replies to the OP, and add the inputs I've received form the Illustrator Engineering team.

On Mac OS, Illustrator usually launches with normal user account permissions (non-privileged). To maximize performance, Illustrator tries to increase the maximum number of files to be opened.  Mac OS does not restrict or limit Illustrator from increasing the maximum number of files that can be opened. However, a system administrator or third party software may place such restrictions on the maximum number of files that can be opened by a process, by adding a system preference to configuration files.

When such a file limit setting is enforced, a process like Illustrator that is starting with normal user account permissions fails to launch.

The possibility of such a system preference being added to your configuration files is higher if you have installed SMART Product Drivers 10.6 (See KB article http://www.smarttech.com/us/Support/Browse+Support/Support+Documents/KB3/146595.aspx). But, here's a procedure to isolate and fix the problem even if it is not SMART product drivers that tweaked this system preference.

You need to first check for the file limit system preference, and then try solution 1 or 2.

Check if your computer has this system preference:

  1. Check if these files exist in your system:

    •     /etc/launchd.conf,
    •     $HOME/.launchd.conf
    •     /etc/sysctl.conf.

  2. If you find any of the files listed above, check for a setting like:

limit maxfiles

Solution 1: If the system preference exists on your computer:

  1. Create a backup of the file that contains the file limit setting
  2. Open the file with editing permissions. For example, sudo vim <filepath>
  3. Find the line that contains the setting, and delete it by pressing dd.
  4. Save the file and press !wq to quit vim.
  5. Reboot and launch Illustrator CS6.
  6. If the error persists, there is a chance that this setting is being enforced from a different location. Perform the actions outlined in Solution 2.

Solution 2: If the system preference does not exist on your computer:


  1. Download the shell script attached with this reply.
  2. Unzip the file, and drag the launchAI.command file into your dock area. Do verify the application path; the command file assumes that Illustrator CS6 is installed at the default location.
  3. Click launchAI.command.
  4. In the terminal that appears, enter your user password, and check if Illustrator CS6 launches successfully.

If you don't like typing your password every time you launch Illustrator:

  1. Open the /etc/sudoers file in editing mode.
  2. Add the following line to the file:

    %staff ALL=(ALL) NOPASSWD: ALL

  3. Replace staff with your user's group name.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2012 1
New Here ,
Jun 15, 2012

Copy link to clipboard

Copied

Ivan David,

We know how to work around the issue, and launch illustrator with a shell script as root user. But that is merely a workaround and does not fix the issue...

Fact is that under my normal user account, I have NO file limit setting of any kind:

bert@bertbookpro ~> ulimit 
unlimited

But still I get the error message displaying the "Unable to set maximum number of files to be opened" error, while I have no files that exists where the ulimit setting could be present:

bert@bertbookpro ~> cat /etc/launchd.conf
cat: /etc/launchd.conf: No such file or directory
bert@bertbookpro ~> cat ~/.launchd.conf
cat: /Users/bert/.launchd.conf: No such file or directory
bert@bertbookpro ~> cat /etc/sysctl.conf
cat: /etc/sysctl.conf: No such file or directory

(which means that this solution also does not work)

THAT is the core problem, so there has to be a real solution to this instead of a workaround, so I can run Illustrator under my normal user account...

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2012 0
Explorer ,
Jun 15, 2012

Copy link to clipboard

Copied

I know. I almost feel like installing then uninstalling those drivers to see if that fixes it because right now I don't have any of those files sitting around.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2012 0
New Here ,
Jun 15, 2012

Copy link to clipboard

Copied

And on top of all that, you're sudo'ing into Illustrator which is insane. You'll almost certaintly run into permission issues if you create folders or maybe even files from within a sudo/superuser Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2012 0
New Here ,
Jun 15, 2012

Copy link to clipboard

Copied

Indeed, I had some issues because of that when working with illustrator today

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2012 0
New Here ,
Jun 15, 2012

Copy link to clipboard

Copied

It's still not working. This is a bit ridiculous.  It would seem as if Illustrator wants to set a ulimit of its own, but can't?  Any updates?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2012 0
New Here ,
Jul 07, 2012

Copy link to clipboard

Copied

I don't think this has been suggested yet.

I don't have SMART drivers installed and don't have the config files, either. But I found a solution that worked for me for Illustrator CS6:

Go into your user/library/preferences/

Delete/rename all of your Illustrator preferences files (there should be a folder) and also the com.adobe.plist file (note: this will lose your preferences).

Restart the computer.

This worked for me on multiple launches of Illustrator and I restarted a few times since as well - still working.

I know this is an easy solution, but it worked for me perfectly. Didn't want to have to launch a script just to run a program everytime.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2012 0
Explorer ,
Jul 07, 2012

Copy link to clipboard

Copied

I tried this previously but I never thought to Restart the computer afterwards. For whatever reason, restarting after removing the preferences actually worked for me and I don't get that message anymore.

Evidently there is something else going on there with the Restart part.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2012 0
New Here ,
Jul 09, 2012

Copy link to clipboard

Copied

@bloodyelle & Ian Kelleigh: Unfortunatly, this did not work for me. Even after restarting I still get the same message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2012 0
Community Beginner ,
Jul 11, 2012

Copy link to clipboard

Copied

this really work for me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 11, 2012 0
Community Beginner ,
Jul 29, 2012

Copy link to clipboard

Copied

I guess this is the most up-to-date thread on this problem; for what it's worth, here's my (strange) experience:

AI was working fine on Mac OS X 10.7; after I upgraded to 10.8 ('clean install') I started getting the error. I tried everything suggested on the forums and Adobe's official help page, to no avail. (sudo-ing didn't work either; it wouldn't let me save anything?!)

Then today everything just went back to normal. The only change I made with the computer in the meantime was to re-install Parallels Desktop 7, and perhaps 3 restarts. There was no change in AI's behavior after the first restart. After the second restart, AI would run for only one session—after I quit and wanted to come back, I got the error, again. Now, it's 'back to normal'.

I'm not confident that things will stay this way, though. This isn't exactly a 'crash' either, so there's no report to send to Adobe. I guess the best we can do is to keep these threads alive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2012 0
Explorer ,
Jul 29, 2012

Copy link to clipboard

Copied

Yeah the whole thing is seemingly random for me too. I could try it one hour and I get the error, next morning I try and it works fine. It is some conflict with another app or setting that is limiting maximum open files and it isn't always from the SMART drivers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2012 0
Community Beginner ,
Jul 29, 2012

Copy link to clipboard

Copied

I was getting this error randomly, too, but it seemed to be happening only when Illustrator CS6 was opened along with CS5.5 apps such as InDesign or Bridge. Now I open only apps belonging to the same suite at the same time -- don't mix and match -- and the error hasn't occurred since. May be just be a coincidence, but perhaps CS5.5 and CS6 don't play well together.

Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2012 0
Explorer ,
Jul 29, 2012

Copy link to clipboard

Copied

Another thing I've noticed is that when I launch this without the error it seems like it's reading different preferences than when I run it through that script. For example, panel locations are different depending on how it launches.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2012 0
New Here ,
Aug 17, 2012

Copy link to clipboard

Copied

I was getting this error and didn't have any of the files or settings listed in Ivan David's post. I downloaded the file he provided and ran it to use Illustrator briefly, until an unrelated keyboard issue forced me to restart. After that, Illustrator seems to be back to normal.

So, if nothing else, try a reboot? I'll repost if the issue crops back up; it may be related to a process or app that was running on my system before the reboot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2012 0
Community Beginner ,
Sep 02, 2012

Copy link to clipboard

Copied

This works for me !!!

1 - Try deleting font database (I use Fontexplorer X Pro)

2 - Stick to Firefox

Good luck!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

I also encountered this issue on MAC OSX 10.7. I tried many hit and trials and finally found a way to launch Ai, though it is just a workaround. I followed these steps:

1. I created shell script which can launch Ai. You can download this shell script from the location: http://dl.dropbox.com/u/47167182/launchAI.command.zip.

2. Unzip the folder and drag the launchAI.command file into your dock area. (Please verify the application path, since I have installed AICS6 on default location)

3. Click launchAI.command icon in the dock.

4. A terminal will appear asking your user password, enter your password to see if AI launches successfully.

5. If you don't like typing password  for each run, you can edit /etc/sudoers file to add a line "%staff ALL=(ALL) NOPASSWD: ALL" . (Replace staff with your user's group name).

Please see if this workaround also works for you.

All the best!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Explorer ,
May 18, 2012

Copy link to clipboard

Copied

Creative_nick, that script works perfectly. That's really strange, what is different about how this is being launched versus just launching the app normally? BTW, during launch I get this error in the terminal window:

2012-05-18 06:57:59.647 Adobe Illustrator[69428:3e03] CFURLCreateWithString was passed this invalid URL string: '/System/Library/Frameworks/' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead.

2012-05-18 06:58:22.879 CS6ServiceManager[69443:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

See /usr/include/servers/bootstrap_defs.h for the error codes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

Ian,

This all is related to permissions that are avaialable to the process. When you launch the app with terminal (with the script that I provided), AI is invoked through shell and inherits the shell quota. It also gets sudo permissions so that AI is now able to change the limit of number of open files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

CS6ServiceManager[69443:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

Ian, Did you deny participating in Adobe PIP (Product Improvement Plan)? I have seen such an error in that case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 21, 2012

Copy link to clipboard

Copied

The solution with the shell script works perfectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2012 0
New Here ,
May 22, 2012

Copy link to clipboard

Copied

Script works, however it appears it's required to run everytime to open Illustrator. Is that correct?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2012 0
Community Beginner ,
May 24, 2012

Copy link to clipboard

Copied

The script launches Illustrator just fine.

I had this issue when I first installed CS6, but after a restart, Ai started working normally. I go to launch it today, and I get the error at startup again. BUT, this screipt works -- now Adobe just needs to figure out what's going on instead of putting the brunt of the work on us. CS5 Ai works just fine. I don't -- and never have -- had Smart installed, nor any app like it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2012 0
Community Beginner ,
May 24, 2012

Copy link to clipboard

Copied

I receive the following Terminal error when I use the script:

2012-05-24 08:34:34.189 Adobe Illustrator[56601:3e03] CFURLCreateWithString was passed this invalid URL string: '/System/Library/Frameworks/' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead.

2012-05-24 08:34:38.874 CS6ServiceManager[56607:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

See /usr/include/servers/bootstrap_defs.h for the error codes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2012 0
Community Beginner ,
May 31, 2012

Copy link to clipboard

Copied

No word from Adobe on this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2012 0
Resources