Removing Overlaps in Lettering from Variable Fonts

Enthusiast ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

I think OpenType Variable Fonts are pretty nifty. But they can include a side-effect of letter forms with overlapping parts, even a single shape overlapping on itself. See the attached image for an example. That side-effect of overlapping parts can be pretty harmful if that lettering will be sent to something like a vinyl cutting machine or computerized routing table. A knife blade or router bit will cut through material wherever a path line is present.

A long time ago Macromedia Freehand featured an "Xtra" called "remove overlap." With one click it would weld over the overlapping lines in objects similar to the letters from those Variable Fonts. CorelDRAW has a similar (but not obvious) Weld function (Object menu>Shaping>Weld). The normal weld function buttons in CorelDRAW don't remove the overlaps. You have to use that drop-down menu item.

Does the current version of Adobe Illustrator have a similar one-click function anywhere to get rid of overlaps? The Shape Builder tool is the only thing I can find that delivers a desirable result, but you have to manually go letter by letter using the tool to draw through the overlaps. It's not bad if it's just a few objects to touch up. It can be a waste of time if you're having to fix a bunch of lines of copy.

IIRC, some years ago, the Unite function in Illustrator's Pathfinder palette was able to automatically get rid of overlaps with one click. It doesn't do that now.

 

Text-Overlap-Sample

TOPICS
Draw and design, Type

Views

172

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 03, 2020 Dec 03, 2020
You can also select the outlined type and click the Use None-Zero Winding Fill Rule followed by Pathinder Unite.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

There's no obvious reason Pathfinder's Unite shouldn't work.

Can you share a file?

Also, what fonts are you using here? I can't replicate the overlaps when expanding any of the variable fonts.

 

Edit: found one, Bahnschrift. But clicking Unite worked as I would expect, so still not sure what you're experiencing.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I've narrowed down the problem some. If the Variable Font text objects are created within Illustrator the Unite button in the Pathfinder palette will remove the overlaps in one click. If the artwork is created in another application and converted to outlines prior to export then the Pathfinder operation won't work properly. At best it only seems to add anchor points where path lines intersect. The issue appears to behave according to how the objects are filled. If they're filled solid even in the overlapping areas then the Unite button will merge the parts together properly. But if the overlaps create negative holes then the weld operation won't work as desired. I would attach an Illustrator file that has the issues I describe but the forum's server functions won't let me upload an AI file.

 

FYI, the fonts used in the sample are Futura Now Variable, Futura Now Script Variable, Futura Display Variable and Bahnscrift.

Side note: not all Variable Fonts have these messy overlapping parts. Acumin Pro doesn't appear to have any of those issues. TT Supermolot Variable is another example. Just out of a lucky accident I first saw these overlaps in Bahnscrift, a typeface I don't use very often at all in projects. But its appearance in outline view set off the warning alarm to be on the lookout for the same issue in any other variable fonts.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

You could upload your fle to Dropbox or the like and post a link in here.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Here's a Dropbox public folder link to it:
https://www.dropbox.com/s/u01yc17loxzj3fp/Text-Overlap-Sample.ai?dl=0

Normally I avoid posting links in forums since the linked items will likely be removed at some point, thus breaking the link.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Thank you!

I could solve this by first apply the Pathfinder Effect (!) "Trim" and then "Add"

Then Expand appearance.

https://www.dropbox.com/s/8b5ea2yvw7z6s9t/Text-Overlap-Sample-mg.ai?dl=0

 

Pathfinder effects are sometimes not stable. So I hope it works for you as well.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I must be missing something in my Pathfinder palette. "Trim" is one of six buttons in "Pathfinders" (along with Divide, Merge, Crop, Outline and Minus Back). I don't have an "Add" button. The four buttons in "Shape Modes" (above Pathfinders) is Unite, Minus Front, Intersect and Exclude. The "Expand" button stays grayed out regardless if I click the buttons on their own or click them along with the Alt key. I'm wondering if something is messed up with my installation. I can't seem to find anything under Preferences or any other settings to change the behavior. (Later edit: I finally remembered the "expand" button only lights up when pressing the Alt key for Pathfinder operations on two distinictly separate objects, not on a single compound object such as a compound line of lettering).

Anyway, if I select one of the "Text Overlap" objects, click the Trim Pathfinder and then click the Unite button all of the shapes fill in solid, including the counters in the "e," "O," "a," and "p" letters.

I'm not overly worried about the situation. It's just another thing to watch-dog up front when creating type elements using Variable Fonts. The overlaps will need to be removed in the host application where the type objects were originally created.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Use the Unite button an check the Edit > Undo Add

Use the Minus Front button and check the Edit > Undo Subtract

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

What Doug said.

My test font was Decovar, which adds some nice complication to the issue. But Pathfinder Unite gets rid of that (most of it, because the font is kind of messy with  its 10 variable axes).

 

You can also add the effect "Outline object" followed by the "Pathfinder > Unite effect" to solve this in the live text. Then in the exported PDF (or EPS or whatever) the text will be outlined and united automatically. But still I would not want to send anything to a plotter without checking it thoroughly first.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

You can also select the outlined type and click the Use None-Zero Winding Fill Rule followed by Pathinder Unite.

non zero.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

That's more like what I was trying to find. I don't know why I didn't remember the Attributes palette. A long time ago I used to bring up that palette on a frequent basis to correct issues with expanded line strokes. They would often overlap at the corners, creating all sorts of issues. When the non-zero winding setting was applied to the object that would allow the unite pathfinder function to eliminate all the path overlaps. Line strokes in modern versions of Illustrator do not behave like that when expanded. The non-zero winding button in the Attributes palette combined with the Unite pathfinder is still not quite as straightforward as the old "remove overlap" xtra in Freehand. But a couple clicks is a lot better than having to use something like the Shapebuilder tool to manually fix the issues.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Good to hear you found it useful. You may reduce the number of clicks by creating an action and use Button mode.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines