Solution: Remove highlighting when selecting type

Contributor ,
Dec 05, 2020 Dec 05, 2020

Copy link to clipboard

Copied

When you select type, AI highlights it. One of many problems is that the highlight changes the visual color of the text, making it difficult to adjust the color of a portion of text since you can't see the changes in real time.

 

AI lets you to hide selections using view>hide edges (or shortcut). It's supposed to work for type also, but many users have pointed out that it doesn't in their versions for whatever reason. I'm using AI 2020 v24 and this is the case for me as well.

 

I experimented to see if there were quick workarounds and hide edges works properly on type:

  • When Preview on CPU is enabled instead of  GPU preview.
  • When either Overprint preview or Pixel preview are enabled.

 

All options under the view menu.

screenshot.jpg

 

I don't know if there are other workarounds or how well known these already are. I just noticed so many people still searching across the web for an answer to this just like I was, so I decided to post my solution in case it helps someone!

TOPICS
How to, Type

Views

104

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Dec 05, 2020 Dec 05, 2020

Copy link to clipboard

Copied

If on my computer is GPU Preview is active:

  • enable menu: View --> Hide Edges [Ctrl+H]

 

 

If on my computer is Preview on CPU is active:

  • enable menu: View --> Hide Edges [Ctrl+H]

          and

  • enable menu: View --> Overprint preview [Ctrl+Alt+Shift+Y]

 

 

(But to me this attitude is meaningless. On the contrary - I always want to see the highlighting so I know exactly which part of the text is being edited.)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 05, 2020 Dec 05, 2020

Copy link to clipboard

Copied

Yes, it depends on your needs. I know which part of the text I'm selecting because I have highlighting on when I do it, but once it's selected, I need the highlighting off so I can make real time adjustments to things like color without the highlight distorting what I'm seeing.

 

When I searched how to hide edges on type, I found dozens of links on various sites with people asking the same thing and not getting an answer other than "hide edges should work". That's why I had to look for my own solution.

 

Though looking into it afterward, I did find a bug report for it on uservoice and an Adobe employee responding in 2019 saying they can reproduce the bug and are looking into it, implying that hide edges was still supposed to work on type as usual without needing to tweak other view settings.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines