Highlighted

There is an unexpected hole in the gradient

Community Beginner ,
May 31, 2020

Copy link to clipboard

Copied

photo_2020-05-31_15-20-45.jpg

 

The four triangular holes are not expected; they just appear only when I export it. I don't know what to do to export something that does not have those holes.

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

I tried it again and it seems to be caused by the anti-aliasing settings.

Art Optimized, no problem.

Type Optimized, holes.

Topics

Bug, How to

Views

713

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

There is an unexpected hole in the gradient

Community Beginner ,
May 31, 2020

Copy link to clipboard

Copied

photo_2020-05-31_15-20-45.jpg

 

The four triangular holes are not expected; they just appear only when I export it. I don't know what to do to export something that does not have those holes.

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

I tried it again and it seems to be caused by the anti-aliasing settings.

Art Optimized, no problem.

Type Optimized, holes.

Topics

Bug, How to

Views

714

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

could you please share the working file? Now it's difficult to say anything useful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 31, 2020

Copy link to clipboard

Copied

대지 1.png

https://shared-assets.adobe.com/link/56f4491d-7270-4cc6-5e58-35a57da67cb8

This is the link to the working file (idk how to upload it here)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

I cannot replicate the problem. Looks fine.

Which version of Illustrator and what export settings are you using?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 31, 2020

Copy link to clipboard

Copied

  • Illustrator Version: 24.1.3
  • Export for Screens / 1x PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

Works fine for me with that version.

Did you try to reset your Preferences? Either with the button in the Preferences ot manually:

https://community.adobe.com/t5/illustrator/how-to-reset-illustrator-preferences/td-p/10602277?page=1

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
May 31, 2020

Copy link to clipboard

Copied

Hi @2wiso,

maybe a problem in different zoom levels. Try to toggle between Preview on CPU/GPU [Strg]+[E]

 

And if the error exists in the final exported file - which file format is it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 31, 2020

Copy link to clipboard

Copied

It is not a preview problem; it only happens in the exported file.

I am using PNG.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 19, 2020

Copy link to clipboard

Copied

I tried it again and it seems to be caused by the anti-aliasing settings.

Art Optimized, no problem.

Type Optimized, holes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

I can't replicate the problem either. Need to take a look at the file to see if there is something in it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

I'm having a similar issue. My mesh gradient has a weird hole in it as well when I save it as a PNG. It is worse when I export for screens (picture below), but when I saved saved for web, it wasn't there at all. I think it has something to do with stretching the gradient. I made it as a square first for other icons then extended it to the right to accomodate the copy. The square version didn't have a problem at all, and you'll notice the tear in my gradient starts at the edge of where the orignial ended. I'm using the latest update of Illustrator 2020.

Sorry for the lack of a real answer. 

 

Help_Desk.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 19, 2020

Copy link to clipboard

Copied

Try export with Art Optimized (Supersampling) for the anti-aliasing setting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

That definitely helps when I use Export As instead of Export for Screens. Export for Screens doesn't give an Art Optimized option. Thanks! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 19, 2020

Copy link to clipboard

Copied

Export for Screens also has that option, click on the little cog wheel for format settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

Thanks! I didn't think to look there. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...