Highlighted

Unable to turn off snapping

Community Beginner ,
Aug 04, 2020

Copy link to clipboard

Copied

I am using Adobe Illustrator 24.2 on a MacBook Pro OS 10.14.6. I am unable to align the edges of two shapes because some sort of "snap" function appears to be turned on which limits the movement of the anchor points. I am unable to move the anchor manually to align and if I try to "nudge" the selected point with arrow keys, it "jumps" over the place I want it to land. This is so tedious. How can I turn this off so that I can just align objects?

Here's what I've tried:

  • In Preferences > General, I have the Keyboard Increment set to 0.0001 px...no effect.
  • In Preferences > Selection & Anchor Display, I set Tolerance to 1 (it won't go any smaller) and have "Snap to Point" unchecked, also unchecked is "Constrain Path.."
  • I have set the Snapping Tolerance to 0 pt in Preferences > Smart Guides...no effect.
  • In Preferences > Guides & Grid, I have set the "Subdivisions" to 1 (the lowest number) and 100 (random) with no effect. I've tried changing the "Gridline every:" to 1px (default is 72 px)...no effect.

Please advise.

Most Valuable Participant
Correct answer by pixxxelschubser | Most Valuable Participant

align_to_pixel_grid.png

 

Uncheck all. 

Does that helps you out?

TOPICS
Draw and design, How to, Tools

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to turn off snapping

Community Beginner ,
Aug 04, 2020

Copy link to clipboard

Copied

I am using Adobe Illustrator 24.2 on a MacBook Pro OS 10.14.6. I am unable to align the edges of two shapes because some sort of "snap" function appears to be turned on which limits the movement of the anchor points. I am unable to move the anchor manually to align and if I try to "nudge" the selected point with arrow keys, it "jumps" over the place I want it to land. This is so tedious. How can I turn this off so that I can just align objects?

Here's what I've tried:

  • In Preferences > General, I have the Keyboard Increment set to 0.0001 px...no effect.
  • In Preferences > Selection & Anchor Display, I set Tolerance to 1 (it won't go any smaller) and have "Snap to Point" unchecked, also unchecked is "Constrain Path.."
  • I have set the Snapping Tolerance to 0 pt in Preferences > Smart Guides...no effect.
  • In Preferences > Guides & Grid, I have set the "Subdivisions" to 1 (the lowest number) and 100 (random) with no effect. I've tried changing the "Gridline every:" to 1px (default is 72 px)...no effect.

Please advise.

Most Valuable Participant
Correct answer by pixxxelschubser | Most Valuable Participant

align_to_pixel_grid.png

 

Uncheck all. 

Does that helps you out?

TOPICS
Draw and design, How to, Tools

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 04, 2020 0
Most Valuable Participant ,
Aug 04, 2020

Copy link to clipboard

Copied

align_to_pixel_grid.png

 

Uncheck all. 

Does that helps you out?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2020 1
Adobe Community Professional ,
Aug 04, 2020

Copy link to clipboard

Copied

Is in View menu > Snap to Pixel on?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2020 0
Community Beginner ,
Aug 04, 2020

Copy link to clipboard

Copied

THANK YOU!! I'm not sure why an explanation of the little Advance options for the Snap to Pixel controls is so hard to find!

Thank you both. My day just got 100% better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2020 0
Adobe Community Professional ,
Aug 04, 2020

Copy link to clipboard

Copied

Good to hear that helped.

The options are hard to find if you don't have Snap to Pixel shown in the Control Panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2020 0