Unable to use special characters while typing in Illustrator (ALT GR issue).

New Here ,
Jul 20, 2017

Copy link to clipboard

Copied

Hi,

I was trying to type the special characters, specifically € character while using Illustrator. Unfortunately the method that works for every other piece of software I use, is not available in Illustrator. There reason is that Illustrator uses 'Alt Gr' key as replacement for combination 'Alt+Ctrl' even in the text typing mode. That prevents me from using any special characters that require the combination of 'Alt Gr + <letter>'. The examples would be 'Alt Gr + 4' which gives € character in result or 'Alt gr + e' giving 'é'.

Please don't suggest for me to pick the special characters from 'Character Map' as it would only make sense if it's just one once in a while. I know I'll need Illustrator for jobs that would require multiple special characters in a sentence.

It also doesn't have anything to do with the keyboard/system/software regional and language settings. The issue is specific to Illustrator and I was wondering if there's a way for disabling the key assignment so I could type freely. I've checked the Keyboard Shortcuts settings in Illustrator and there's no option to do that.

I'm looking forward to the reply from someone from Adobe as I've seen this issue raised many times in the forums but no solution or official statement was provided (as far as I've seen anyway).

Thanks in Advance.

Views

4.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to use special characters while typing in Illustrator (ALT GR issue).

New Here ,
Jul 20, 2017

Copy link to clipboard

Copied

Hi,

I was trying to type the special characters, specifically € character while using Illustrator. Unfortunately the method that works for every other piece of software I use, is not available in Illustrator. There reason is that Illustrator uses 'Alt Gr' key as replacement for combination 'Alt+Ctrl' even in the text typing mode. That prevents me from using any special characters that require the combination of 'Alt Gr + <letter>'. The examples would be 'Alt Gr + 4' which gives € character in result or 'Alt gr + e' giving 'é'.

Please don't suggest for me to pick the special characters from 'Character Map' as it would only make sense if it's just one once in a while. I know I'll need Illustrator for jobs that would require multiple special characters in a sentence.

It also doesn't have anything to do with the keyboard/system/software regional and language settings. The issue is specific to Illustrator and I was wondering if there's a way for disabling the key assignment so I could type freely. I've checked the Keyboard Shortcuts settings in Illustrator and there's no option to do that.

I'm looking forward to the reply from someone from Adobe as I've seen this issue raised many times in the forums but no solution or official statement was provided (as far as I've seen anyway).

Thanks in Advance.

Views

4.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 20, 2017 0
Adobe Community Professional ,
Jul 20, 2017

Copy link to clipboard

Copied

kamil.luc  schrieb

The examples would be 'Alt Gr + 4' which gives € character in result or 'Alt gr + e' giving 'é'.

If this were a general issue then nobody would be able to type the EURO symbol on Windows, which is clearly not the case.

So the issue is with your setup.

You might want to tell us, what is installed.

Which version?

Which system?

Any third party plugins in Illustrator?

A Wacom? Did you update the driver recently?

Any keyboard enhancements in your system?

Does it work with a different keyboard?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2017 0
New Here ,
Jul 20, 2017

Copy link to clipboard

Copied

Hi,

Adobe Illustrator CC 2017

Windows 10 64bit

No plugins.

No Wacom

No keyboard enhancements.

If this were a general issue then nobody would be able to type the EURO symbol on Windows, which is clearly not the case.

I've said already that I have no problem with typing the special characters anywhere in Windows except for Illustrator. Specifically in the text editing mode. I can for example type special characters with Alt Gr in the search fields in Illustrator but not anywhere on the artboard. When I press Alt Gr in text editing mode the cursor changes to 'Selection'. So even in text editing mode Illustrator's keyboard shortcuts are activated with Alt Gr - a function that should be disabled for the duration of text editing to allow the use of special characters.

Can you type € character in Illustrator using the combination of 'Alt Gr + 4'? Or any other special character for that matter?

Do you have a special button on your keyboard for € character? Mine is on the 4-$ button and can only be called by Alt Gr + 4 combination.

I've also noticed that formatting of the text using standard keyboard shortcuts like Ctrl+I, Ctlr+B and Ctlr-U is not available in Illustrator as opposed to most of the other applications with text editing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2017 0
Adobe Community Professional ,
Jul 21, 2017

Copy link to clipboard

Copied

On my keybard the EURO symbl is on Alt Gr + E and I have no issue typing that in Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2017 0
New Here ,
Aug 01, 2017

Copy link to clipboard

Copied

I assume you have the special German keyboard with special German characters. I have the standard UK layout but sometimes need to type certain language specific characters (irish, polish, german, spanish etc.) and the only way to achieve this is by using the combination of a letter and Alt-Gr. That's when the conflict with the default Illustrator keyboard shortcuts occurs and, unfortunately, AI doesn't have a shortcut override while editing the text (which would solve the problem).

The only way to fix that at the moment is the remapping of the AI shortcuts to free up the special character letters.

I wish that AI creators kept in mind that a large group of their users doesn't come from US and that they type in different languages, sometimes a few of them at the same time, and you can't own a special keyboard for each of them.

I know that I could type my text outside of Illustrator and then paste it in afterwards but that's not a correct way to do it, just workaround.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2017 0
Adobe Community Professional ,
Aug 01, 2017

Copy link to clipboard

Copied

I just pressed Alt Gr and dragged my finger over the keyboard. None of the keys triggered anything else than typing.

This is Windows 10 on a Surface.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2017 0
New Here ,
Aug 01, 2017

Copy link to clipboard

Copied

That's just one computer and software to compare with though.

With me, whenever I press  Alt Gr, the cursor changes to selection/copy cursor, even when typing.

As I said, I'm not the only one, see:

Unable to type Polish characters (right alt key not working)

CS5 AI. How to add accented text character in windows

After googling a lot I've found that there's a way of inputting the Polish accented characters on the Polish (Programmers) keyboard setting by pressing Shift + <~> followed by the corresponding character like 'o' for 'ó'. It's quite uncomfortable to do so compared to the usual Alt Gr method.

It doesn't work for Irish (GA) keyboard setting either.

I wish Adobe employee would make a statement as I've spent a lot of time trying to find the solution and if they just said that there's no solution and there won't be, I would at least stop wasting my time trying to find it.

I'd prefer though if I was offered a proper solution or a promise of adding one in the next update (disable Alt Gr when typing - DONE).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2017 0
Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

Hi, Kamil,

What if you try to add an AltGr-enabled keyboard layout, but for the language you want to use characters from? It works for me. Somehow Adobe apps seem to be picky (clever?) about it. See: Photoshop Windows: Polish letter ć (AltGr + c) triggers Canvas size (Ctrl + Alt + c) in text editing... .

Regards

m.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0
New Here ,
Nov 10, 2017

Copy link to clipboard

Copied

This is a bug  in Illustrator (and Photoshop); it’s not your keyboard’s fault. Illustrator just shouldn’t hijack this key combination (there’s Alt and Ctrl near the AltGr key for that). Typing symbols and accented letters using AltGr works everywhere else in Windows, InDesign included. It would be a deal breaker if it din’t work in InDesign, now wouldn’i it, Adobe? Broken deals are not good deals…

It changes nothing if you set the language to your keyboard’s language in the text box. And it shouldn’t, as keyboard layouts should be global, not per-program. It also changes nothing if you choose the “programmer’s” or “default” layout for the input language.

All you can do now is paste text from a different program and wait patiently for a fix from Adobe. Or at least an answer… Or wait! just use the glyphs panel!

Oh, and onscreen/tablet keyboards don’t count, since there’s an extra layer of input between the virtual keyboard and the actual input (think gesture typing, spring modifiers).

Happy illustrating everyone!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2017 0
Explorer ,
Nov 14, 2017

Copy link to clipboard

Copied

Hi, Alexandru,

You got me interested. Could you tell me which OS version, Illustrator version, which keyboard added under which Language in Regional settings are you using and are unable to enter which characters using which key combinations, I will try to replicate.

Thanks!

Regards

m.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2017 0
Explorer ,
Feb 14, 2018

Copy link to clipboard

Copied

Here is how to use special character on windows 10

1- Press windows+x key from keyboard and select control panel from power user menu.

2– Select fonts from Control Panel Window.

3– Click on Find a character from the left column of fonts window.

You can also simply search character map by just typing character map on search box.

4– You will see a medium sized character map windows pops out on your screen with several distinct special character.

5- Click on the font section. It has a huge variety of fonts to choose from. Each fonts has its own set of special character. Choose the character you want to prefer by scrolling down the list and as soon as to bring your cursor on character an enlarged view of that character will pops out.

6– After choosing the character click on the select button. You will also see the Keystroke of that special character on the bottom right corner of the window.

7- Now click on the copy button.

8- The selected special character is now copied on your clipboard. Now you can easily paste it in desired location.

Source:- https://merabheja.com/how-to-use-special-character-on-windows-10/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2018 0
New Here ,
Apr 10, 2018

Copy link to clipboard

Copied

Hello (sorry for my Eng)

I have the same trouble. «Right Alt» in Adobe Illustrator works like «Alt+Ctrl».

That provide me a huge amount of pain

for example:

i use non-stadart russian keyboard layout with special characters, like «» or „“ and ≈ ≠ ± and so on. They works with RAlr+ or RAtl+Shift+ combinations. Its very useful and timesaving in typography tasks. And this works fine in every text input on my computer ... exept Illustrator.

And once, when i became angry again, i pressed RightAlt many times and it did work! It worked great until relaunch 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2018 0
Explorer ,
Dec 27, 2019

Copy link to clipboard

Copied

I had this problem for years on my desktop. Now I got a new laptop and the problem is gone, even with the same Logitech wireless keyboard. Both computers with the same keyboard and input language and settings, except the obvious difference that the desktop was Windows 10 single language (portuguese) and the laptop is Windows 10 Home multi languages, which should only affect the display language.
But it seems that this issue has to do with display language.

Try going to keyboard settings in windows and  check "Let me use a different input method for each app window" then change your input language while you are in illustrator via the language bar. Maybe you have to restart Illustrator.

Said that, this is ALSO an Illustrator issue, since I never had this problem with Photoshop, Indesign or After Effects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2019 1
MrGurgul LATEST
New Here ,
Dec 10, 2020

Copy link to clipboard

Copied

I truly love you! You are a god to me. I have been struggling with that thing for couple years. Finally it is gone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2020 0
Resources