Why does everything want to open in Illustrator?

New Here ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Since October 2017 it seems Adobe Illustrator has made itself the default application for opening everything (I'm on a Mac running Adobe CC 2015 version)?

PNG screen grabs - double click they now open in Illustrator instead of Preview

PDF files - double click they now open in Illustrator instead of Acrobat

The same applies to TXT files, DOC files, PSD files, HTML files... even if I try to 'View Source' of an email in Outlook - it always opens it (or tries to) in Illustrator.

I tried the advice of selecting the file on the desktop, select Apple and 'i' to view document info, and then changing the default application back to what it should be (and selecting 'Change All' so all similar files default the same) - which works for a few days, but then it all defaults back to Illustrator again!

Perhaps I'm inadvertently doing this somehow?

Views

19.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Feb 25, 2018 Feb 25, 2018
There are a couple of other things you might need to do, such as: wrong icons and OSX doesnt know what program to... | Communities  and maybe even more. I have never had an issue with that, so I never needed to do it.Bottom line is: this is not an Illustrator issue, but a Finder issue. It happens with other apps as well. You will need to answer this question on an Apple forum, where you will find other people who could solve it.

Likes

translate

Translate

Translate
Explorer ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

Wow!  Thanks, AnnaLenaK.  That is good info.

I do use Firefox as my default browser.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

I've been having the same problem since last fall, with everything wanting to open in Illustrator. Weirdly, what worked for me was to Quit Firefox, double-click on an image to open it with Firefox off, then reopen Firefox.

So far, so good. Even with Firefox back on, all my images are again opening automatically in Preview. From what I've read in various places, it's a conflict of some kind with Firefox. There are all kinds of weird and wonderful things you can do with .plist and .sandbox, but it seems to reset itself just as well if you just quit out of Firefox, open an image, then reopen Firefox. Not sure yet how well it works over the long term, but if it happens again, I'll just do the same thing.

For the record, I'm using El Capitan and CC-whatever-is-newest, and was driven so bananas that I wanted to ditch Adobe-everything.

Good luck everyone!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

I have had the same problem for tow or three months now - with Illustrator opening all jpeg, png and some other files by defalt, regardless of clicking the 'Always' button in the Get Info dialog box. It's really irritating.

I have CS4 and El Capitan

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

  schrieb

I have had the same problem for tow or three months now - with Illustrator opening all jpeg, png and some other files by defalt, regardless of clicking the 'Always' button in the Get Info dialog box. It's really irritating.

I have CS4 and El Capitan

Please read answer #48 - does that work for you?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

The source of the problem has been determined to be Mozilla Firefox.

Here is the fix:

In Firefox, browse to about:config.

Change setting "security.sandbox.content.level" to 2 (instead of the current default value of 3).

Restarting your browser.

This makes the security sandbox more permissive, but doesn't completely disable it.

More info here;

https://bugzilla.mozilla.org/show_bug.cgi?id=1437281#c23

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

Hello Wernergt

Thanks for your email:

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Hello Guys I am happy you I am not the only one.

I have El Capital and experiencing the same issue.

No Idea why and still nothing works, very anoying

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

  schrieb

Hello Guys I am happy you I am not the only one.

I have El Capital and experiencing the same issue.

No Idea why and still nothing works, very anoying

Please read post #53

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2019 Jan 19, 2019

Copy link to clipboard

Copied

I found this to be very helpful...

Windows or a Mac?

On a PC, you should be able to fix this by going into the Help menu in Acrobat and select to repair the installation. You can also open up Acrobat's Preferences, then go to the "General" category and change the default PDF handler.

On a Mac, right-click (or Ctrl-click) on any PDF file and select "Get Info". Change the "Open with" setting, and click on the "Change all..." button.

Karl Heinz

[ private informations removed by moderator --> https://forums.adobe.com/docs/DOC-3731 ]

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2019 Jun 12, 2019

Copy link to clipboard

Copied

I don't even have Firefox on my machine.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2018 May 30, 2018

Copy link to clipboard

Copied

It is happening on my Windows PC too. So glad I found this info.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2019 Jun 12, 2019

Copy link to clipboard

Copied

SAME PROBLEM HERE.

MacBook Pro 15' 2017 / MOJAVE 10.14.5 (18F132) /  Adobe Illustrator 2019 CC

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2019 Nov 13, 2019

Copy link to clipboard

Copied

Step 1: Single click a PDF file you wish to open or any PDF file in general while holding the Control key. Then select GET INFO from the menu you’ve opened.

 

Step 2: Click the drop down menu for OPEN WITH.

 

Step 3: Select ADOBE READER [or Acrobat] from the menu.

 

Step 4: Click on the CHANGE ALL button to keep the changes.

 

Worked first time, like a charm. I'm running MacOS Sierra 10.12.6

I’m not the clever one here, this advice was from ZipLogix

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines