Highlighted

Wonky vectors when embedded from Adobe CC libraries to canvas

New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

So this happens to me every so often and I cannot find a fix. When I option drag a saved vector, like a logo to my canvas in Illustrator. The logo or graphic will look off alignment, missing segments, jagged or off. Not sure what to do. Anyone have this happen and know of a fix?

 

The top image is the wonky logo.

Screen Shot 2020-08-25 at 8.49.12 AM.png

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

Can you check if View > Snap to Pixel is checked?

TOPICS
Bug, Draw and design, Performance

Views

82

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Wonky vectors when embedded from Adobe CC libraries to canvas

New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

So this happens to me every so often and I cannot find a fix. When I option drag a saved vector, like a logo to my canvas in Illustrator. The logo or graphic will look off alignment, missing segments, jagged or off. Not sure what to do. Anyone have this happen and know of a fix?

 

The top image is the wonky logo.

Screen Shot 2020-08-25 at 8.49.12 AM.png

Adobe Community Professional
Correct answer by Ton Frederiks | Adobe Community Professional

Can you check if View > Snap to Pixel is checked?

TOPICS
Bug, Draw and design, Performance

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

How do you add the vectors to the library? Dragging them from an Illustrator artboard?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

Hi Ton, No I add them by dragging them in from my Adobe CC libraries panel where I have them saved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

How do you save them to your library? Dragging them from an Illustrator artboard?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

Yes, I drag them from Illustrator to my CC libraries. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

I was suspecting SVG files, dragged from the desktop to a library.

Do these contain live type, or are they outlined characters? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

I'm pretty sure they are all outlined. I'm taking original EPS logo files, opening them in Illustrator and then dragging them into my CC libraries. Sometimes they drag back into Illustrator fine when I do an option drag and sometimes they come out a little crooked or their alignment is off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
Adobe Community Professional ,
Aug 28, 2020

Copy link to clipboard

Copied

Can you check if View > Snap to Pixel is checked?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2020 0
New Here ,
Aug 31, 2020

Copy link to clipboard

Copied

Hi Tom, Snap to pixel is not on. I am starting fresh today and so when I do it now, everything is working good! I'm thinking that that might have something to do with it. Either snap to pixel or snap to grid may have been left on. If it happens again, I will go through and check all of those settings. Thanks for keeping up with this thread. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2020 0
Adobe Community Professional ,
Aug 31, 2020

Copy link to clipboard

Copied

Good, let us know if the problem pops up again,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2020 0