Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Autonumbering turns off when hiding a layer

Participant ,
Aug 01, 2021 Aug 01, 2021

Copy link to clipboard

Copied

Steps to reproduce:

  1. Create 2 threaded text frames on a page.
  2. Fill them with text (Lorem ipsum)
  3. Autonumber the paragraphs with Autonumbering feature in InDesign - regular 1, 2, 3-list will do.
  4. Create a new layer
  5. Move the first frame in the text flow to that layer
  6. Turn off visibility of that layer.... The autonumbering is gone from any autonumbered list!!!

Did anyone else see this behaviour?

Michael

TOPICS
Bug

Views

62

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 02, 2021 Aug 02, 2021
Hi Michael, tested a bit. It seems it depends on the visibility of the layer of the first frame of the story: Two stories with threaded text frames below. One where the first text frame is on a layer I want to make invisible. One where the second text frame is on a layer I want to make invisible. Layer "Ebene 2" is still visible, all's normal, auto numbering is working: Now watch the thread at the top where the first frame is on the layer I make invisible. Auto numbering is not rendered! ...

Likes

Translate

Translate
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

If you turn off just the sub layer it works fine

EugeneTyson_0-1627890932902.png

 

 

I see the same behaviour though. 

Not sure if it's a bug or a expected behaviour. 

The fact it works with the sub-layer makes me think it is a bug.

You can submit the bug report here

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Hi Michael,

yes. It's a known none-feature or bug. I reported that some years ago.

Especially ugly if you need to export PDFs with some layers turned off where a possible user should turn on layers in Acrobat or Adobe Reader to reveal additional contents like other languages. The auto numbers are missing.

 

Workaround?  None. The only option for the language case I mentioned above: Convert to plain text.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

To add to Eugene's reply:

There are no real "sub layers" in InDesign like in Illustrator. You simply turn off the visibility of objects like text frames or graphic frames instead of the layer itself.

 

Regards,
Uwe Laubender

( ACP )

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Indeed - apologies for the incorrect terminology.

 

The Layers are whole layers and not sublayers, and the dig down into the layer shows the objects within that layer that you can indeeed turn on and off their visibility.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Found this old thread from 2019 about the issue:

 

Multi-layered/language InDesign to Multi-layered/language PDF
timl99453563 Jan 22, 2019

https://community.adobe.com/t5/indesign/multi-layered-language-indesign-to-multi-layered-language-pd...

 

See my reply in the same thread where I tested the issue with a script:

https://community.adobe.com/t5/indesign/multi-layered-language-indesign-to-multi-layered-language-pd...

This bug is an old one that I can trace back to even InDesign CS4.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Hi Michael,

tested a bit. It seems it depends on the visibility of the layer of the first frame of the story:

 

Two stories with threaded text frames below.

One where the first text frame is on a layer I want to make invisible.

One where the second text frame is on a layer I want to make invisible.

 

Layer "Ebene 2" is still visible, all's normal, auto numbering is working:

FirstFrameOfStory-1.PNG

 

Now watch the thread at the top where the first frame is on the layer I make invisible.

Auto numbering is not rendered! Not so in the story below where the first frame is on a layer that's visible:

 

FirstFrameOfStory-2.PNG

 

So it is the first frame's layer visibility that dictates this issue!

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Thank you Uwe and Eugene,

I came to the same conclusions - the autonumbering is only affected only when the first text frame in text flow gets hidden (invisible). The solution I used was to make the layer non-printing, instead of invisible. The solution to add an empty frame before the first one, while workable, is not easy to maintain in a team environment. I filed a bug report with Adobe. The issue seems to exist since at least 2014 and I don't recall seeing it in CS5.5 but can't test it in this version currently.

Michael

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

LATEST

To add, I just tested in CS5.5 - same issue. Another solution would be to disconnect the frames from the text flow... but again, this is a hack.

Michael

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines