Black artifacts on rulers with legacy files

New Here ,
Sep 13, 2019 Sep 13, 2019

Copy link to clipboard

Copied

Hi everyone,

This issue has plagued InDesign for at least 5 years. There are many posts online about it so I'm not the only one. Whenever I open an InDesign file that's older than my current version, black artifacts start to accumulate on the rulers. I can zoom and they disappear. But once I start working at 100%, they reappear and start to accumulate again. It gets to the point that the rulers become illegible.

I'm using the latest macOS, on a 5K iMac. Not that that matters because this issue persisted with previous Macs that had lower screen resolutions. It also happens currently on my MacBook Pro 2015 with retina screen.

I'd love it if Adobe could resolve this issue. I've posted tweets on Twitter about it several times, and have contacted support in the past, but it never gets fixed.

See screenshot. Thanks!

Views

181

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2019 Sep 14, 2019

Copy link to clipboard

Copied

I have not seen this problem reported before nor have I experienced it myself on similar Mac computers. Do you have any third party plug-ins installed with your InDesign (or perhaps even your Mac OS)? If so try disabling the plug-ins and see if the problem persists.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

This issue continues, as of today, 3/3/21.

 

Since posting this topic in 2019, I have replaced the hard drive with a 2tb SSD, as well replaced the 5K display on my iMac. And no matter how many new releases of InDesign come out, the same display issue happens.

 

If I open a legacy file and save it, the black artifacts start to appear and accumulate on the rulers. If I start a brand new document, this never happens.

 

Today I opened an ID file from last year, saved it, and made some edits. As I worked, black artifacts began to appear. If I zoom or do anything while using the ID interface they go away, but then they start accumulating again. Really maddening after all these years. My iMac is from late 2015, still fast and still working perfectly, and running Big Sur with the latest macOS update.

 

Maybe someone out there has some ideas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I too am experiencing this odd artifact that appears when I drag my cursor along the bar or just dragging the anchor of a box in the file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

In the InDesign preferences - try turning off the GPU performance.

 

Other fixes include

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl (and Apple/Cmd if working on a Macintosh). A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

 

and 

You can always try the creative cloud cleaner tool https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Thanks Eugene, turning off the GPU performance didn't fix the clutter, but it made zomming in better.

I will try ressetting the preferences later and see if that helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Well! Now it's happening for me as well. (Mac iMac 27" late 2015 w/ Catalina) IDv16.4

But the file I was working on is a new file only a day old, but yes, like you I tried creating a new document, copied and pasted the exact same content onto it, and it didn't occur! GPU on or off did not make a difference.

Even weirder, as a test,  I saved my file backwards and opened it in an v15 and it still happened there too, but not on any old files  I opened.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

I'm happy to say the artifacts have finally disappeared for me somehow. It must have been from a recent macOS update or from an InDesign updater. Try upgrading to Big Sur. You're already using the latest version of InDesign. And if you really want to start from the most pristine of origins possible, wipe your drive and do a fresh install of everything. I know, it means losing a weekend, but sometimes the sacrifice is worth it.

Btw, in the past I've tried both of the suggestions that Eugene mentions on multiple iterations of macOS and InDesign over time, and neither one fixed the artifacts issue for me.

 

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

LATEST
Thanks for the info about the artifacts. They seemed to have vanished for
me. I did turn off the GPU, so maybe that did the trick and it just needed
some time to clear up the issue. Either way I am good for now.


Jon Bayley

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines