• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Can't paste vectors from Illustrator to InDesign anymore?

Participant ,
Nov 11, 2023 Nov 11, 2023

Copy link to clipboard

Copied

For as along as I've used InDesign (and I was an early adopter back in the days), I was able to copy/paste vector elements from Illustrator to InDesign.

 

Since I got my new computer last week (M2 MacBook Pro, Sonoma 14.1, newest version of all CC apps), when I copy/paste from Illustrator to InDesign, it pastes elements as 'pasted graphics' (meaning pixels, not vectors), instead of groups of vectors, as it's done up until this point.

 

How can I change this? Is this a "feature" (and I mean that ironically) of the newest round of CC apps? Is the newest version of macOS the culprit? Either way, I need to get back to be able to copy/paste vectors/paths between Ai and ID. Help?

TOPICS
Bug

Views

133

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 11, 2023 Nov 11, 2023

Go to the preferences in the clipboard section. There is the setting which is responsible for this behavior. Nothing hs changed since 2002 here. 

Votes

Translate

Translate
Community Expert ,
Nov 11, 2023 Nov 11, 2023

Copy link to clipboard

Copied

Go to the preferences in the clipboard section. There is the setting which is responsible for this behavior. Nothing hs changed since 2002 here. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2023 Nov 11, 2023

Copy link to clipboard

Copied

Hi @hanskfroschauer:

 

Elaborating on Willi's answer, be sure Prefer PDF when Pasting is disabled (which it defaulted to for me in 19.0.1). This hasn't changed from earlier versions, but 19.0 had preference migration issues during the installation, so perhaps that played a role in the default changing for you.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

LATEST

Thanks Barb! It worked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines