Cannot get background shapes to export

Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

This has been a chronic question for years now and there isn't an easy answer that I've been able to find or use. Why aren't my background layers exporting? Below are screenshots of the doc in InDesign, the document and export settings plus two separate outputs to show that when the shape is within the margins it renders, but once it reaches the edge of the document, or bleeds, it doesn't export.

I am able to get smaller objects that only bleed at one corner or a smaller section of the document to export properly so it is only when using a background layer. Either as a gradient or solid fill.

background shape not to margin.PNGbackground shape w bleed.PNGlayout.PNGexport settings.PNGbleed setting.PNG

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 08, 2019 Feb 08, 2019

I did see the initial probelm and exporting as smallest file size it exported correctly.

I switched to High Quality and it exported incorrectly.

The fact that you started a new document and it still happens, might something quirky with your default swatches.

Reset your Preferences.

  1. (Windows) Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
  2. (Mac OS) While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want
...

Likes

Translate

Translate
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

When you say background layer, what exactly are you referring to. Can you please show screenshots of your layers panel.

-Dax

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Can you provide a screenshot of the Advanced-tab please?

And just my 2 ct: Is that yellow box your final solution to to cover the text/something?

Bildschirmfoto 2019-02-08 um 12.01.49.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

The yellow box is just a quick cover up. This was for a potential client who went a different way, and I just didn't want their name in screenshots. Since they're immaterial to the question, I just put a box over their name. But here's the advanced tab.advanced.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Sorry, I used "layer" like you would in Photoshop. Here's the layers panel, and as you can see I'm referencing the rectangle with the gradient in it. layer.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

InDesign has a few ways to supress printing/export of images/layers

Check Window>Outpu>Attributes and ensure Nonprinting is not selected

Screen Shot 2019-02-08 at 12.58.20.png

or more likely - Window>Layers - then click the 3 lines in the top right of the panel - (above the blue score on the image on the right)

Layer Options> and ensure Print Layer is not turned off (there should be a tick mark)

Screen Shot 2019-02-08 at 12.58.38.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

I just checked and nonprinting is not selected in Output but Print layer is selected in the layer panel, so that's not why the background isn't exporting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

When you go to View>overprint preview in InDesign does the background disappear?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

No, the background is still there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

That's odd.

Feel like sharing the file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Ok - when I first opened the file I got the same result.

I checked the swatches - and there's swatches in a folder - the royal blue colour - that did not show up any colour in the dialog box at all.

I deleted this swathc and replaced it with the swatch already there in the main panel of swatches.

And it all works now.

Seems to be some sort of file corruption (not uncommon and nothing to worry about)

You should use File>Export and choose IDML - open that and it opens as untitled.

And then save that as a new file.

Try the export now.

Failing that try the swatches steps above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Unfortunately, I'm still having the problem with the background even when I tried your suggestions. I even created a new document using only preset swatch colors and the background did not export when it covered the full document. It did export when it was only 3/4 of the document though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 11, 2019 Feb 11, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Eugene+Tyson  wrote

Ok - when I first opened the file I got the same result.

Hi Eugene,

very strange. I had no problem to export to PDF and seeing the background.

Tried with PDF/X-4 and PDF/X-1a presets.

InDesign CC 2019 version 14.0.1.209 on Windows 10 (German).

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 11, 2019 Feb 11, 2019

Copy link to clipboard

Copied

Hi Lau

It only happened briefly but can confirm it happened for sure. I opened the file Indesign 13.1 on my Mac and had the issue.

Later opened on my Windows laptop and using 14.1 (latest version available of INDeisgn) and the issue persisted.

But also quickly disappeared.

It was like it was trying to use old information but somehow got overridden and resolved the issue.

That's why I thought that there may be some default settings corrupt on the users end, like default swatches, or a bad pref file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Interestingly enough, I downloaded and opened the indd file and was able to export a pdf with the background with no problem from your exact file. Can you tell us what version of InDesign you are using? 14.0.1 is the version I am on.

Also, I see that you are using the gradient feather tool. What happens if you just change it to a solid color, or if you change it to a normal gradient fading from your blue to white?

-Dax

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

I'm in 14.0.1 as well. I even uninstalled and reinstalled so I'm working with a recently installed version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

The problem for me appears to be with the bottom edge. Anything that touches or bleeds at the bottom edge of the document doesn't appear when I export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

I did see the initial probelm and exporting as smallest file size it exported correctly.

I switched to High Quality and it exported incorrectly.

The fact that you started a new document and it still happens, might something quirky with your default swatches.

Reset your Preferences.

  1. (Windows) Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
  2. (Mac OS) While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.

If that's not working then a clean install

Use the Creative Cloud Cleaner Tool to solve installation problems

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 10, 2019 Feb 10, 2019

Copy link to clipboard

Copied

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

And I'm having the same problems with solid as well as gradient backgrounds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

LATEST

SOLVED Had the same issue, found this elsewhere: Check your Acrobat preferences: Edit > Preferences, then click on accessibility and make sure "Replace Document colors" is NOT checked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Save time with Adobe Express quick actions