• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Cannot turn off Ordinals in paragraph styles

Community Expert ,
Apr 09, 2023 Apr 09, 2023

Copy link to clipboard

Copied

I have some subheads that always show with ordinals, so some letters are superscripted. I can select the text and turn ordinals off in the Opentype menu in the Character panel. But I cannot control the appearance of the ordinals in the style definition. Whether I turn ordinals on or off the text shows as ordinals unless I manualy change the formatting. If I redefine style the change has no effect. That is, remove ordinals from one subhead, redefine style, and the other subheads do not change.

 

Every time I apply any style ordinals are turned on for the affected paragraph. There seems to be no way to prevent this. Aain, to be clear, ordinals are off in the style definition.

 

Anyone experience this and have a solution that will prevent errant ordinal characters?

 

Mac OS 13.3.1

InDesign 18.2.1

Font: Minion Pro

TOPICS
Type

Views

190

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2023 Apr 10, 2023

Copy link to clipboard

Copied

Where did the text come from? Are there any character, grep or nested styles at work that you might have overlooked?

Screenshots or, even better, the document itself would be helpful.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2023 Apr 10, 2023

Copy link to clipboard

Copied

There is a GREP Style to apply ordinals to, well, ordinals (st, nd, th after numerals). I turned that off and even deleted the Character Style but it does not change anything. Note, again, that Ordinals is off for the style. Turning it on, saving the style, then turning it off again does not affect the issue. Deleting preferences and saving an IDML did not fix anything.

 

The text was pasted from a Word file. Formatting does not travel through the clipboard so the text pasted as my default style. The document is an annual report based on the annual report from the previous year. That document does not exhibit this behaviour.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2023 Apr 10, 2023

Copy link to clipboard

Copied

Is it happening in a new file? Have you checked for a default character style that's being applied? Ordinals selected when not text cursor is active? These things do happen to all of us once in a while.

Maybe it's time to trash the prefs.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2023 Apr 10, 2023

Copy link to clipboard

Copied

LATEST

It’s happening with the newer version based on the old file. I did some experimenting: Copied the text from new version and pasted into the older file. Then I selected some text and changed the paragraph style. In this example I changed a Body Copy paragraph to Body Copy Tight, then back to Body Copy. Problem appeared. The file did not do this before, so there is something hinky about the text in the newer file.

 

The older file did not have this behaviour so I tried an experiment: I exported the text from the new file to a text file, this way there is no chance any formatting can corrupt the new file. I place the text then pasted it it over the text in one page. Buggered.

 

Test two: Open the text file in Text Edit and copy and paste the text into the new file (deleting the experiment from the previous paragraph). This appears to be working.

 

And I did trash prefs, as I said in the previous post.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines