CC Library popping up when creating swatches—figured it out

Participant ,
Jun 22, 2015 Jun 22, 2015

Copy link to clipboard

Copied

So I was having this issue with the new InDesign CC 2015 (Mac) and I finally figured it out and thought I'd share, in case anyone else is in the same boat.

I don't use any of the sync stuff, but I was constantly having a CC Library window pop open every single time I'd create a new swatch in an InDesign document (CC 2015). Wasn't having this problem before the upgrade.

It turns out that there's a checkbox at the bottom of the New Color Swatch window: "Add to CC Library." Looks like this is checked by default. Just uncheck it. Seems like it remembers this from then on.

I was going crazy for a bit there, because I had turned off all my sync settings in InDesign and clicked "Manage Creative Cloud Account" to clear settings on the website. I even went so far as to rebuild my InDesign preferences (because at one point the colors palette lost all of the buttons at the bottom and I could no longer delete swatches), repaired permissions in OS X, restarted my computer, yet this was still happening. Then I noticed that checkbox... yeah... a checkbox that was probably there the whole time. Go me.

Anyway, there you go.

Views

12.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

THANK YOU!

Yep, there it is in the bottom lefthand corner where I would never look while I'm on auto-pilot!

—April

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 14, 2015 Oct 14, 2015

Copy link to clipboard

Copied

This is agonizingly close to what I need. Except I can't see any checkbox? All I see is a cloud that won't let me turn off anything. What am I missing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

Hey! Thought I'd see if this helps. . . . Beats working, right?

When you make a new paragraph style or new color swatch etc., InDesign now defaults to having the "add to CC Libraries" option selected. It's a box that is in the lower left corner of the dialogue boxes. You want to UNcheck it whenever it shows up. See below. . . . Hope it helps!

--April

Screen Shot 2015-10-15 at 10.26.24 AM.png

Screen Shot 2015-10-15 at 10.26.44 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

Thanks for the guidance! I thought that might fix my main problem with CC Library, which is that I can't stand how it insists on popping up every time I start ID. I turned it off for swatches, ¶ styles and char styles, but to no avail. It's still there when I start up. Not the biggest problem in the world, but annoyingly intractable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

Try doing what April suggests with no document open, if you haven't already. It should remember your setting for each new swatch and paragraph/character style you set up.

So, for example, launch InDesign by itself, go to Swatches and select New Color Swatch... and uncheck that CC Library box. Hit OK (you can delete the swatch after the fact).

Then do the same for Paragraph and Character styles -- uncheck that box and hit OK to create the new styles, then just go back and delete them.

But also make sure you've closed that CC Library window with no document open, too. If you close it with a document open, it'll only remember that setting for that particular document. After you close that window and do the other unchecking steps above, if it still doesn't go away, maybe try creating a new workspace with it turned off (Window -> Workspace -> New Workspace...)...?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

Very much appreciate the suggestions — still no luck. Even the new workspace doesn't do it.


By the way, just so I'm clear, I'm not talking about the palette popping up when I add a swatch or style. I mean that it's always there when I first start up ID. Even right-clicking and closing the palette doesn't help. It just insinuates itself back in there when I restart. I get the impression Adobe really, really wants to push CC Libraries. But others aren't experiencing this issue, it seems?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

No, I don't experience it, myself, after making the changes per above.

Here's what happens for me -- just a quick vid I just uploaded to YouTube. Shows me opening InDesign in real-time:

InDesign Launch - CC Libraries - YouTube

That panel kinda "blips" open as I'm launching it (about 13 seconds into the video), but then it goes away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2015 Oct 15, 2015

Copy link to clipboard

Copied

Interesting. Yeah, my blip just stays there. I've tried all the suggestions, to no avail. Guess I'm just stuck with it. Thanks again for trying to help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

It happens to me too. I even tried moving it with the rest of my panels even though I don't use it. But it keeps coming up in the middle of my screen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2015 Oct 30, 2015

Copy link to clipboard

Copied

After turning off syncing in my preferences, I no longer have that option when I add a new style.

But the palette refuses to go away no matter how many times I reset my workspace. But at least the slowness has gone away. I'm going to make an Alias of the Adobe Application Manager folder and just dele the CC Library every day.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

I updated today (figuring why not, can't be much worse?), and the problem has gone away.


No telling what other problems I have, but the hesitation has been solved for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2015 Dec 03, 2015

Copy link to clipboard

Copied

Thanks guruscotty — the update fixed it for me as well. At least once I turned off the "Show Start Workspace when no document is open" setting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2015 Dec 03, 2015

Copy link to clipboard

Copied

Unfortunately it didn't work for me. It looked like it was going to but then I had to get rid of the "Application Frame" and then it started showing back up. I'm now trying to hide the panel behind the others that have open all the time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2016 Apr 12, 2016

Copy link to clipboard

Copied

thank you thank you thank you thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

You have saved me much frustration, can't thank you enough!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

I am having this problem as well and while i was able to uncheck the "add to cc library" box in the Paragraph and the Object styles dialog boxes - when I click "create new swatch" in the swatches pallete - there is no checkbox there for me to turn that off.

Can anyone tell me how to fix this?

It is a total pain in the arse to constantly have to close the cc swatch pallette that opens after every single sampled color swatch I create. Please help if you have a solution!  It's painfully annoying and cramps my workflow.

ADOBE PLEASE FIX THIS PROBLEM!!!

The cc swatch library should be an option and if you want to use it it should need to be activated and should not be the default that it launches.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

What version of InDesign are you running? Fixed in InDesign CC 2019. It's not turned on by default.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

Oh...I just noticed we are still on 2018. Thanks for the tip. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

"here's a checkbox at the bottom of the New Color Swatch window: "Add to CC Library." Looks like this is checked by default" Why is this set as the default?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 05, 2022 Aug 05, 2022

Copy link to clipboard

Copied

LATEST

The default for the New Color Swatch panel in InDesign 2022 (and I believe that last two versions before that) is for "Add to CC Library" to be turned OFF as shown below

 

Screen Shot 2022-08-05 at 3.31.16 PM.png

Are you using an older version of InDesign that 2020? (If you are using a current version, restore your InDesign preferences.) I restored my InDesign 2022 preferences before making the screen capture. I think it's also a sticky preference (one that stays on if you check it).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines