• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Character direction in latin text imported on InDesign Middle East Version

Explorer ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

I installed InDesign ME (Middle East Version) for a bilingual project (Portuguese and Arabic), but I'm having trouble working on other projects whose text is exclusively in Portuguese.

 

Specifically, I'm having problems with character direction when importing Portuguese text files: all imported files bring text with character direction as RightToLeft, and it's always necessary to apply the styles using Clear Overrides, or else select the text entirely and change the character direction.

 

In one of these projects, I'm preparing a template that will be used by other designers, who will work in the standard version of InDesign. I'd like to avoid needing an additional step in the process to correct the character's direction.

 

I've already tried to change the character direction in [Basic Paragraph Style], and even edit [No Paragraph Style] (which is in Styles.xml, inside the .idml file). None of the attempts were enough to fix this problem. Any suggestion?

TOPICS
How to , Import and export

Views

26

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Oct 19, 2022 Oct 19, 2022

Got the solution! The character direction needs to be defined in [No Character Style], inside the Styles.xml of the .idml file. I just added the CharacterDirection="LeftToRightDirection" parameter at the end of the line:

 

<CharacterStyle Self="CharacterStyle/$ID/[No character style]" Imported="false" SplitDocument="false" EmitCss="true" StyleUniqueId="$ID/" IncludeClass="true" ExtendedKeyboardShortcut="0 0 0" Name="$ID/[No character style]" CharacterDirection="LeftToRightDirection" />

Likes

Translate

Translate
Explorer ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

LATEST

Got the solution! The character direction needs to be defined in [No Character Style], inside the Styles.xml of the .idml file. I just added the CharacterDirection="LeftToRightDirection" parameter at the end of the line:

 

<CharacterStyle Self="CharacterStyle/$ID/[No character style]" Imported="false" SplitDocument="false" EmitCss="true" StyleUniqueId="$ID/" IncludeClass="true" ExtendedKeyboardShortcut="0 0 0" Name="$ID/[No character style]" CharacterDirection="LeftToRightDirection" />

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines