Cintiq Display Problem with InDesign

Community Beginner ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

I am a long-time InDesign user. I just upgraded to a Cintiq monitor for my MacPro and all of my Adobe apps are working great except for InDesign. There are little gray boxes all over the page and artboard. It's not an image resolution issue, it seems to be a display issue. They redraw when I zoom in and out and adjust display quality settings but they don't go away.

Wacom says it's a software bug since the monitor is working great in all other uses, and they suggested reinstall InDesign - which I did, and it did not resolve the problem. I've tried all the display setting options both in Indesign and also in system preferences.

This is a huge issue for me as I use my monitor both for digital painting and as my standard work monitor.

But I can't seem to find anybody else having this problem. Anybody? Take a look at the attached screenshots.

TOPICS
Bug , Feature request , How to , Performance

Views

73

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

Hi @JamiButler

 

We are sorry to hear about your experience. I would request you to share a few more details like:

  • The exact version of macOS Monterey & InDesign
  • Does it happen while working on all files?
  • Does turning off “GPU Performance” from InDesign Preferences >  GPU Performance > uncheck GPU Performance helps to resolve the issue?
  • Screenshot of “About This Mac” (both Overview and Displays tab).
  • With which port and cable combination is it connected?
  • What is the screen resolution of your display(s)?
  • Are you using eGPU?
  • Screenshot of your UI scaling settings from the InDesign preferences.

 

We are here to help. We just need more information.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2022 Feb 06, 2022

Copy link to clipboard

Copied

Hi, turnign off GPU performance in the Indesign prefs did solve the problem!  It's a little bit glitchy on redrawing when I move around or switch pages, etc. but it does eventually redraw correctly with a few clicks or zooms. And the squares are gone so until I upgrade my Mac I'm happy with this result.

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear that, @JamiButler. I would suggest you turn on the GPU performance and check if changing the UI scaling from InDesign preferences help resolve the issue or not.

 

Also, last week we released v17.1 with multiple bug fixes. You may update the app and check if it helps.

 

Let us know how it goes. We will be looking forward to your response.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines