Copy and Paste issue on the same document - unwanted spacing on top and overset text

New Here ,
Nov 01, 2019 Nov 01, 2019

Copy link to clipboard

Copied

I recently had  a new work laptop and re-downloaded the Adobe software. Since then when I create a text box, there is an extra spacing above the text (always set to 'ascent' in First Baseline'). I have checked the settings and everything looks fine and is set as previous.

 

Problem comes when I try to copy and paste a text box (from an existing document, created from another pc), the copied text box has an extra space/paddign on top, resulting the text move down and have an overset text box. It is done in the same document so everything should retain and shouldn't be conflict of styles. When I open a new document, this extra space stay too. We maintain a lot of existing documents (text-heavy) and loads of them are direct copy and paste jobs before we make further changes. It is not good when every text box I copy has an overset box as they don't sit right in the template and have to be repositioned. 

 

Screenshots below:

 

original doc:

1.jpg

 

original doc with copied text box at the bottom:

2.jpg

 

It's a straightforward copy and paste and I really can't work out why it does this. All settings looks ok.

 

Another thing is, when I tried to shorten the original text box's width, the text shifts down (to where the unwanted top padding starts), resulting the second line overset.

 

oringal text box re-sized with no height change:

3.jpg

 

Please can anyone help? I wonder it's anything to do with a newer version of InDesign, I'm on 14.0.3?

 

Thanks all in advance.

TOPICS
Type

Views

497

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2019 Nov 02, 2019

Copy link to clipboard

Copied

In your Text Frame options - go to the 2nd tab and change it to Cap Height.

See help section 

First baseline offset options

https://helpx.adobe.com/indesign/using/creating-text-text-frames.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2019 Nov 02, 2019

Copy link to clipboard

Copied

Thanks Eugene. Unfortunately, that has been tried before and it makes no difference. I have tried all the options Ascent/Cap height etc, none worked.

 

Another thing is, within the original text box, I did 'Find and Replace' text function, the text will shift down too. That should be a straight replacement of text and should make text move. It doesn't do it on the other machine so I'm convinced it's something to do with this version of InDesign or its settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2019 Nov 04, 2019

Copy link to clipboard

Copied

Hm. Does the text's baselines snap to the document's baseline grid?

If yes, I'd turn this paragraph formatting off.

 

Before, text snaps to the baseline grid ( screenhot is showing the Paragraph panel from my German InDesign CC 2019 😞

 

Text-with-BaselineGrid-1.PNG

 

After, where I turned off: Snap to Baseline Grid:

 

Text-with-BaselineGrid-TurnedOff.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

Thanks Uwe, unfortunnately changing the aligment to baseline grid doesn't make any difference. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

Hi peggieliu,

can you share a sample InDesign document where you see this issue?

Best save it with a Dropbox account and share the link.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I am having this same exact issue, did you ever find a solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I am having this same exact issue, did you ever find a solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Hi libbyvaughan,

thank you for bringing up this issue again!

 

My findings:

The root cause is a font substitution of font styles from font families that are both available on Google Fonts and Adobe Fonts.

 

If you substitute a font style that initally was activated from Adobe Fonts with the same font sytle of an installed TrueType font file from Google Fonts. And also the other way around: the document was done with an installed TrueType font file from Google Fonts, was handed over to someone where that font style was not installed and then was substituting the missing styles with activated font styles with the same name from Adobe Fonts.

 

See my reply in this thread where I have some proof of this in a document when using styles from the Roboto font family:

 

https://community.adobe.com/t5/indesign-discussions/space-added-above-and-below-source-sans-pro-and-...

 

Be aware that this issue is not only with the Roboto font family.

It can become an issue with every font family that is available both on Adobe Fonts and Google Fonts.

 

One thing you can do:

Change the position of the first baseline in a text frame from ASCENT_OFFSET to e.g. a fixed value.

You'll find this control in the text frame options.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

LATEST

Thank you!! I saw your answer in the other thread and it helped me fix the issue! All I had to do was disable the font in question in Adobe Fonts as it seems that inDesign was defaulting to the Adobe ones--even though I was using a packaged file where the attached fonts were given. Thank you! Such an annoying issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines