• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Copy/Pasting Chinese characters from Word into InDesign fails

New Here ,
Aug 10, 2017 Aug 10, 2017

Copy link to clipboard

Copied

I cut and paste chinese characters and English text from Word to windows to Adobe PageMaker it comes out wrong so I tried to do the same using InDesign but it also does not display the text correctly especially the Chinese characters. What I should do?

Views

7.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

InDesign by default does not carry styles & attributes with copy & paste. Look at Clipboard & Handling in the Preferences & change the Paste option to All Information (Index Markers, Swatches, Styles, etc.) (picture below). InDesign defaults to Text Only which is not what you want in this case.

Screen Shot 2017-08-11 at 3.43.39 AM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 18, 2020 Aug 18, 2020

Copy link to clipboard

Copied

This way worked for me! Thank you! We work with offices in China. They sent me translations from a Word Document and it copy and pastes directly into InDesign without messing up the symbols and exports just fine. 

 

THANK YOU! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

Hello, this does not work for me for Chinese Characters. Am I missing something? Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

I'm thinking you might be encountering differences in the character encoding between Word and InDesign.  

  • Which font is applied to the Chinese text in Microsoft Word? Are you able to use the same font in InDesign to format the text?

Alternatively:

  • Have you tried using File > Place command to place the text from Word into InDesign?

Basically ensure that the font you use to format the Chinese text uses an identical character encoding to avoid font mapping issues when copying and pasting. As you mention you originally tried pasting into Adobe PageMaker, I'm wondering if the system you are working on still uses legacy Big Five / Guobiao font encoding instead of Unicode. For more information see also: FAQ - Chinese and Japanese

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Cari has a great option there: File> Place! If you turn on Show Import Options, Word will have many options that can be altered for InDesign. By default, if you did not select Show Import Options, Adobe would bring in the Word Style unless there was a conflict with the style name in InDesign then it uses the Indesign Style. You can change this if you Show Import Options.

Screen Shot 2017-08-11 at 10.23.23 AM.png

Doc, Docx and rtf options:

Screen Shot 2017-08-11 at 10.22.44 AM.png

FYI a txt file has different options:

Screen Shot 2017-08-11 at 10.35.27 AM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 20, 2023 Apr 20, 2023

Copy link to clipboard

Copied

Also, make sure Preferences > Advanced Type > Default Composer: is set to Adobe World-Ready Paragraph Composer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 20, 2023 Apr 20, 2023

Copy link to clipboard

Copied

LATEST

Hi John,

if one likes to copy/paste Chinese text from Word, I think it would be better to use the Adobe Japanese Single-line Composer the following way:

 

Draw out a new text frame.

Add dummy text to an empty text frame.

While activating the menu command to do this hold the CMD key (Mac) or the CTRL key (Windows) and select Chinese. InDesign would use the default font for Chinese, Adobe Song Std, for the dummy text.

Then select all the dummy text before pasting the Chinese text from Word to replace the contents.

 

If glyphs are missing, one will notice this because of the pink highlighting of glyphs in Normal page view, use a different font for the Chinese text.

 

Regards,
Uwe Laubender
( Adobe Community Expert )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines