Data Merge- Data is importantly very incorrectly and all over the place

New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

When I import a .csv file, the data is displayed all over the place, very incorrect. Clearly there is something wrong with my source data doc. I think the problem is formatting. So I format it in a way that the data is not abbreviated due to not enough cell space. Very think is now readable by InDesign.

This is my issue: formatting does not save within a .csv. InDesign Data Merge requires a .csv. How do I save my formatting in a .csv so that InDesign can read my data correctly? 

TOPICS
Import and export

Views

84

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 26, 2022 Jul 26, 2022

OK.

First, make a new template file for the data merge. Preview has been buggy for years and can cause bad merges, so I advise never to use it. If a preview has damaged the template, in my experience it cannot be recovered and must be rebuilt.

Running a test merge on a few records is one quick option, or just merge the whole data set without preview. If it's correct, great, else juast discard the bad file and find the problem before rerunnning the merge.

Are there any special characters in the f

...

Likes

Translate

Translate
New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Sorry for all the typos! Was very tired. I think the  TRIM function is my solution. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Need a lot more information.

Version of InDesign, OS. Single record or multiple records per page? Do you preview the merge before running? Are the merge fileds on the Parent/Master page or the document page? (A screen shot would be very usefule here) How was your .csv file made? How is it encoded?

For what it's worth, you can use either .csv or tab-delimited text for your data source.

Are you able to share your template file and a sample of your data file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Thanks for the reply.

InDesign version 17.3 on Windows 10 operating system. Single record per page, generating a total of 250 records total. I do use the preview before running the merge and don't get any further than that because it does not preview correctly. I am not sure if the merge fields are on the parent/master page or document page. I'm thinking document page. Unfortunatley I can't share any screenshots or CSV's due to stakeholder confidentiality. 

The .csv is created through an export on WizeHive (the database I use). I open in Excel and import into InDesign. Encoding is UTF-8.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

OK.

First, make a new template file for the data merge. Preview has been buggy for years and can cause bad merges, so I advise never to use it. If a preview has damaged the template, in my experience it cannot be recovered and must be rebuilt.

Running a test merge on a few records is one quick option, or just merge the whole data set without preview. If it's correct, great, else juast discard the bad file and find the problem before rerunnning the merge.

Are there any special characters in the field names? Check the first row of the file in Excel VERY carefully. Also look for line breaks in individual cells that might cause a problem.

You can also try resaving in Excel, and try saving as tab-delimited rather than .csv and see if that makes a difference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Peter,

This is so helpful. I am excited to try out these potential solutions. Will keep you updated!

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

LATEST

But, to emphasise: a CSV contains only text. There is no place in a CSV for anything else. No formatting is possible. Formatting has to happen in InDesign. TXT is the same. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines