Data Merge Doesn't Let Me Edit Merged Data Sometimes

New Here ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Hello!

 

I have an InDesign file which I import data from a CSV into, but sometimes InDesign won't let me edit what I import. In these cases, when I click into the text to edit it, the entire imported field gets selected and my only option is to delete all of it; I want to edit just some of it and leave the rest.

 

For example, let's say a field imported contains the text ABCABC, but I want it to be ABCDEF. If I click into the field's text box, it selects all of the text instead of just some of it. The second I type anything or try to delete anything in the text box, the whole field is deleted.

 

Is there an option I'm missing to stop this from happening? It seems to happen randomly, and usually I can do what I want to, which is edit the imported value within the text box.

TOPICS
Bug , How to

Views

63

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Can you show an example with hidden characters and tag markers showing? Other than tag markers, a merged Indesign document should not be any different than a standard document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Hidden characters and tag markers are showing in the following examples:

 

In the first image, I haven't tried to edit the text.

example-pt1.png

 

In the second image, I have tried to edit the text, but InDesign selects all of the text; it won't let me select just some of it or delete any of it without deleting all of it.

example-pt2.png

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Your screen shot is not showing either hidden or markers, it would look like this:

cant-select.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Ah, I apologize. I thought they were on. See the following screenshots. Is there a different way to enable them?

example-pt4.pngexample-pt3.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Change Hide Hidden Characters to Show Hidden Characters. For tag markers, View > Structure > Show Tag Markers.

You should be able to select and highlight individual characters without issue. Some times the tag marker can interfere with selecting multiple words, but your example appears as one placeholder.

 

Are you double clicking or triple clicking when selecting? Are you contexually selecting or holding down other keys like alt, shift, etc.?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

LATEST

Thanks, Jeff. I really appreciate it. I made those changes and it's still not showing any markers/tags.

 

I am not holding down any other keys and I am not double-clicking or triple-clicking: even when I click once, the text is automatically highlighted.

 

For whatever reason, the file isn't experiencing this problem now, but it happens from time to time on various files. I think it has something to do with whether the merged values are saved into the document or not: after reloading the file this time, it wasn't an issue. Next time this happens I'll try saving and re-opening the document a few times to see if that won't fix the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines