Data Merge images crashing InDesign on Preview or Create Merged Document

Community Beginner ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

InDesign Version 17.2.1

M1 Ultra Mac Studio

macOS 12.3

 

I can preview and create documents as expected, but as soon as I add an image and try to preview or create a document, InDesign hangs and needs to be force quit.

 

I'm using absolute paths with a colon as a seperator, e.g.

 

Column name: @My_image

Data: Users:daz:Documents:MyProject:Images:my_photo1.jpg

 

Same format I've always used, only now it's crashing

TOPICS
Bug

Views

73

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , May 09, 2022 May 09, 2022
Update: You need to open System Preferences > Privacy > Full Disk Access, and add InDesign.

Likes

Translate

Translate
Community Beginner ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Additionally, opening a previous .indd that was generated with the same master file, the image renders corrupted in InDesign, and exporting to PDF gives an error that files/URLs are not accessible. There's only one linked file, and it's clearly accessible because I can right click it in Links, and click Reveal In Finder, and Finder jumps straight to the image. It's not a crazy image format either, same thing is happening with images from multiple cameras.

 

These errors are only since upgrading to an M1 Mac on Monterey, from a 2014 iMac on Big Sur. It appears image links are entirely borked, whether that's an InDesign version issue or M1 compatibility, I'm not sure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

LATEST

Update:

 

You need to open System Preferences > Privacy > Full Disk Access, and add InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines