• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Disappearing Copy on "No Break" Style

Participant ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

I'm in the process of setting up a GREP to eliminate widows and orphans. One of the steps says to set up a Character Style for the body text where the "No Break" is enabled. When I do this, all my text disappears accept for maybe the first line.

Views

2.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 04, 2019 Feb 04, 2019

That's great, Mark.

And the color is just so that you can see what is going on. Once you know it is working as expected, you can turn the color back off on your No Break character style.

By the way, my GREP string will keep the last two words together, whereas yours keeps the last 10 characters together.

\w+\s\w+[[:punct:]]+$

vs

.{10}$

Just as a heads up, that will result in a single word on its own line in some situations. As long as that is OK, you are good to go!

Screen Shot 2019-02-04 at 1.34.30 PM.png

~Barb

Votes

Translate

Translate
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Hi Mark:

We can help you with this but need a little more information.

Can you show us a screen shot for your GREP Style in your Body text style, similar to mine, below?

And I find it helpful to add a color (temporarily) to my character style so that I can see exactly which letters are being assigned the No Break. If you look at Edit > Edit in Story Editor the text is still there, right? I'm guessing you are signing the No Break style to more characters than you think.

For example, this applies my No Break style to the last two words in a paragraph.
Screen Shot 2019-02-04 at 11.00.44 AM.png

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

I think it's working now. I just set up the Paragraph Style to call on the No Break in the Character Style.

Screen Shot 2019-02-04 at 3.06.13 PM.png

I'm not sure what I was doing wrong but now I can see my colored text like in your sample. I think we're done her. Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

That's great, Mark.

And the color is just so that you can see what is going on. Once you know it is working as expected, you can turn the color back off on your No Break character style.

By the way, my GREP string will keep the last two words together, whereas yours keeps the last 10 characters together.

\w+\s\w+[[:punct:]]+$

vs

.{10}$

Just as a heads up, that will result in a single word on its own line in some situations. As long as that is OK, you are good to go!

Screen Shot 2019-02-04 at 1.34.30 PM.png

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2020 Jan 06, 2020

Copy link to clipboard

Copied

Late last night (rushing to make a deadline) I had major issues with things disappearing.  I've concluded that the main problem was suddenly my entire bibliography text would disappear and I would hit undo.  As this kept repeatedly happening, I must have accidentally been undoing things all over the 15 page document (nightmare).  That is the only explanation I think makes sense for random things moving back to how they were two hours prior.  which leaves the disappearing bibliography as the source of the issues.

I have no idea how to diagnose the issue but I had been messing around with text box settings and using auto fit (with no line break) for the first time, and copying the whole bibliography text from word, so this could easily be the issue (thank you for making this thread or I may have never figured it out).  

 

When I'd paste the text it would import long and skinny.  When I'd resize the box it would initially look like two separate boxes (skinny full of text, and wide empty second box) until I'd double click. Then it would seemingly be fine but next time I look it's gone.


But the whole text box was gone, not just the text in it. Nothing on the page. Does it make sense that this could happen because of auto fit/line break?

 

It's POSSIBLE that the text became invisible and my instant "undo" reaction un-pasted it...which could result in no box?

 

I would be grateful for any help just figuring out what the problem could be. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

I have seen two forum posts on No Break causing text to disappear (pushing it offset) while trying to setup a No Break–GREP rule, and neither of your posts, both of which are marked as answers, helps prevent the text from disappearing in my case. Is it because I have text split across multiple text boxes?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

Disregard, I figured it out. The No Break rule I created was applied to a previous style, so all text, rather jsut a rule by itself applied to no body of text, that the GREP rule could reference alone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

Can you perhaps send screenshots? I'm in the process of solving the issue on my side but don't manage.. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

LATEST

Also just figured it out! So basically you are NOT supposed to add the Character Style (with the No Break Rule) to neither your text frame box nor your text! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Widows and orphans are handled in the Keep Options of the paragraph style. Set the Keep Lines Together to 2 and you have a simple solution to preventing widows/orphans.

If, on the other hand, you dislike short runt lines, in general, than either of your GREP solutions that apply the No Break command will help.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines