Disappearing Footnotes

Community Beginner ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

For a while now footnotes have been disappearing from my documents--just the actual footnote, not the reference. When enough disappear that text reflows I receive the "Overset Text" error, but recently one disappeared and text should have reflown but did not, and I received no error warning. This was only caught by chance before sending it to the printer. 

 

I have seen others on forums struggling with issues like this, but there are never any answers, from Adobe or from other clever typesetters. This is a very concerning problem. Please let me know if there's any way to at least make sure I am notified if footnotes disappear!

TOPICS
Bug , Performance

Views

3.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 03, 2021 Feb 03, 2021

The fix for this issue is now available in the latest update of InDesign—version 16.1

Please update to this version to get the fix. To prevent problem on existing documents and see the footnotes again, you will have to force recompose the stories. To force recompose stories, you can use the shortcut Command-Option-/ (slash) on Mac or Ctrl-Alt-slash on Windows.

 

—InDesign Team

Likes

Translate

Translate
Guide ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

very serious bug and it was reported here:

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/38832532--performance-f...

Adobe engeneering team traying to find one solution

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

It would help a lot if you would add to your report: Please tell us what operating system (exactly) you're running. Please tell us (exactly) what InDesign version you're using.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

Right, sorry! I am using 15.0.1 on a Mac desktop computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

I've been getting this as well for a few weeks. Footnote text just randomly disappears. The only indication is an "overset text" message when creating a pdf. Extremely serious bug.

 

I am using Indesign 15.0.1 on Mac OS 10.13.6

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2020 Jan 31, 2020

Copy link to clipboard

Copied

I am on Indesign 14.0.3, Mac OS 10.15.3. I have had same issue with footnotes going to overset text with no warning. This was just discovered in a 19-chapter, 660-page book that is about to go to printer. I had to go through every chapter finding the footnote number reference in the text, then make sure the footnote itself is not hidden. I found 6 instances out of hundreds of footnotes. This was discovered AFTER the book went to the indexer, so page breaks could not be changed. This is serious!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2020 Apr 14, 2020

Copy link to clipboard

Copied

My own workaround to this problem while working on a 1000 page document:
Firstly, I only know of the problem when updating the TOC. It gives a warning of overset text, but no indication of where it is.
The solution is to do a global format change of all superscript characters (footnotes reference format) to be changed to color black, which is already the color of the footnotes references. I use black in my document, and actually nothing changes, but this will make all footnotes appear again. You can check this first on individual occurrences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2020 May 15, 2020

Copy link to clipboard

Copied

You've just saved my life.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 05, 2020 Jun 05, 2020

Copy link to clipboard

Copied

hey,

i do not understand your workaround. can you elaborate?

My english is not that good, sorry. I tried to change the paragraph format, but it didnt change anything.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2020 Jun 07, 2020

Copy link to clipboard

Copied

footnotes_bug

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2020 Jul 24, 2020

Copy link to clipboard

Copied

Do you find that you have to use Find/Change to make this work? I had been doing it in the footnote reference style, highlighting and then unhighlighting the footnote. It fixed it immediately for a while, but then I noticed it made some things reflow, which makes no sense because the size doesn't change at all. I was just wondering if you have tried changing the style itself and if that works? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2020 Jul 23, 2020

Copy link to clipboard

Copied

I JUST had this problem start today--months after the OP, and I use Indesign almost every day! While the work around suggested above about the footnote color works (thank you!), has Adobe not fixed this or a settings solution found? I'm running the latest version, which is 15.1.1. No overset text message either. So frusterating as I now need to check everything.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 23, 2020 Sep 23, 2020

Copy link to clipboard

Copied

I'm so glad to have found this tip! The footnotes have appeared. (It partially solved my problem of references showing as "?" and no footnote.) I voted for this bug in hopes they will keep working on a fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

It's now the end of 2020 and this bug is still severely affecting my work. Random footnotes disappear when using the Book export function. It means that my workflow is slowed down to a crawl while I re-check files that have been edited and approved multiple times. It's a serious bug and severely undermining my confidence in InDesign. I use Indesign 15.1.2 with Mac High Sierra 10.13.6. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

The best work-around is to export as separate files, but that is a backwards step when working with publishing houses. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard

Copied

It's January 2021 and I'm also having this problem. Adobe, you've got thousands of my dollars at this point. Fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard

Copied

To those of us frustrated with the disappearing footnote issue, may I
suggest that we start asking Adobe for a partial refund for what we are
paying for InDesign as part of Creative Cloud. The footnote issue can't be
that hard to fix. When Adobe starts taking a financial hit perhaps they
will prioritize this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard

Copied

That's an excellent idea. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2021 Jan 17, 2021

Copy link to clipboard

Copied

I've found that if I open "Document Footnote Options" from the Type Menu and change the numbering style the footnotes reappear. I keep the Preview box checked and make a change ... footnotes reappear, and I then click Cancel or change the setting back. There's no need to implement the change. Typically I check the "Restart Numbering Every" checkbox, the footnotes reappear, then I uncheck the box, and close the options window. It's very annoying but seems to occur in files that are part of a book that has had pagination changes elsewhere in the book.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

The fix for this issue is now available in the latest update of InDesign—version 16.1

Please update to this version to get the fix. To prevent problem on existing documents and see the footnotes again, you will have to force recompose the stories. To force recompose stories, you can use the shortcut Command-Option-/ (slash) on Mac or Ctrl-Alt-slash on Windows.

 

—InDesign Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

LATEST

I have tried all the suggestions here but I still can't get my endnotes and references to reappear. Every time I try to work with the Endnote options the file crashes. I'm using InDesign 17.0.1 for Mac, running OS Big Sur 11.6.2.

 

Exporting the .indd file to .idml format stops the crashing, but all the references are replaced with <?>. Adobe support suggested changing the font to force them to reappear but that didn't work. 

 

I also tried the Recompose command+option+/ (slash) and that didn't work.

 

I unsuccessfully tried exporting the text to various formats hoping the endnotes would show up and I could at least copy and paste the text.

 

Any and all suggestions welcome!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines