Don't crop artwork imported form Ai

New Here ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

Hi there. When trying to import artworks from Ai to Id they are automatically cropped to the Id page format. (I do that in order to combine master elements applied in all pages to already created artworks from Ai)

What I need to do is to keep bleed from Ai so as to export printable pdf. It is impossible to do so with the cropped bleed. Any ideas? Thanks for helping.

TOPICS
How to , Import and export , Print

Views

148

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

When you place your AI file, select Show Import Options. From there you can select the Bleed crop box.

Keep in mind that this will affect your future PDF placement too. 

image.png

image.png

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

Hmm, the problem is that I have used the multi-page PDF script and there are no import options...

Also, even when placing Ai with bleed selected the artwork seems to be shrunk to fit the Id page size.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

Sorry I see now that with bleed or art or media the artwork is always cropped no matter what option selected

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I think the script uses the last set of options used when you manually place a PDF (those settings are sticky), so you might want to try setting the options in the Place dialog and actually placing a page manually ina another document before running the script.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

The problem is that I still cannot place uncropped artwork. What I am trying to achieve is to import artwork from Ai to Id while the artboard and page have the same size - but I need to keep the bleed outside the artboard because I want to have it printed. I have tried this with all place attributed incuding bleed but the artwork is always cropped. See below; the black outline is cropped. Thanks for helping.Screenshot 2021-12-15 133733.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Can you show us a screen capture of the crop options you have set in the InDesign Place dialog, please.

Based on what you've shown us above and some quick experimentation, the correct setting to import the bleed would be Bleed, Media, or one of the  Bounding Box options. All three worked as expected and gave me the full bleed PDF.

As this is not working for you, are you sure you are including document bleed under marks and bleeds in the save dialog? You've shown us the .ai capture, but not the PDF created from it.

I did my test .ai file by creating a solid field the size of the artboard, then adding two contrasting stripes (horizontal and vertical) extending out to the bleed so I could easily see if they were cropped off by the presence or lack of white space around the edge next to the stripes.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Maybe the problem is that I don't import pdf but .ai?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

There is literally no difference in that import.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Maybe that was the issue. With pdf placement and bleed or media crop selected I get the bleed correctly. I also had to uncheck 'facing pages' in doc setup. One more issue: is there an option to place art centered on each page? I think I have seen this option somewhere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

It still isn't clear if you are able to import a single page correctly.

Also, what script are you using? I'm not able to run Mike Edel's new version of MultiPageImporter.jsx, which is the only script I'm aware of that can import multipage .ai.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I use PlaceMultipagePDF. Yes I can import now both single or multi pages correctly. It might be something wrong in saving from Ai. I am just looking for a way to place art centered, otherwise I will have to center all pages manually ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I just tested the script and it places the AI artboard at XY 0,0, so your bleeds won’t matchup. You could edit the code so the place point is minus the bleed amount. Change line 110 to this where the bleed amount is .125":

 

app.scriptPreferences.measurementUnit = MeasurementUnits.INCHES
myPDFPage = myPage.place(File(myPDFFile), [-.125,-.125])[0];

 

Or code could be added to center the placed artboard.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Adding this should center the artboard after it’s placed at 0,0

 

//line 110
myPDFPage = myPage.place(File(myPDFFile), [0,0])[0];

//add this below
myDocument.zeroPoint = [0, 0];
var pf = myPDFPage.parent.geometricBounds
var pb = myPage.bounds;
var xoff = (pb[3]-pb[1])-(pf[3]-pf[1]);
var yoff = (pb[2]-pb[0])-(pf[2]-pf[0]);
myPDFPage.parent.move([xoff*.5,yoff *.5])

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

quote

I have tried this with all place attributed incuding bleed but the artwork is always cropped.

 

If that's a true statement, the next thing to try is resetting preferences.

https://community.adobe.com/t5/indesign/reset-indesign-preferences-and-other-troubleshooting/td-p/11...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

LATEST

Thanks everyone for your help... I placed it page-by-page eventually because PlaceMultipagePDF when placing new artwork automatically erased all page titles etc created with Id even though I used different layers. So I had to do it manually and then align art one-by-one with alignment tool (x-y).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Hi @opkathens , If you are using the PlaceMultipagePDF script from the ID Sample scripts folder? It sets the crop to media, so that would override the stickiness of the place options setting.

 

You could edit the script, in a plain text editor or ExtendScript toolkit. Line 102 is this:

 

 

app.pdfPlacePreferences.pdfCrop = PDFCrop.cropMedia;

 

 

try editing to this:

 

 

app.pdfPlacePreferences.pdfCrop = PDFCrop.CROP_BLEED;

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines