• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Dotted cell stroke start/end offset and related issues

Engaged ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Hi,

I am having an issue with the cell stroke in a table set to dots and how it interacts with the table border.

1- I have set the Stroke Drawing Order for the table to Draw Row Strokes in Front. I have selected the default dotted stroke for the cell, with gap colour set to none. Yet, as you can see in the image, the first dot right on the table border shows a white background, not the table's black border.

cellstrokeissue.jpg

2- If I select Column Strokes in Front for the table, then the row's stroke first dot starts to the right of the table border, not on top of the table border as on the previous picture.

3- I tried to create a custom dotted stroke but that always starts with a dot that cannot be removed. Is there a way to make it start with a gap?

4- What I would like is something similar to #1 but with the fill around the first dot being none, so that the black table border shows through! I thought that would be the expected behaviour with the chosen settings.

 

This is for CS4.

Thanks.

TOPICS
Bug , How to

Views

299

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 08, 2023 Nov 08, 2023

I would say it's a bug....

 

Votes

Translate

Translate
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Have you tried Best Joins? Have you tried Overprint on? Are you building your table using cell styles? Why CS4 from the year 2008?

I always let the cell styles borders apply and override the view of the table border.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I don't know what controls and options are available in CS4, but the general order is that all cell styles apply over all table styles, so the dotted cell stroke appearing to overwrite the table border is... correct. You may need to set the cell borders to different stroke types to avoid this, and may need multiple cell styles to get the exact combination you want.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I would say it's a bug....

 

▒► ID-Tasker - "Industrial Revolution" is finally here ◄▒

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I think it's ID doing its best to sort out the combining rules. That the dotted line has a white background... I'd have to experiment to see where that shows. Could be closer to bug than intended rendering, but with a 15yo version... hard to say.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

RobertTkaczyk_0-1699486952623.png

 

 

▒► ID-Tasker - "Industrial Revolution" is finally here ◄▒

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

LATEST

Hi Robert,

Exactly what I see too. If I apply a gap colour to the cell row border, the right half of the area around the dot on the table's border (first dot) has the correct background but the other half (on its left), doesn't, like in your image. If I apply "none" as the background colour to the cell, then both areas around the first dot are white, instead of no colour. I am also leaning towards a bug. Is this still a bug in the current version of ID?

 

So if I set the colour of the gap to be none, the area around the first dot seems to be white, not "colour none".

 

Mike. I have tried other Stroke Drawing Order for the table, as indicated in my post. For example, with "Column Strokes in Front" for the table, then the row's stroke first dot starts to the right of the table border, not on top of the table border as on the picture in my post. This was explained in item #2 in my post, which led to item #3 (open question).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines