• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

DropCap whin using indent left

New Here ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

I notice, whin I set a paragraph left indent, and I use drop cap, the drop cap gets an extra indent.

If I counter balance the drop cap by using a negative first line indent, the second line does not line up with the upper line.

Can anyone please tell me how to correct this?

See attached screenshots

TOPICS
How to , Type

Views

686

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Mar 01, 2023 Mar 01, 2023

I just went to check on this issue on the Bugs page and sure enough, it has come up.

Sooooooo... there's a new preference in v18 under Composition (which is checked by default) which is causing this.

Screen Shot 2023-03-02 at 12.06.35 AM.png

It's being investigated, as the preference was not intended to do this, so it's a bug.

In the meantime, if you uncheck  the "Honor text indents..." the problem goes away. But then, that undoes what the preference is supposed to fix, so that ain't good.

Votes

Translate

Translate
Community Expert , Mar 02, 2023 Mar 02, 2023

Any NEW text you create will be fine.

Existing text won't change until you "recompose"...  (command-option-/) [Mac] (ctrl-alt-/) [Windows]).

Even doing a minor edit, or resizing a text frame, will do it.

 

Votes

Translate

Translate
Community Expert , Mar 02, 2023 Mar 02, 2023

It's not a well known key command. ID normally recomposes automatically whenever anything is "moved/touched/edited" in any way. The key command simply forces it.

 

Votes

Translate

Translate
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

You might consider making a paragraph style that has 0 indent along with defining the drop cap. If you want the letter to stick out a bit more, apply the Type > Story attribute to the textframe carrying the drop-capped text. Story causes things to outdent a bit in orde to give a better optical feel to the alignment.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

If you want the drop cap the align with the left margin give the paragraph no first line indent and no left margin. If you want the drop cap to hang outside the margin make the drop cap length two characters, add a space at the beginning of the paragraph before the drop cap, then kern the drop cap into the space.

Screenshot 2023-03-01 at 7.33.03 PM.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

This appears to be a bug in v18. It works properly in previous versions. I tried v16 and v17 and could not reproduce the problem. Also, I OPENED a file created in v16 with v18 and the problem goes away, both on the existing text from the saved file and any new text block created.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Fun fact: I saved a v18 file with the screwed up alignment as an IDML file and opened it in older versions, and the alignment problem goes away.

Screen Shot 2023-03-01 at 11.50.10 PM.png

Screen Shot 2023-03-01 at 11.49.48 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

I just went to check on this issue on the Bugs page and sure enough, it has come up.

Sooooooo... there's a new preference in v18 under Composition (which is checked by default) which is causing this.

Screen Shot 2023-03-02 at 12.06.35 AM.png

It's being investigated, as the preference was not intended to do this, so it's a bug.

In the meantime, if you uncheck  the "Honor text indents..." the problem goes away. But then, that undoes what the preference is supposed to fix, so that ain't good.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Thank you

I tried unchecing "Honor text indents..." it didnot fix the problem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Any NEW text you create will be fine.

Existing text won't change until you "recompose"...  (command-option-/) [Mac] (ctrl-alt-/) [Windows]).

Even doing a minor edit, or resizing a text frame, will do it.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Oh! Thank you very much. I didn't know that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

LATEST

It's not a well known key command. ID normally recomposes automatically whenever anything is "moved/touched/edited" in any way. The key command simply forces it.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines