Englisch/Hebrew mixed text

Community Beginner ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

Hi All,

I need help with my InDesign. I am working with InDesign CS 6 ME Cloud Version. I have some mixed text, most of it is German but words (one or more) are Hebrew. I first made a test, a page imported from Word. And surprise, some word were in the correct order, other with an inverted order. Inside the word (the letters) everything was OK.

You can see in the following pictures, first in Word (which is the original text) an then the InDesign. As you can see in the InDesign picture, the green text has the same (reading) order as in Word, but the red ones are in inverted order.

The font is Times New Roman, Paragraph Style is set to Adobe World Ready Paragraph Composer, Paragraph Direction: Left to Right; Hebrew words have a Character Style with Character Direction: Right to Left. Still ...

word_hebrew.png

indd_hebrew.png

What am I doing wrong? And if so, why some words are in the correct order and others are not? What should I do (what settings should I use) to have all OK?

Thank you for all the help you can provide!

Your,

Dan

Views

4.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Mar 07, 2017 Mar 07, 2017
Hmmm. Looks like it is time for שחרית …There are several issues here which complicate things and you aren't the only one to experience these anomalies!  The first is that you are importing from Microsoft Word as opposed to entering directly in InDesign. Not that this wrong in any way, but there may be some control characters that are being misinterpreted in the import process.Secondly, any text in InDesign that has any right-to-left text (such as Hebrew, Arabic, or Farsi) needs to be formatted w...

Likes

Translate

Translate
Valorous Hero ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

There is a setting in InDesign called "character direction." Make sure that it is set to "default" and not left-to-right.

Edit: Ah, I see you mention character direction already. Well, make sure that the spaces also have a "default" character direction.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

Hmmm. Looks like it is time for שחרית …

There are several issues here which complicate things and you aren't the only one to experience these anomalies! 

The first is that you are importing from Microsoft Word as opposed to entering directly in InDesign. Not that this wrong in any way, but there may be some control characters that are being misinterpreted in the import process.

Secondly, any text in InDesign that has any right-to-left text (such as Hebrew, Arabic, or Farsi) needs to be formatted with the Adobe World-Ready Paragraph Composer. This must be set in the Justification panel of the paragraph styles.

Thirdly, InDesign attempts to be smart, maybe way too smart when handling text that is a mixture or left-to-right and right-to-left as you have above. Character such a spaces (or even worse special spaces), punctuation, digits, etc. may cause the layout to attempt to switch between right-to-left and left-to-right inexplicably. What I found that solves the problem (in addition to using the World-Ready Composer) is to explicitly tag the Hebrew text with a text direction of right-to-left. This can be set for the particular text by selecting the text in question and using the menu on the top-right of the screen for special character formatting and selecting Character Direction => Right-to-Left.

          - Dov

- Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2022 Feb 13, 2022

Copy link to clipboard

Copied

LATEST

Dear Dov,

 

I have a PDF in Ivrit and tried to export it to MS Word.  Acrobat successfully converted the document format and the lettets, but the document is typed backwards!  Any suggestions, please?

 

Regards,

 

Meir

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

I would agree with Dov: sometimes InDesign tries to be too smart, especially with assigning direction to spaces (and tabs) contextually. It drives me batty when I am working on twenty-language jobs. I have two pieces of advice for you:

1) Instead of a Right-to-Left character style, I would typically use a character style that assigns Hebrew as a language, and then use Default character direction. There are lots of reasons to do this, but in general I would try language settings first, and then only force direction if more gentle methods didn't work.

2) But sometimes you have to brute-force it. This is especially true if your Hebrew text is surrounded by character types to which InDesign likes to automagically assign direction. The slash and the tab character that you are using for your dotted leader are two such characters. I would make new character styles that only apply RtL or LtR behavior and apply them to direction-neutral glyphs and whitespace surrounding your Hebrew text as necessary. I do this so often that my generic Arabic template has zero-width non-joiners styled with these character styles off in the pasteboard so I can grab them and insert them as necessary.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 21, 2017 Mar 21, 2017

Copy link to clipboard

Copied

Hi All,

Thank you for your help and please excuse the delay to me answering your posts. In the end I was able to solve the problem by editing the XML behind the  DOCX Word file (fortunately it was a DOCX) and tagging in this XML each Hebrew word and space. Then I imported the DOCX file and with grep applied a Character Style with language settings on Hebrew and Character Direction on Default.

Again,

Thank you!

Dan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2019 May 24, 2019

Copy link to clipboard

Copied

Very helpful - hard to find that Paragraph Style information!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines